Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести значение из объединенной ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести значение из объединенной ячейки (Формулы/Formulas)
Вывести значение из объединенной ячейки
Jebox Дата: Вторник, 28.12.2021, 15:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

здравствуйте, как можно, через формулы вывести значения из объединенных ячеек по совпадению из соседнего столба?
наткнулся на аналогичную тему, http://www.excelworld.ru/forum/2-1458-1 , но не получается правильно ее применить.

Например:
- необходимо вывести значение из ячейки А2, по критерию Квартальный проезд, д.2А,
но т.к., ячейка А2 - имеет пустое значение (т.к. диапазон A1:A6 объединен), значение выводится соответственно пустое

в таблице много названий улиц, и объединенный столбец будет иметь разное значение для каждого определенно списка улиц
К сообщению приложен файл: 5052227.xlsx(9.2 Kb)


Сообщение отредактировал Serge_007 - Вторник, 28.12.2021, 15:47
 
Ответить
Сообщениездравствуйте, как можно, через формулы вывести значения из объединенных ячеек по совпадению из соседнего столба?
наткнулся на аналогичную тему, http://www.excelworld.ru/forum/2-1458-1 , но не получается правильно ее применить.

Например:
- необходимо вывести значение из ячейки А2, по критерию Квартальный проезд, д.2А,
но т.к., ячейка А2 - имеет пустое значение (т.к. диапазон A1:A6 объединен), значение выводится соответственно пустое

в таблице много названий улиц, и объединенный столбец будет иметь разное значение для каждого определенно списка улиц

Автор - Jebox
Дата добавления - 28.12.2021 в 15:45
bigor Дата: Вторник, 28.12.2021, 16:08 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
Здравствуйте
Пробуйте
Код
=INDEX(LOOKUP(ROW($A$1:$A$7);ROW($A$1:$A$7)/($A$1:$A$7>0);($A$1:$A$7));MATCH(A10;$B$1:$B$6;0))
массивная
 
Ответить
СообщениеЗдравствуйте
Пробуйте
Код
=INDEX(LOOKUP(ROW($A$1:$A$7);ROW($A$1:$A$7)/($A$1:$A$7>0);($A$1:$A$7));MATCH(A10;$B$1:$B$6;0))
массивная

Автор - bigor
Дата добавления - 28.12.2021 в 16:08
Jebox Дата: Вторник, 28.12.2021, 18:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

огромное спасибо, работает,

а если будет несколько совпадений по названию, и соответственно несколько результатов, их можно как то отфильтровать?
например, есть Ленина в 30 и в 90 (или даже больше совпадений..), он выведет только первое,

необходимо например, проверить условие по дополнительному столбцу.. (даже по нескольким столбцам, т.е. несколько условий),
чтобы, значение было "да", и вывести первый результат, где "да" ..

К сообщению приложен файл: 0555128.jpg(18.8 Kb)


Сообщение отредактировал Serge_007 - Среда, 29.12.2021, 09:00
 
Ответить
Сообщениеогромное спасибо, работает,

а если будет несколько совпадений по названию, и соответственно несколько результатов, их можно как то отфильтровать?
например, есть Ленина в 30 и в 90 (или даже больше совпадений..), он выведет только первое,

необходимо например, проверить условие по дополнительному столбцу.. (даже по нескольким столбцам, т.е. несколько условий),
чтобы, значение было "да", и вывести первый результат, где "да" ..


Автор - Jebox
Дата добавления - 28.12.2021 в 18:53
Jebox Дата: Вторник, 28.12.2021, 20:14 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Я правильно делаю? Только, мне необходимо, проверять не конкретное значение, а наличие куска слова, при использовании "*СЛОВО*", формула не работает..

Цитата
=ИНДЕКС(ПРОСМОТР(СТРОКА($A$1:$A$11);СТРОКА($A$1:$A$11)/($A$1:$A$11>0);($A$1:$A$11));ПОИСКПОЗ(A13&B13;$B$1:$B$11&$C$1:$C$11;0))
 
Ответить
СообщениеЯ правильно делаю? Только, мне необходимо, проверять не конкретное значение, а наличие куска слова, при использовании "*СЛОВО*", формула не работает..

Цитата
=ИНДЕКС(ПРОСМОТР(СТРОКА($A$1:$A$11);СТРОКА($A$1:$A$11)/($A$1:$A$11>0);($A$1:$A$11));ПОИСКПОЗ(A13&B13;$B$1:$B$11&$C$1:$C$11;0))

Автор - Jebox
Дата добавления - 28.12.2021 в 20:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести значение из объединенной ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!