Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Достать данные через ГПР с использование объединенной ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Достать данные через ГПР с использование объединенной ячейки (Формулы/Formulas)
Достать данные через ГПР с использование объединенной ячейки
itm Дата: Среда, 29.12.2021, 20:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток, столкнулся с проблемой, не понимаю как вытащить данные через гпр и объединенную ячейку. В файле лист "!САМ" из которого берутся данные и переносятся в лист "!сводная таблица". Но через функцию гпр возможно вытащить данные только из первого столбца - С НДФЛ. Вопрос: как достать данные из второго столбца - без НДФЛ. Внутри файла я более подробно описал.
К сообщению приложен файл: KPI_.xlsx(57.4 Kb)
 
Ответить
СообщениеДоброго времени суток, столкнулся с проблемой, не понимаю как вытащить данные через гпр и объединенную ячейку. В файле лист "!САМ" из которого берутся данные и переносятся в лист "!сводная таблица". Но через функцию гпр возможно вытащить данные только из первого столбца - С НДФЛ. Вопрос: как достать данные из второго столбца - без НДФЛ. Внутри файла я более подробно описал.

Автор - itm
Дата добавления - 29.12.2021 в 20:50
gling Дата: Среда, 29.12.2021, 21:05 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Здравствуйте.
Думаю что ГПР() - неудачный выбор. Попробуйте ИНДЕКС() и ПОИСКПОЗ()
Код
=ИНДЕКС(САМ!$B$4:$U$15;1;ПОИСКПОЗ('Сводная таблица'!$B$2;САМ!$B$2:$U$2;0))
Код
=ИНДЕКС(САМ!$B$4:$U$15;1;ПОИСКПОЗ('Сводная таблица'!$B$2;САМ!$B$2:$U$2;0)+1)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Думаю что ГПР() - неудачный выбор. Попробуйте ИНДЕКС() и ПОИСКПОЗ()
Код
=ИНДЕКС(САМ!$B$4:$U$15;1;ПОИСКПОЗ('Сводная таблица'!$B$2;САМ!$B$2:$U$2;0))
Код
=ИНДЕКС(САМ!$B$4:$U$15;1;ПОИСКПОЗ('Сводная таблица'!$B$2;САМ!$B$2:$U$2;0)+1)

Автор - gling
Дата добавления - 29.12.2021 в 21:05
itm Дата: Четверг, 30.12.2021, 14:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Супер, спасибо!
 
Ответить
СообщениеСупер, спасибо!

Автор - itm
Дата добавления - 30.12.2021 в 14:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Достать данные через ГПР с использование объединенной ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!