Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение таблицы по по анализу содержания строковых ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение таблицы по по анализу содержания строковых ячеек (Формулы/Formulas)
Заполнение таблицы по по анализу содержания строковых ячеек
Sergey3976 Дата: Понедельник, 03.01.2022, 19:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Есть столбец с перечислением данных/названий в виде строки (в одной строке может быть несколько названий с разными разделительными знаками или пробелом), и столбец с соответствующим числом, приходящимся на эти данные. Также создана таблица столбцов, каждый из которых содержит отдельное название (совпадающее с вписанными названиями в текстовую ячейку). Нужно с помощью формулы проанализировать строку ячейки на содержание конкретного названия и если название присутствует, то число соответствующего столбца из исходной таблицы поставить в столбец новой таблицы с данным названием.
Как я это вижу?
1. Для каждой ячейки мы заведомо знаем название. Следовательно анализируем соответствующую строку ячейки исходной таблицы и ищем в ней нужное название.
2. В случае удачи из второго столбца копируем в нашу новую ячейку число. В случае неудачи ничего не копируем/оставляем ячейку пустой.
Пояснение: В случае нахождения в строке нескольких названий, копируем число в каждый соответствующий столбец (это будет само собой делаться, просто для понимания)
Прежде всего, конечно, вопрос, как вычленить из строки нужную подстроку, т.е. провести сравнение на наличие подстроки?
Файл-пример прикрепил.
К сообщению приложен файл: _3.xlsx(8.8 Kb)


Сообщение отредактировал Sergey3976 - Понедельник, 03.01.2022, 19:12
 
Ответить
СообщениеДобрый день! Есть столбец с перечислением данных/названий в виде строки (в одной строке может быть несколько названий с разными разделительными знаками или пробелом), и столбец с соответствующим числом, приходящимся на эти данные. Также создана таблица столбцов, каждый из которых содержит отдельное название (совпадающее с вписанными названиями в текстовую ячейку). Нужно с помощью формулы проанализировать строку ячейки на содержание конкретного названия и если название присутствует, то число соответствующего столбца из исходной таблицы поставить в столбец новой таблицы с данным названием.
Как я это вижу?
1. Для каждой ячейки мы заведомо знаем название. Следовательно анализируем соответствующую строку ячейки исходной таблицы и ищем в ней нужное название.
2. В случае удачи из второго столбца копируем в нашу новую ячейку число. В случае неудачи ничего не копируем/оставляем ячейку пустой.
Пояснение: В случае нахождения в строке нескольких названий, копируем число в каждый соответствующий столбец (это будет само собой делаться, просто для понимания)
Прежде всего, конечно, вопрос, как вычленить из строки нужную подстроку, т.е. провести сравнение на наличие подстроки?
Файл-пример прикрепил.

Автор - Sergey3976
Дата добавления - 03.01.2022 в 19:11
Pelena Дата: Среда, 05.01.2022, 10:23 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18233
Репутация: 4096 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
В соответствии с примером
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(";"&C$2&";";";"&$A3&";"));$B3;"")
К сообщению приложен файл: 0059330.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
В соответствии с примером
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(";"&C$2&";";";"&$A3&";"));$B3;"")

Автор - Pelena
Дата добавления - 05.01.2022 в 10:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение таблицы по по анализу содержания строковых ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!