Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление вверх по заданному списку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление вверх по заданному списку (Формулы/Formulas)
Округление вверх по заданному списку
GP75 Дата: Суббота, 08.01.2022, 20:12 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте товарищи .
Есть ли возможность в экселе реализовать округление в большую сторону до значений, заданных в табличном списке? Пример в прикреплении.
К сообщению приложен файл: primer2020-01.xls(26.5 Kb)
 
Ответить
СообщениеЗдравствуйте товарищи .
Есть ли возможность в экселе реализовать округление в большую сторону до значений, заданных в табличном списке? Пример в прикреплении.

Автор - GP75
Дата добавления - 08.01.2022 в 20:12
DrMini Дата: Суббота, 08.01.2022, 20:53 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
округление в большую сторону до значений, заданных в табличном списке

Так:
Код
=ЕСЛИ(B2<=D2;D2;ЕСЛИ(B2<=D3;D3;ЕСЛИ(B2<=D4;D4;ЕСЛИ(B2<=D5;D5;ЕСЛИ(B2<=D6;D6;ЕСЛИ(B2<=D7;D7;ЕСЛИ(B2<=D8;D8;ЕСЛИ(B2<=D9;D9))))))))

или так:
Код
=ЕСЛИМН(B2<=D2;D2;B2<=D3;D3;B2<=D4;D4;B2<=D5;D5;B2<=D6;D6;B2<=D7;D7;B2<=D8;D8;B2<=D9;D9)

[p.s.]функция ЕСЛИМН() работает в excel 2016 +[/p.s.]
 
Ответить
Сообщение
округление в большую сторону до значений, заданных в табличном списке

Так:
Код
=ЕСЛИ(B2<=D2;D2;ЕСЛИ(B2<=D3;D3;ЕСЛИ(B2<=D4;D4;ЕСЛИ(B2<=D5;D5;ЕСЛИ(B2<=D6;D6;ЕСЛИ(B2<=D7;D7;ЕСЛИ(B2<=D8;D8;ЕСЛИ(B2<=D9;D9))))))))

или так:
Код
=ЕСЛИМН(B2<=D2;D2;B2<=D3;D3;B2<=D4;D4;B2<=D5;D5;B2<=D6;D6;B2<=D7;D7;B2<=D8;D8;B2<=D9;D9)

[p.s.]функция ЕСЛИМН() работает в excel 2016 +[/p.s.]

Автор - DrMini
Дата добавления - 08.01.2022 в 20:53
GP75 Дата: Суббота, 08.01.2022, 21:08 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо. Работает! Про функцию ЕСЛИ думал (правда не со столькими неизвестными). Предполагал, что есть какая увязка с "Данные" "Список"
 
Ответить
СообщениеСпасибо. Работает! Про функцию ЕСЛИ думал (правда не со столькими неизвестными). Предполагал, что есть какая увязка с "Данные" "Список"

Автор - GP75
Дата добавления - 08.01.2022 в 21:08
Egyptian Дата: Суббота, 08.01.2022, 21:18 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 375
Репутация: 127 ±
Замечаний: 0% ±

Excel 2013/2016
Можно так:
Код
=INDEX($D$2:$D$9;MATCH(TRUE;INDEX((B2<=$D$2:$D$9););))
 
Ответить
СообщениеМожно так:
Код
=INDEX($D$2:$D$9;MATCH(TRUE;INDEX((B2<=$D$2:$D$9););))

Автор - Egyptian
Дата добавления - 08.01.2022 в 21:18
bmv98rus Дата: Суббота, 08.01.2022, 21:25 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3943
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
для примера подойдет и
Код
=CEILING(B2;0.05)

ну и варианты
Код
=LOOKUP(B2+0.05;D2:D9)

Код
=INDEX(D2:D10;MATCH(B2;D1:D9))

Код
=INDEX(D1:D9;1+MATCH(B2;D1:D9))
К сообщению приложен файл: example2564.xlsx(9.1 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 08.01.2022, 21:35
 
Ответить
Сообщениедля примера подойдет и
Код
=CEILING(B2;0.05)

ну и варианты
Код
=LOOKUP(B2+0.05;D2:D9)

Код
=INDEX(D2:D10;MATCH(B2;D1:D9))

Код
=INDEX(D1:D9;1+MATCH(B2;D1:D9))

Автор - bmv98rus
Дата добавления - 08.01.2022 в 21:25
GP75 Дата: Суббота, 08.01.2022, 21:25 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое!!. Тоже хороший вариант .
 
Ответить
СообщениеСпасибо большое!!. Тоже хороший вариант .

Автор - GP75
Дата добавления - 08.01.2022 в 21:25
GP75 Дата: Суббота, 08.01.2022, 21:26 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Варинты идентичны, или могут быть различия?
 
Ответить
СообщениеВаринты идентичны, или могут быть различия?

Автор - GP75
Дата добавления - 08.01.2022 в 21:26
GP75 Дата: Суббота, 08.01.2022, 22:01 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
в примере поюзал, да, есть различия, последний вариант наверное самый удачный с округлением до 0,05.
Ещё раз всем спасибо!
 
Ответить
Сообщениев примере поюзал, да, есть различия, последний вариант наверное самый удачный с округлением до 0,05.
Ещё раз всем спасибо!

Автор - GP75
Дата добавления - 08.01.2022 в 22:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление вверх по заданному списку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!