Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество уникальных буквенно-цифровых значений по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество уникальных буквенно-цифровых значений по условию (Формулы/Formulas)
Количество уникальных буквенно-цифровых значений по условию
striffe Дата: Воскресенье, 09.01.2022, 21:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!
Не могу понять ошибку в своей формуле. Есть список заявок нескольких условных подразделений (столбец А), т.к. подразделение может подать несколько заявок, формируется столбец С с уникальными номерами. Нужно подсчитать количество уникальных подразделений в столбце С и вывести в столбец F.
К примеру вот заявок у подразделения СМ - одна, у ССД - три и т.д., но почему то считает не правильно. По идее нужно задать условие, чтобы выбирались значения по содержащимся в них буквам, но вместе с тем надо что бы не путались значения С-1 и ССД-1, т.к. Excel при поиске С выдаст как и "С" так и "ССД". Так же необходимо исключить подсчет повторяющихся в столбце С.
К сообщению приложен файл: 8104106.xls(29.5 Kb)


Сообщение отредактировал striffe - Воскресенье, 09.01.2022, 22:00
 
Ответить
СообщениеДобрый вечер!
Не могу понять ошибку в своей формуле. Есть список заявок нескольких условных подразделений (столбец А), т.к. подразделение может подать несколько заявок, формируется столбец С с уникальными номерами. Нужно подсчитать количество уникальных подразделений в столбце С и вывести в столбец F.
К примеру вот заявок у подразделения СМ - одна, у ССД - три и т.д., но почему то считает не правильно. По идее нужно задать условие, чтобы выбирались значения по содержащимся в них буквам, но вместе с тем надо что бы не путались значения С-1 и ССД-1, т.к. Excel при поиске С выдаст как и "С" так и "ССД". Так же необходимо исключить подсчет повторяющихся в столбце С.

Автор - striffe
Дата добавления - 09.01.2022 в 21:56
gling Дата: Воскресенье, 09.01.2022, 22:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2311
Репутация: 605 ±
Замечаний: 0% ±

2010
Здравствуйте.
Не всё понял из вашей формулы, написал другую, а вдруг угадал, что вы хотите.
Код
=СУММПРОИЗВ(МАКС(($A$2:$A$20=E2)*$B$2:$B$20))
К сообщению приложен файл: 4999989.xls(32.0 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 09.01.2022, 22:25
 
Ответить
СообщениеЗдравствуйте.
Не всё понял из вашей формулы, написал другую, а вдруг угадал, что вы хотите.
Код
=СУММПРОИЗВ(МАКС(($A$2:$A$20=E2)*$B$2:$B$20))

Автор - gling
Дата добавления - 09.01.2022 в 22:23
striffe Дата: Воскресенье, 09.01.2022, 22:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

gling, Вроде подошло) спасибо, только бы понять ее логику, особенно *, с виду то формула простая, короткая)
 
Ответить
Сообщениеgling, Вроде подошло) спасибо, только бы понять ее логику, особенно *, с виду то формула простая, короткая)

Автор - striffe
Дата добавления - 09.01.2022 в 22:54
gling Дата: Воскресенье, 09.01.2022, 23:15 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2311
Репутация: 605 ±
Замечаний: 0% ±

2010
особенно *

Если что, так пишет знак умножить Excel.


ЯД-41001506838083
 
Ответить
Сообщение
особенно *

Если что, так пишет знак умножить Excel.

Автор - gling
Дата добавления - 09.01.2022 в 23:15
striffe Дата: Воскресенье, 16.01.2022, 21:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Понятно, скажите, а если к примеру задача стоит такая: подсчитать кол-во уникальных значений в столбце L в соответствии со значениями в столбцах O и Р и занести их в Т и U.
причем обязательно в диапазоне надо учесть якобы пустую строку 21. Начинаю с базовой формулы как в Т6, и уже на этом этапе она не работает, а нужно еще добавить условие что учитывать только те значения у которых статус:Переходящий.
К сообщению приложен файл: -_.xls(30.5 Kb)
 
Ответить
СообщениеПонятно, скажите, а если к примеру задача стоит такая: подсчитать кол-во уникальных значений в столбце L в соответствии со значениями в столбцах O и Р и занести их в Т и U.
причем обязательно в диапазоне надо учесть якобы пустую строку 21. Начинаю с базовой формулы как в Т6, и уже на этом этапе она не работает, а нужно еще добавить условие что учитывать только те значения у которых статус:Переходящий.

Автор - striffe
Дата добавления - 16.01.2022 в 21:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество уникальных буквенно-цифровых значений по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!