Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ПРОМЕЖУТОЧНЫЕ.ИТОГИ с подсчётом только положительных чисел - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПРОМЕЖУТОЧНЫЕ.ИТОГИ с подсчётом только положительных чисел (Формулы/Formulas)
ПРОМЕЖУТОЧНЫЕ.ИТОГИ с подсчётом только положительных чисел
DrMini Дата: Вторник, 11.01.2022, 09:46 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 834
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток форумчане и гости форума.
Подскажите, как объединить две формулы в одну:
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;B1:B4)
ошибся малость.
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;B1:B4)
и
Код
=СУММЕСЛИ(B1:B4;">0")

Нужно подсчитать только положительные значения пропуская отрицательные, при возможности скрытия строк которые в итоговой сумме не будут учитываться.
К сообщению приложен файл: 220111_0.xlsx(8.9 Kb)


Сообщение отредактировал DrMini - Вторник, 11.01.2022, 10:15
 
Ответить
СообщениеДоброго времени суток форумчане и гости форума.
Подскажите, как объединить две формулы в одну:
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;B1:B4)
ошибся малость.
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;B1:B4)
и
Код
=СУММЕСЛИ(B1:B4;">0")

Нужно подсчитать только положительные значения пропуская отрицательные, при возможности скрытия строк которые в итоговой сумме не будут учитываться.

Автор - DrMini
Дата добавления - 11.01.2022 в 09:46
Serge_007 Дата: Вторник, 11.01.2022, 09:52 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15403
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Здравствуйте

как объединить две формулы в одну
Посмотрите здесь: http://forum.msexcel.ru/index.php/topic,12058.0.html (посты 9-11)

Нужно подсчитать только положительные значения пропуская отрицательные, при возможности скрытия строк которые в итоговой сумме не будут учитываться
Код
=СУММПРОИЗВ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;ДВССЫЛ("b"&СТРОКА(1:4))))*(B1:B4>0))
К сообщению приложен файл: 20220111_DrMini.xls(68.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

как объединить две формулы в одну
Посмотрите здесь: http://forum.msexcel.ru/index.php/topic,12058.0.html (посты 9-11)

Нужно подсчитать только положительные значения пропуская отрицательные, при возможности скрытия строк которые в итоговой сумме не будут учитываться
Код
=СУММПРОИЗВ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;ДВССЫЛ("b"&СТРОКА(1:4))))*(B1:B4>0))

Автор - Serge_007
Дата добавления - 11.01.2022 в 09:52
DrMini Дата: Вторник, 11.01.2022, 10:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 834
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Посмотрите здесь: http://forum.msexcel.ru/index.php/topic,12058.0.html (посты 9-11)

Спасибо за подсказку.
Пока разбирался, что такое "h" вот в этом куске
Код
ДВССЫЛ("h"&СТРОКА
Вы уже выдали готовое решение.
Serge_007, спасибо. всё работает.
 
Ответить
Сообщение
Посмотрите здесь: http://forum.msexcel.ru/index.php/topic,12058.0.html (посты 9-11)

Спасибо за подсказку.
Пока разбирался, что такое "h" вот в этом куске
Код
ДВССЫЛ("h"&СТРОКА
Вы уже выдали готовое решение.
Serge_007, спасибо. всё работает.

Автор - DrMini
Дата добавления - 11.01.2022 в 10:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПРОМЕЖУТОЧНЫЕ.ИТОГИ с подсчётом только положительных чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!