Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести все совпадения с условиями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести все совпадения с условиями (Формулы/Formulas)
Вывести все совпадения с условиями
Xenus91 Дата: Вторник, 18.01.2022, 07:32 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Помогите пжл получить список сотрудников которые не вышли на смену(указан "нн" в строках "отсутствия), и сотрудников которые присутствовали на смене в выбранную дату("фактические часы" в строках "факт часы") и по выбранному типу смены(указаны в строках "тип смены":"день" или "ночь")
дата и тип смены выбирается пользователем в ячейке Q2, P2
заранее огромное спасибо!
файл прилагаю
К сообщению приложен файл: 4611248.xlsx(23.0 Kb)
 
Ответить
СообщениеДоброго времени суток!
Помогите пжл получить список сотрудников которые не вышли на смену(указан "нн" в строках "отсутствия), и сотрудников которые присутствовали на смене в выбранную дату("фактические часы" в строках "факт часы") и по выбранному типу смены(указаны в строках "тип смены":"день" или "ночь")
дата и тип смены выбирается пользователем в ячейке Q2, P2
заранее огромное спасибо!
файл прилагаю

Автор - Xenus91
Дата добавления - 18.01.2022 в 07:32
Pelena Дата: Вторник, 18.01.2022, 07:58 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$148;АГРЕГАТ(15;6;(СТРОКА($B$2:$B$148)-1)/($P$2=ИНДЕКС($D$2:$K$148;0;ПОИСКПОЗ($Q$2;$D$1:$K$1;0)));СТРОКА(A1)));"")
К сообщению приложен файл: 2500105.xlsx(24.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$148;АГРЕГАТ(15;6;(СТРОКА($B$2:$B$148)-1)/($P$2=ИНДЕКС($D$2:$K$148;0;ПОИСКПОЗ($Q$2;$D$1:$K$1;0)));СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 18.01.2022 в 07:58
Xenus91 Дата: Вторник, 18.01.2022, 08:43 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Pelena, доброе утро!
Спасибо!
Посмотрел не учитывается тип смены сотрудников из P2, для тех кто не вышел на смену, забыл дописать...
и в присутствующих попадают те кто невышли
некорректно подал данные по тем кто с меткой нн, факт часы отсутствуют
прилагаю файл
К сообщению приложен файл: 5220082.xlsx(24.1 Kb)


Сообщение отредактировал Xenus91 - Вторник, 18.01.2022, 08:50
 
Ответить
СообщениеPelena, доброе утро!
Спасибо!
Посмотрел не учитывается тип смены сотрудников из P2, для тех кто не вышел на смену, забыл дописать...
и в присутствующих попадают те кто невышли
некорректно подал данные по тем кто с меткой нн, факт часы отсутствуют
прилагаю файл

Автор - Xenus91
Дата добавления - 18.01.2022 в 08:43
Pelena Дата: Вторник, 18.01.2022, 09:15 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Так?
К сообщению приложен файл: 6500192.xlsx(24.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТак?

Автор - Pelena
Дата добавления - 18.01.2022 в 09:15
Xenus91 Дата: Вторник, 18.01.2022, 09:22 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Pelena, да!
Огромное спасибо!
 
Ответить
СообщениеPelena, да!
Огромное спасибо!

Автор - Xenus91
Дата добавления - 18.01.2022 в 09:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести все совпадения с условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!