Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение номера квартала в зависимости от даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение номера квартала в зависимости от даты (Формулы/Formulas)
Определение номера квартала в зависимости от даты
mrjons Дата: Вторник, 25.01.2022, 10:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день
Возникла необходимость сделать так, чтобы ячейка сама определяла номер квартал в году в зависимости от конкретной даты.
Формулу я придумал, и она даже работает, но в силу ограниченных знаний в экселе не знаю как ее укоротить.
Код
=ЕСЛИ(И(A2>=ДАТА(ГОД(A2);1;1);A2<=ДАТА(ГОД(A2);3;31));1;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);4;1);A2<=ДАТА(ГОД(A2);6;30));2;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);7;1);A2<=ДАТА(ГОД(A2);9;30));3;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);10;1);A2<=ДАТА(ГОД(A2);12;31));4;))))
Подскажите пожалуйста варианты более компактные, спасибо
К сообщению приложен файл: _Microsoft_Exce.xlsx(9.0 Kb)


Сообщение отредактировал mrjons - Вторник, 25.01.2022, 12:12
 
Ответить
СообщениеДобрый день
Возникла необходимость сделать так, чтобы ячейка сама определяла номер квартал в году в зависимости от конкретной даты.
Формулу я придумал, и она даже работает, но в силу ограниченных знаний в экселе не знаю как ее укоротить.
Код
=ЕСЛИ(И(A2>=ДАТА(ГОД(A2);1;1);A2<=ДАТА(ГОД(A2);3;31));1;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);4;1);A2<=ДАТА(ГОД(A2);6;30));2;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);7;1);A2<=ДАТА(ГОД(A2);9;30));3;ЕСЛИ(И(A2>=ДАТА(ГОД(A2);10;1);A2<=ДАТА(ГОД(A2);12;31));4;))))
Подскажите пожалуйста варианты более компактные, спасибо

Автор - mrjons
Дата добавления - 25.01.2022 в 10:51
Serge_007 Дата: Вторник, 25.01.2022, 11:15 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15403
Репутация: 2536 ±
Замечаний: ±

Excel 2016


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеОпределение номера квартала по дате

Автор - Serge_007
Дата добавления - 25.01.2022 в 11:15
mrjons Дата: Вторник, 25.01.2022, 11:50 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Serge_007, спасибо большое
Я проверил варианты, и в случае, если ячейка, куда вводится дата, пуста, то во всех вариантах номер квартала ставиться 1, можно ли как-то обойти этот момент? Например пустое значение квартала, или как в моей формуле 0 стоит
 
Ответить
СообщениеSerge_007, спасибо большое
Я проверил варианты, и в случае, если ячейка, куда вводится дата, пуста, то во всех вариантах номер квартала ставиться 1, можно ли как-то обойти этот момент? Например пустое значение квартала, или как в моей формуле 0 стоит

Автор - mrjons
Дата добавления - 25.01.2022 в 11:50
Pelena Дата: Вторник, 25.01.2022, 12:00 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
mrjons, придумайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениеmrjons, придумайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума

Автор - Pelena
Дата добавления - 25.01.2022 в 12:00
mrjons Дата: Вторник, 25.01.2022, 12:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, готово
 
Ответить
СообщениеPelena, готово

Автор - mrjons
Дата добавления - 25.01.2022 в 12:13
Nic70y Дата: Вторник, 25.01.2022, 12:19 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(A2;ЦЕЛОЕ((МЕСЯЦ(A2)+2)/3);"")


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(A2;ЦЕЛОЕ((МЕСЯЦ(A2)+2)/3);"")

Автор - Nic70y
Дата добавления - 25.01.2022 в 12:19
mrjons Дата: Вторник, 25.01.2022, 12:40 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Nic70y, классный вариант, спасибо :)
 
Ответить
СообщениеNic70y, классный вариант, спасибо :)

Автор - mrjons
Дата добавления - 25.01.2022 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение номера квартала в зависимости от даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!