Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма значений одной даты в разных формах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма значений одной даты в разных формах (Формулы/Formulas)
Сумма значений одной даты в разных формах
svetochka2804061991 Дата: Среда, 26.01.2022, 12:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Приветики) нужна помощь!!! %) нужно посчитать металлы от одной даты учитывая его форму, ума не приложу как это сделать
Файл прикрепила)
К сообщению приложен файл: 0327325.xlsx(467.5 Kb)


Сообщение отредактировал svetochka2804061991 - Среда, 26.01.2022, 12:31
 
Ответить
СообщениеПриветики) нужна помощь!!! %) нужно посчитать металлы от одной даты учитывая его форму, ума не приложу как это сделать
Файл прикрепила)

Автор - svetochka2804061991
Дата добавления - 26.01.2022 в 12:29
Nic70y Дата: Среда, 26.01.2022, 12:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
svetochka2804061991, у вас файл в оригинале такой красивый и будет?
т.е.:
- даты по порядку
- форма подряд
или все в перемешку?


ЮMoney 41001841029809
 
Ответить
Сообщениеsvetochka2804061991, у вас файл в оригинале такой красивый и будет?
т.е.:
- даты по порядку
- форма подряд
или все в перемешку?

Автор - Nic70y
Дата добавления - 26.01.2022 в 12:34
svetochka2804061991 Дата: Среда, 26.01.2022, 12:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, все как в примере, по порядку
 
Ответить
СообщениеNic70y, все как в примере, по порядку

Автор - svetochka2804061991
Дата добавления - 26.01.2022 в 12:38
китин Дата: Среда, 26.01.2022, 12:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6898
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
PQ всемогущий
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"металл", type text}, {"дата ", type date}, {"форма", type text}}),
    #"Сгруппированные строки" = Table.Group(#"Измененный тип", {"дата ", "форма"}, {{"Количество металла", each Table.RowCount(Table.Distinct(_)), type number}})
in
    #"Сгруппированные строки"
[/vba]
К сообщению приложен файл: 1577431.xlsx(463.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеPQ всемогущий
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"металл", type text}, {"дата ", type date}, {"форма", type text}}),
    #"Сгруппированные строки" = Table.Group(#"Измененный тип", {"дата ", "форма"}, {{"Количество металла", each Table.RowCount(Table.Distinct(_)), type number}})
in
    #"Сгруппированные строки"
[/vba]

Автор - китин
Дата добавления - 26.01.2022 в 12:51
Nic70y Дата: Среда, 26.01.2022, 12:51 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(ИНДЕКС(A:A;ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-1):ИНДЕКС(A:A;СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));L8)+ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-2);ИНДЕКС(A:A;ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-1):ИНДЕКС(A:A;СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));L8)+ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-2)))
К сообщению приложен файл: 19.xlsx(464.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(ИНДЕКС(A:A;ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-1):ИНДЕКС(A:A;СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));L8)+ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-2);ИНДЕКС(A:A;ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-1):ИНДЕКС(A:A;СЧЁТЕСЛИ(ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));L8)+ПОИСКПОЗ(L8;ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B;)):ИНДЕКС(C:C;ПОИСКПОЗ(K8;B:B));)+ПОИСКПОЗ(K8;B:B;)-2)))

Автор - Nic70y
Дата добавления - 26.01.2022 в 12:51
svetochka2804061991 Дата: Среда, 26.01.2022, 13:56 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо большое) вы очень помогли)))


Сообщение отредактировал svetochka2804061991 - Среда, 26.01.2022, 14:14
 
Ответить
СообщениеNic70y, спасибо большое) вы очень помогли)))

Автор - svetochka2804061991
Дата добавления - 26.01.2022 в 13:56
прохожий2019 Дата: Среда, 26.01.2022, 14:44 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 250 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СЧЁТЗ(УНИК(ФИЛЬТР($A$2:$A$27;($B$2:$B$27=K8)*($C$2:$C$27=L8))))
 
Ответить
Сообщение
Код
=СЧЁТЗ(УНИК(ФИЛЬТР($A$2:$A$27;($B$2:$B$27=K8)*($C$2:$C$27=L8))))

Автор - прохожий2019
Дата добавления - 26.01.2022 в 14:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма значений одной даты в разных формах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!