Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ВПР - замена #Н/Д на пустую ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР - замена #Н/Д на пустую ячейку (Формулы/Formulas)
Функция ВПР - замена #Н/Д на пустую ячейку
AveTiS Дата: Среда, 02.02.2022, 08:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день уважаемые форумчане. У меня есть формула
Код
=ВПР(H2;FLOCK!$A:$B;2;ЛОЖЬ)
как ее изменить что бы она считала еще и:
- если ячейка Н2 пустая то ячейка в которой формула остается пустой.
- если совпадений нет то тоже пусто а не #Н\Д
Прошу прощения если что не так и спасибо заранее за помощь.


Сообщение отредактировал AveTiS - Среда, 02.02.2022, 08:52
 
Ответить
СообщениеДобрый день уважаемые форумчане. У меня есть формула
Код
=ВПР(H2;FLOCK!$A:$B;2;ЛОЖЬ)
как ее изменить что бы она считала еще и:
- если ячейка Н2 пустая то ячейка в которой формула остается пустой.
- если совпадений нет то тоже пусто а не #Н\Д
Прошу прощения если что не так и спасибо заранее за помощь.

Автор - AveTiS
Дата добавления - 02.02.2022 в 08:23
Nic70y Дата: Среда, 02.02.2022, 08:29 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
у Вас какая версия эксель? новее 2003?


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 02.02.2022, 08:55
 
Ответить
Сообщениеу Вас какая версия эксель? новее 2003?

Автор - Nic70y
Дата добавления - 02.02.2022 в 08:29
AveTiS Дата: Среда, 02.02.2022, 08:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

AveTiS, нужно формулу в сообщении оформлять тэгом fx - иначе у нас отвечать не принято.
у Вас какая версия эксель? новее 2003?


Добрый день! У меня версия 365 enterprise. И спасибо за совет по оформлению. Непременно исправлюсь в следующий раз.
 
Ответить
Сообщение
AveTiS, нужно формулу в сообщении оформлять тэгом fx - иначе у нас отвечать не принято.
у Вас какая версия эксель? новее 2003?


Добрый день! У меня версия 365 enterprise. И спасибо за совет по оформлению. Непременно исправлюсь в следующий раз.

Автор - AveTiS
Дата добавления - 02.02.2022 в 08:44
Nic70y Дата: Среда, 02.02.2022, 08:46 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ВПР(H2;FLOCK!$A:$B;2;ЛОЖЬ);"")
так пойдет?


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 02.02.2022, 08:54
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(H2;FLOCK!$A:$B;2;ЛОЖЬ);"")
так пойдет?

Автор - Nic70y
Дата добавления - 02.02.2022 в 08:46
AveTiS Дата: Среда, 02.02.2022, 08:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

см. как это выглядит

исправил :-)
 
Ответить
Сообщение
см. как это выглядит

исправил :-)

Автор - AveTiS
Дата добавления - 02.02.2022 в 08:55
Nic70y Дата: Среда, 02.02.2022, 08:58 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
ответ отредактировал, см. №4


ЮMoney 41001841029809
 
Ответить
Сообщениеответ отредактировал, см. №4

Автор - Nic70y
Дата добавления - 02.02.2022 в 08:58
AveTiS Дата: Среда, 02.02.2022, 09:03 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

так пойдет?

все просто шикарно. спасибо огромное. + 100500 к карме
 
Ответить
Сообщение
так пойдет?

все просто шикарно. спасибо огромное. + 100500 к карме

Автор - AveTiS
Дата добавления - 02.02.2022 в 09:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР - замена #Н/Д на пустую ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!