Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по значению и месяцу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по значению и месяцу (Формулы/Formulas)
Сумма по значению и месяцу
seldom Дата: Среда, 02.02.2022, 19:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый вечер!

Подскажите пожалуйста как сделать чтобы в ячейках выделенные жёлтым, считалась общая сумма из столбца "H" исходя из значений столбце "F" и за месяц в столбце "G".
Большое спасибо!
К сообщению приложен файл: __.xlsx(8.9 Kb)
 
Ответить
СообщениеДобрый вечер!

Подскажите пожалуйста как сделать чтобы в ячейках выделенные жёлтым, считалась общая сумма из столбца "H" исходя из значений столбце "F" и за месяц в столбце "G".
Большое спасибо!

Автор - seldom
Дата добавления - 02.02.2022 в 19:42
Pelena Дата: Среда, 02.02.2022, 21:20 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ($H$10:$H$12*(ТЕКСТ($G$10:$G$12;"ММММ")=C$1)*($F$10:$F$12=$B2))

или сводной
К сообщению приложен файл: -4-.xlsx(14.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ($H$10:$H$12*(ТЕКСТ($G$10:$G$12;"ММММ")=C$1)*($F$10:$F$12=$B2))

или сводной

Автор - Pelena
Дата добавления - 02.02.2022 в 21:20
Egyptian Дата: Среда, 02.02.2022, 21:25 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 391
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Если подправить месяцы в С1:Е1 то:
Код
=SUMIFS($H$10:$H$50;$F$10:$F$50;$B2;$G$10:$G$50;">="&C$1;$G$10:$G$50;"<="&EOMONTH(C$1;0))
К сообщению приложен файл: 5487438.xlsx(9.9 Kb)
 
Ответить
СообщениеЕсли подправить месяцы в С1:Е1 то:
Код
=SUMIFS($H$10:$H$50;$F$10:$F$50;$B2;$G$10:$G$50;">="&C$1;$G$10:$G$50;"<="&EOMONTH(C$1;0))

Автор - Egyptian
Дата добавления - 02.02.2022 в 21:25
seldom Дата: Среда, 02.02.2022, 21:54 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо большое! Всё работает!
 
Ответить
СообщениеСпасибо большое! Всё работает!

Автор - seldom
Дата добавления - 02.02.2022 в 21:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по значению и месяцу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!