Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сгенерировать номера +n (скопировать столбцы прибавляя n) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сгенерировать номера +n (скопировать столбцы прибавляя n) (Формулы/Formulas)
Сгенерировать номера +n (скопировать столбцы прибавляя n)
Александр7034 Дата: Понедельник, 21.02.2022, 14:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Нужно для стикеровки присваивать серийные номера созданные по определенному шаблону. Шаблон создан и конечный результат получаем путем протягивания ячейки столбца C мышью. Но нужно отойти от этого обойдясь формулой, так как когда их под тысячу геморно протягивать. В моем примере в столбце A вводим количество уникальных идентификаторов _n. В столбце B вводим вручную уникальные буквенные обозначения и они не меняются, а повторяются. Изменения только в цифровом окончании.
К сообщению приложен файл: 234dss.xlsx(9.3 Kb)
 
Ответить
СообщениеНужно для стикеровки присваивать серийные номера созданные по определенному шаблону. Шаблон создан и конечный результат получаем путем протягивания ячейки столбца C мышью. Но нужно отойти от этого обойдясь формулой, так как когда их под тысячу геморно протягивать. В моем примере в столбце A вводим количество уникальных идентификаторов _n. В столбце B вводим вручную уникальные буквенные обозначения и они не меняются, а повторяются. Изменения только в цифровом окончании.

Автор - Александр7034
Дата добавления - 21.02.2022 в 14:30
Nic70y Дата: Понедельник, 21.02.2022, 14:50 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
ну как-то так
Код
=ЕСЛИ(ОКРУГЛВВЕРХ(СТРОКА(D1)/D$1;)<=A$2;ИНДЕКС(B$2:B$1999;ОСТАТ(СТРОКА(D1)-1;D$1)+1)&ПРАВБ("00"&ОКРУГЛВВЕРХ(СТРОКА(D1)/D$1;);3);"")
где d1 - кол-во сеийных
К сообщению приложен файл: 0958413.xlsx(10.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениену как-то так
Код
=ЕСЛИ(ОКРУГЛВВЕРХ(СТРОКА(D1)/D$1;)<=A$2;ИНДЕКС(B$2:B$1999;ОСТАТ(СТРОКА(D1)-1;D$1)+1)&ПРАВБ("00"&ОКРУГЛВВЕРХ(СТРОКА(D1)/D$1;);3);"")
где d1 - кол-во сеийных

Автор - Nic70y
Дата добавления - 21.02.2022 в 14:50
Egyptian Дата: Понедельник, 21.02.2022, 14:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 384
Репутация: 132 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=IF((INT((ROW(A1)-1)/COUNTA($B$2:$B$100))+1)<=$A$2;INDEX($B$2:$B$6;MOD(ROW(A1)-1;COUNTA($B$2:$B$100))+1)&TEXT(INT((ROW(A1)-1)/COUNTA($B$2:$B$100))+1;"000");"")
К сообщению приложен файл: 5682601.xlsx(10.0 Kb)
 
Ответить
СообщениеВариант.
Код
=IF((INT((ROW(A1)-1)/COUNTA($B$2:$B$100))+1)<=$A$2;INDEX($B$2:$B$6;MOD(ROW(A1)-1;COUNTA($B$2:$B$100))+1)&TEXT(INT((ROW(A1)-1)/COUNTA($B$2:$B$100))+1;"000");"")

Автор - Egyptian
Дата добавления - 21.02.2022 в 14:58
Александр7034 Дата: Понедельник, 21.02.2022, 15:00 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Благодарю то что нужно.
 
Ответить
СообщениеБлагодарю то что нужно.

Автор - Александр7034
Дата добавления - 21.02.2022 в 15:00
Александр7034 Дата: Понедельник, 21.02.2022, 15:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

А можете показать кусок что отвечает за функцию добавления 001, 002 и тд. и если нужно эти значения (начинающиеся с 0) поставить спереди. У себя эти цифры добавлял функцией СЦЕПИТЬ, для чего пришлось ввести несколько промежуточных столбцов, в ваших формулах изящней вышло, в одну строку.
 
Ответить
СообщениеА можете показать кусок что отвечает за функцию добавления 001, 002 и тд. и если нужно эти значения (начинающиеся с 0) поставить спереди. У себя эти цифры добавлял функцией СЦЕПИТЬ, для чего пришлось ввести несколько промежуточных столбцов, в ваших формулах изящней вышло, в одну строку.

Автор - Александр7034
Дата добавления - 21.02.2022 в 15:22
Serge_007 Дата: Понедельник, 21.02.2022, 15:34 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15403
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Цитата Александр7034, 21.02.2022 в 15:22, в сообщении № 5 ()
кусок что отвечает за функцию добавления 001, 002 и тд.

Код
=ТЕКСТ(ОТБР((СТРОКА()-1)/СЧЁТЗ(B$2:B$99)-1/СЧЁТЗ(B$2:B$99))+1;"000")
возвращает последовательность:
001
001
001
001
001
002
002
002
002
002
003
003
003
003
003

и т.д.

Код
=ИНДЕКС(B$2:B$99;(СТРОКА()-1)-ОТБР((СТРОКА()-1)/СЧЁТЗ(B$2:B$99)-1/СЧЁТЗ(B$2:B$99))*СЧЁТЗ(B$2:B$99))
возвращает последовательность:
AAA
AAB
AAC
AAD
AAE

AAA
AAB
AAC
AAD
AAE
AAA
AAB
AAC
AAD
AAE

и т.д.

Цитата Александр7034, 21.02.2022 в 15:22, в сообщении № 5 ()
поставить спереди. У себя эти цифры добавлял функцией СЦЕПИТЬ
=Формула2&Формула1


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата Александр7034, 21.02.2022 в 15:22, в сообщении № 5 ()
кусок что отвечает за функцию добавления 001, 002 и тд.

Код
=ТЕКСТ(ОТБР((СТРОКА()-1)/СЧЁТЗ(B$2:B$99)-1/СЧЁТЗ(B$2:B$99))+1;"000")
возвращает последовательность:
001
001
001
001
001
002
002
002
002
002
003
003
003
003
003

и т.д.

Код
=ИНДЕКС(B$2:B$99;(СТРОКА()-1)-ОТБР((СТРОКА()-1)/СЧЁТЗ(B$2:B$99)-1/СЧЁТЗ(B$2:B$99))*СЧЁТЗ(B$2:B$99))
возвращает последовательность:
AAA
AAB
AAC
AAD
AAE

AAA
AAB
AAC
AAD
AAE
AAA
AAB
AAC
AAD
AAE

и т.д.

Цитата Александр7034, 21.02.2022 в 15:22, в сообщении № 5 ()
поставить спереди. У себя эти цифры добавлял функцией СЦЕПИТЬ
=Формула2&Формула1

Автор - Serge_007
Дата добавления - 21.02.2022 в 15:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сгенерировать номера +n (скопировать столбцы прибавляя n) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!