Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/определить уровень по условию (Множественный оператор ЕСЛИ) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определить уровень по условию (Множественный оператор ЕСЛИ) (Формулы/Formulas)
определить уровень по условию (Множественный оператор ЕСЛИ)
denisugak2006 Дата: Среда, 23.02.2022, 00:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

[offtop]Microsoft Exel 2010[/offtop]

В общем проблема такая. Делаю таблицу персонажа для настольной игры. Нужно в одном окне прописать общее кол-во опыта, и чтобы в другой появлялся уровень от 1 до 20.

Код
=ЕСЛИ(E3<300;1;ЕСЛИ(E3>=300;2;ЕСЛИ(E3>=600;3;ЕСЛИ(E3>=1200;4))))


НО! При опыте более 600, уровень не повышается и остаётся на 2.
В чём проблема? Как решить?


Сообщение отредактировал Pelena - Среда, 23.02.2022, 10:54
 
Ответить
Сообщение[offtop]Microsoft Exel 2010[/offtop]

В общем проблема такая. Делаю таблицу персонажа для настольной игры. Нужно в одном окне прописать общее кол-во опыта, и чтобы в другой появлялся уровень от 1 до 20.

Код
=ЕСЛИ(E3<300;1;ЕСЛИ(E3>=300;2;ЕСЛИ(E3>=600;3;ЕСЛИ(E3>=1200;4))))


НО! При опыте более 600, уровень не повышается и остаётся на 2.
В чём проблема? Как решить?

Автор - denisugak2006
Дата добавления - 23.02.2022 в 00:18
DrMini Дата: Среда, 23.02.2022, 06:36 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
denisugak2006,
И Вам здравствуйте.
Оформите пожалуйста формулу правильно (выделите её и нажмите на кнопку Формула).

И Вам помогут.
К сообщению приложен файл: 8772501.jpg(31.5 Kb)
 
Ответить
Сообщениеdenisugak2006,
И Вам здравствуйте.
Оформите пожалуйста формулу правильно (выделите её и нажмите на кнопку Формула).

И Вам помогут.

Автор - DrMini
Дата добавления - 23.02.2022 в 06:36
Апострофф Дата: Среда, 23.02.2022, 07:44 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 411
Репутация: 117 ±
Замечаний: 0% ±

Excel 1997
denisugak2006, наверно потому что 600>=300;2 ?
Код
=ЕСЛИ(E3<300;1;ЕСЛИ(E3<600;2;ЕСЛИ(E3<1200;3;4)))
 
Ответить
Сообщениеdenisugak2006, наверно потому что 600>=300;2 ?
Код
=ЕСЛИ(E3<300;1;ЕСЛИ(E3<600;2;ЕСЛИ(E3<1200;3;4)))

Автор - Апострофф
Дата добавления - 23.02.2022 в 07:44
bigorq Дата: Среда, 23.02.2022, 10:46 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 125
Репутация: 25 ±
Замечаний: 0% ±

Нет
У Вас второе условие
Цитата denisugak2006, 23.02.2022 в 00:18, в сообщении № 1 ()
ЕСЛИ(E3>=300
истино для любого Е3 больше 300, поэтому дальше проверки не идут. Если хотите решать через ЕСЛИ то условия должны быть типа E3<600 итд
 
Ответить
СообщениеУ Вас второе условие
Цитата denisugak2006, 23.02.2022 в 00:18, в сообщении № 1 ()
ЕСЛИ(E3>=300
истино для любого Е3 больше 300, поэтому дальше проверки не идут. Если хотите решать через ЕСЛИ то условия должны быть типа E3<600 итд

Автор - bigorq
Дата добавления - 23.02.2022 в 10:46
jakim Дата: Среда, 23.02.2022, 13:30 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1115
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=LOOKUP(A1;{0;300;600;900;1200;1500;1800;2100;2400};{1;2;3;4;5;6;7;8;9})
К сообщению приложен файл: lookup.xlsx(8.9 Kb)
 
Ответить
Сообщение
Формула

Код
=LOOKUP(A1;{0;300;600;900;1200;1500;1800;2100;2400};{1;2;3;4;5;6;7;8;9})

Автор - jakim
Дата добавления - 23.02.2022 в 13:30
DrMini Дата: Среда, 23.02.2022, 14:09 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
До кучи:
Код
=ЕСЛИ(E3<300;1;ЕСЛИ(И(E3>=300;E3<600);2;ЕСЛИ(И(E3>=600;E3<1200);3;ЕСЛИ(E3>=1200;4;))))

или покороче:
Код
=((E3<0)+(E3>=0)+(E3>=300)+(E3>=600)+(E3>=1200))

если не будет отрицательных значений в ячейке E3 то:
Код
=((E3>=0)+(E3>=300)+(E3>=600)+(E3>=1200))

или так:
Код
=ABS(СУММ(-(E3>={0;300;600;1200})))


Сообщение отредактировал DrMini - Среда, 23.02.2022, 14:10
 
Ответить
СообщениеДо кучи:
Код
=ЕСЛИ(E3<300;1;ЕСЛИ(И(E3>=300;E3<600);2;ЕСЛИ(И(E3>=600;E3<1200);3;ЕСЛИ(E3>=1200;4;))))

или покороче:
Код
=((E3<0)+(E3>=0)+(E3>=300)+(E3>=600)+(E3>=1200))

если не будет отрицательных значений в ячейке E3 то:
Код
=((E3>=0)+(E3>=300)+(E3>=600)+(E3>=1200))

или так:
Код
=ABS(СУММ(-(E3>={0;300;600;1200})))

Автор - DrMini
Дата добавления - 23.02.2022 в 14:09
bmv98rus Дата: Среда, 23.02.2022, 15:36 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
Если все так линейно как у jakim, то

Код
=ПРОСМОТР(A1;300*{0;1;2;3;4;5;6;7;8};{1;2;3;4;5;6;7;8;9})

Код
=MATCH(A1;300*{0;1;2;3;4;5;6;7;8})

Код
=INT(A1/300)+1

До кучи:

=ЕСЛИ(E3<300;1;ЕСЛИ(И(E3>=300;E3<600)
вот теперь мне и себе поясните смысл проверки на E3>=300 если это уже проверено в условии E3<300?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеЕсли все так линейно как у jakim, то

Код
=ПРОСМОТР(A1;300*{0;1;2;3;4;5;6;7;8};{1;2;3;4;5;6;7;8;9})

Код
=MATCH(A1;300*{0;1;2;3;4;5;6;7;8})

Код
=INT(A1/300)+1

До кучи:

=ЕСЛИ(E3<300;1;ЕСЛИ(И(E3>=300;E3<600)
вот теперь мне и себе поясните смысл проверки на E3>=300 если это уже проверено в условии E3<300?

Автор - bmv98rus
Дата добавления - 23.02.2022 в 15:36
DrMini Дата: Среда, 23.02.2022, 15:47 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
вот теперь мне и себе поясните

Просто пробел в образовании. У Владимира всё как нужно написано. Не судите меня строго. Осознал.
Я же потом попытался исправиться.
SORRY
Всему учусь только на этом ресурсе.


Сообщение отредактировал DrMini - Среда, 23.02.2022, 15:48
 
Ответить
Сообщение
вот теперь мне и себе поясните

Просто пробел в образовании. У Владимира всё как нужно написано. Не судите меня строго. Осознал.
Я же потом попытался исправиться.
SORRY
Всему учусь только на этом ресурсе.

Автор - DrMini
Дата добавления - 23.02.2022 в 15:47
bmv98rus Дата: Среда, 23.02.2022, 16:02 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
Я же потом попытался исправиться.
этим
=ABS(СУММ(-(E3>={0;300;600;1200})))

вместо
Код
=-СУММ(-(E3>={0;300;600;1200}))
или
Код
=СУММ(--(E3>={0;300;600;1200}))
:D


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Я же потом попытался исправиться.
этим
=ABS(СУММ(-(E3>={0;300;600;1200})))

вместо
Код
=-СУММ(-(E3>={0;300;600;1200}))
или
Код
=СУММ(--(E3>={0;300;600;1200}))
:D

Автор - bmv98rus
Дата добавления - 23.02.2022 в 16:02
DrMini Дата: Среда, 23.02.2022, 19:02 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
этим

Да. этим. Функция
Код
ABS
сделала результат положительным.
Спасибо за разъяснение в Ваших примерах. Постараюсь запомнить.
[p.s.]хотя это Вами "сказано" с таким раздражением. Бррр...[/p.s.]
 
Ответить
Сообщение
этим

Да. этим. Функция
Код
ABS
сделала результат положительным.
Спасибо за разъяснение в Ваших примерах. Постараюсь запомнить.
[p.s.]хотя это Вами "сказано" с таким раздражением. Бррр...[/p.s.]

Автор - DrMini
Дата добавления - 23.02.2022 в 19:02
bmv98rus Дата: Среда, 23.02.2022, 21:19 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
DrMini, на ошибки можно ткнуть носом, можно указать, а можно просто обратить в шутку. Смотрите всегда на все мои коррекции отталкиваясь от последнего.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеDrMini, на ошибки можно ткнуть носом, можно указать, а можно просто обратить в шутку. Смотрите всегда на все мои коррекции отталкиваясь от последнего.

Автор - bmv98rus
Дата добавления - 23.02.2022 в 21:19
DrMini Дата: Четверг, 24.02.2022, 05:03 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Смотрите всегда на все мои коррекции отталкиваясь от последнего.

Так и будет учитель.
:D :) yes
 
Ответить
Сообщение
Смотрите всегда на все мои коррекции отталкиваясь от последнего.

Так и будет учитель.
:D :) yes

Автор - DrMini
Дата добавления - 24.02.2022 в 05:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » определить уровень по условию (Множественный оператор ЕСЛИ) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!