Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена буквы числом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена буквы числом (в зависимости от буквы в ячейке рядом проставить числовое зн)
Замена буквы числом
pluss1958 Дата: Воскресенье, 13.03.2022, 05:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Есть ячейка рядом с буквенным значением. Есть несколько букв, которым соответствуют определенные числа. Как сделать чтобы в ячейке появлялось значение соответствующей буквы. Спасибо
К сообщению приложен файл: 35.xlsx(11.0 Kb)
 
Ответить
СообщениеДобрый день. Есть ячейка рядом с буквенным значением. Есть несколько букв, которым соответствуют определенные числа. Как сделать чтобы в ячейке появлялось значение соответствующей буквы. Спасибо

Автор - pluss1958
Дата добавления - 13.03.2022 в 05:45
DrMini Дата: Воскресенье, 13.03.2022, 07:32 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 776
Репутация: 46 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Как сделать чтобы в ячейке появлялось значение соответствующей буквы.

Может так (в ячейку A10 и протянуть вправо):
Код
=ЕСЛИ(A9=$A$2;$B$2;ЕСЛИ(A9=$A$3;$B$3;ЕСЛИ(A9=$A$4;$B$4;"")))

[p.s.]Можно и через УФ[/p.s.]
 
Ответить
Сообщение
Как сделать чтобы в ячейке появлялось значение соответствующей буквы.

Может так (в ячейку A10 и протянуть вправо):
Код
=ЕСЛИ(A9=$A$2;$B$2;ЕСЛИ(A9=$A$3;$B$3;ЕСЛИ(A9=$A$4;$B$4;"")))

[p.s.]Можно и через УФ[/p.s.]

Автор - DrMini
Дата добавления - 13.03.2022 в 07:32
Irisha1092 Дата: Воскресенье, 13.03.2022, 07:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Или вот так (в ячейку A10 и протянуть вправо):
Код
=ЕСЛИОШИБКА(ВПР(A9;$A$2:$B$4;2;0);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$4;ПОИСКПОЗ(A9;$A$2:$A$4;0));"")
 
Ответить
СообщениеИли вот так (в ячейку A10 и протянуть вправо):
Код
=ЕСЛИОШИБКА(ВПР(A9;$A$2:$B$4;2;0);"")

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$4;ПОИСКПОЗ(A9;$A$2:$A$4;0));"")

Автор - Irisha1092
Дата добавления - 13.03.2022 в 07:36
pluss1958 Дата: Воскресенье, 13.03.2022, 08:40 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Спасибо. Формула работает. Изумительно
 
Ответить
СообщениеСпасибо. Формула работает. Изумительно

Автор - pluss1958
Дата добавления - 13.03.2022 в 08:40
pluss1958 Дата: Воскресенье, 13.03.2022, 08:42 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Спасибо, с ВПР формула тоже сработала. Она даже несколько попроще. Благодарю всех, кто отозвался и помог.
 
Ответить
СообщениеСпасибо, с ВПР формула тоже сработала. Она даже несколько попроще. Благодарю всех, кто отозвался и помог.

Автор - pluss1958
Дата добавления - 13.03.2022 в 08:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена буквы числом (в зависимости от буквы в ячейке рядом проставить числовое зн)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!