Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет выдачи и возврата по Ф.И.О - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет выдачи и возврата по Ф.И.О (Формулы/Formulas)
Подсчет выдачи и возврата по Ф.И.О
Serge_007 Дата: Понедельник, 14.03.2022, 23:40 | Сообщение № 21
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Мне включить мои телепатические способности?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеМне включить мои телепатические способности?

Автор - Serge_007
Дата добавления - 14.03.2022 в 23:40
Смольный Дата: Вторник, 15.03.2022, 05:36 | Сообщение № 22
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Извиняюсь, в прикрепленном файле 123 строка на листе движения попадает в статистику только по количеству ТСР, по людям нет ее. Если в B5 на листе статистика в формуле изменить A122, B122, C122 на 123 то информация по людям тоже появится, но так каждый раз править формулу это невозможно, а если прописать большее значение, к примеру 815 как в ячейке С5 то в ячейке В5 пишет #Н/Д
К сообщению приложен файл: 3044478.xls(235.5 Kb)


Сообщение отредактировал Смольный - Вторник, 15.03.2022, 05:36
 
Ответить
СообщениеSerge_007, Извиняюсь, в прикрепленном файле 123 строка на листе движения попадает в статистику только по количеству ТСР, по людям нет ее. Если в B5 на листе статистика в формуле изменить A122, B122, C122 на 123 то информация по людям тоже появится, но так каждый раз править формулу это невозможно, а если прописать большее значение, к примеру 815 как в ячейке С5 то в ячейке В5 пишет #Н/Д

Автор - Смольный
Дата добавления - 15.03.2022 в 05:36
Serge_007 Дата: Вторник, 15.03.2022, 09:28 | Сообщение № 23
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Формула массива:
Код
=СУММ((Движение!A$2:A$815>=A$3)*(C$3>=Движение!A$2:A$815)*(A5=Движение!C$2:C$815)*(ЕСЛИОШИБКА(ПОИСКПОЗ(Движение!B$2:B$815;Движение!B$2:B$815;);)=СТРОКА($1:$814)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеФормула массива:
Код
=СУММ((Движение!A$2:A$815>=A$3)*(C$3>=Движение!A$2:A$815)*(A5=Движение!C$2:C$815)*(ЕСЛИОШИБКА(ПОИСКПОЗ(Движение!B$2:B$815;Движение!B$2:B$815;);)=СТРОКА($1:$814)))

Автор - Serge_007
Дата добавления - 15.03.2022 в 09:28
Смольный Дата: Вторник, 15.03.2022, 10:00 | Сообщение № 24
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, формула работает, но есть один нюанс, в прикрепленном файле на листе статистика взят период с 11.02 по 14.02 за этот период Порк П.Е. получил 12.02 два ТСР и 14.02 еще один ТСР, в статистике по людям он должен был посчитаться два раза, так как получал ТСР в разные дни. Дико извиняюсь за такой сумбур, но министерство такую информацию просит и специалистам приходится в ручную все считать.
К сообщению приложен файл: 3044478-1-.xls(235.5 Kb)


Сообщение отредактировал Смольный - Вторник, 15.03.2022, 10:00
 
Ответить
СообщениеSerge_007, формула работает, но есть один нюанс, в прикрепленном файле на листе статистика взят период с 11.02 по 14.02 за этот период Порк П.Е. получил 12.02 два ТСР и 14.02 еще один ТСР, в статистике по людям он должен был посчитаться два раза, так как получал ТСР в разные дни. Дико извиняюсь за такой сумбур, но министерство такую информацию просит и специалистам приходится в ручную все считать.

Автор - Смольный
Дата добавления - 15.03.2022 в 10:00
Nic70y Дата: Среда, 16.03.2022, 14:02 | Сообщение № 25
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ((Движение!A$2:A$815>=A$3)*(C$3>=Движение!A$2:A$815)*(A5=Движение!C$2:C$815)*(ЕСЛИОШИБКА(ПОИСКПОЗ(Движение!A$2:A$815&Движение!B$2:B$815;Движение!A$2:A$815&Движение!B$2:B$815;);)=СТРОКА($1:$814)))
так?
К сообщению приложен файл: 4581534.xls(235.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММ((Движение!A$2:A$815>=A$3)*(C$3>=Движение!A$2:A$815)*(A5=Движение!C$2:C$815)*(ЕСЛИОШИБКА(ПОИСКПОЗ(Движение!A$2:A$815&Движение!B$2:B$815;Движение!A$2:A$815&Движение!B$2:B$815;);)=СТРОКА($1:$814)))
так?

Автор - Nic70y
Дата добавления - 16.03.2022 в 14:02
Смольный Дата: Среда, 16.03.2022, 14:15 | Сообщение № 26
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, да, сейчас считает как надо. спасибо
 
Ответить
СообщениеNic70y, да, сейчас считает как надо. спасибо

Автор - Смольный
Дата добавления - 16.03.2022 в 14:15
Смольный Дата: Четверг, 14.04.2022, 13:00 | Сообщение № 27
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Добрый день, опять нужна Ваша помощь, в прикрепленном файле в один день Иванов вернул ТСР три штуки и в этот же день опять получил, делается это для того, когда заканчивается срок безвозмездной аренды на ТСР, но они нужны и их опять отдают по документам, на листе статистика в ячейках В5 В6 идет не правильный подсчет по людям, в данном примере в ячейке В5 ноль, хотя на листе движение есть две записи с одной фамилией и должно быть 1 человек. Помогите решить проблему, если возможно.
 
Ответить
СообщениеNic70y, Добрый день, опять нужна Ваша помощь, в прикрепленном файле в один день Иванов вернул ТСР три штуки и в этот же день опять получил, делается это для того, когда заканчивается срок безвозмездной аренды на ТСР, но они нужны и их опять отдают по документам, на листе статистика в ячейках В5 В6 идет не правильный подсчет по людям, в данном примере в ячейке В5 ноль, хотя на листе движение есть две записи с одной фамилией и должно быть 1 человек. Помогите решить проблему, если возможно.

Автор - Смольный
Дата добавления - 14.04.2022 в 13:00
Смольный Дата: Вторник, 19.04.2022, 12:16 | Сообщение № 28
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, пардон, файл не прикрепил.
К сообщению приложен файл: _2022__.xls(216.0 Kb)
 
Ответить
СообщениеNic70y, пардон, файл не прикрепил.

Автор - Смольный
Дата добавления - 19.04.2022 в 12:16
Nic70y Дата: Вторник, 19.04.2022, 12:57 | Сообщение № 29
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ("1\"&Движение!B$2:B$831;ЕСЛИ((Движение!A$2:A$831>=A$3)*(C$3>=Движение!A$2:A$831)*(A5=Движение!C$2:C$831);"1\"&Движение!B$2:B$831););)=СТРОКА(B$2:B$831)-1))
К сообщению приложен файл: _2022_.xls(215.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ("1\"&Движение!B$2:B$831;ЕСЛИ((Движение!A$2:A$831>=A$3)*(C$3>=Движение!A$2:A$831)*(A5=Движение!C$2:C$831);"1\"&Движение!B$2:B$831););)=СТРОКА(B$2:B$831)-1))

Автор - Nic70y
Дата добавления - 19.04.2022 в 12:57
Смольный Дата: Вторник, 19.04.2022, 15:30 | Сообщение № 30
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо, работает так как надо.
 
Ответить
СообщениеNic70y, спасибо, работает так как надо.

Автор - Смольный
Дата добавления - 19.04.2022 в 15:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет выдачи и возврата по Ф.И.О (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!