Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Excel сравнения столбцов с нескольками данными - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Excel сравнения столбцов с нескольками данными (Формулы/Formulas)
Excel сравнения столбцов с нескольками данными
xanSolo Дата: Среда, 16.03.2022, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Добрый день! Есть 2 таблицы надо сравнить 2 столбца но данные столбца различаются . Например в столбце Данные1 есть строка с "город Москва ул.Абрикос" а столбце Данные2 который надо сравнить там написано в строке "у.Абрикос" если Данные1 есть в Данных2 то тогда результат на третьем столбце должен быть "у.Абрикос". как решить эту задачу не подскажите новичку. Попробовал через условное форматирование но это работает если в столбцах одинаковые данные
К сообщению приложен файл: info.xlsx(9.6 Kb)


Сообщение отредактировал xanSolo - Среда, 16.03.2022, 13:34
 
Ответить
СообщениеДобрый день! Есть 2 таблицы надо сравнить 2 столбца но данные столбца различаются . Например в столбце Данные1 есть строка с "город Москва ул.Абрикос" а столбце Данные2 который надо сравнить там написано в строке "у.Абрикос" если Данные1 есть в Данных2 то тогда результат на третьем столбце должен быть "у.Абрикос". как решить эту задачу не подскажите новичку. Попробовал через условное форматирование но это работает если в столбцах одинаковые данные

Автор - xanSolo
Дата добавления - 16.03.2022 в 13:17
Nic70y Дата: Среда, 16.03.2022, 16:03 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7520
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ВПР("*"&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ПРАВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99);".";ПОВТОР(" ";99));99));E:E;1;);"")
но это не точно(с)
К сообщению приложен файл: 2908121.xlsx(9.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР("*"&СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ПРАВБ(ПОДСТАВИТЬ(A2;" ";ПОВТОР(" ";99));99);".";ПОВТОР(" ";99));99));E:E;1;);"")
но это не точно(с)

Автор - Nic70y
Дата добавления - 16.03.2022 в 16:03
xanSolo Дата: Четверг, 17.03.2022, 12:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Огромное спасибо! 85% совпало остальное ручками сделал respect


Сообщение отредактировал Serge_007 - Четверг, 17.03.2022, 12:48
 
Ответить
СообщениеОгромное спасибо! 85% совпало остальное ручками сделал respect

Автор - xanSolo
Дата добавления - 17.03.2022 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Excel сравнения столбцов с нескольками данными (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!