Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/SUM не складывает значения массива по ВПР или ПРОСМОТР - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » SUM не складывает значения массива по ВПР или ПРОСМОТР (Формулы/Formulas)
SUM не складывает значения массива по ВПР или ПРОСМОТР
andreevivan7 Дата: Пятница, 18.03.2022, 06:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Возникла проблема: Делаю формулу сложения всех найденных в массиве значений по ВПР или ПРОСМОТР. Находится одна строка(первая или последняя) и все.
Перечитал кучу примеров и мануалов. Формулу завершаю ctrl+shift+enter.
Пример данных и формулы в картинке.
Прошу помощи и совета, что я делаю не так.

Цель работы: найти все повторяющиеся строки в столбце и сложить их значения или найти среднее арифметическое.
К сообщению приложен файл: 5606351.png(4.8 Kb)
 
Ответить
СообщениеДобрый день.
Возникла проблема: Делаю формулу сложения всех найденных в массиве значений по ВПР или ПРОСМОТР. Находится одна строка(первая или последняя) и все.
Перечитал кучу примеров и мануалов. Формулу завершаю ctrl+shift+enter.
Пример данных и формулы в картинке.
Прошу помощи и совета, что я делаю не так.

Цель работы: найти все повторяющиеся строки в столбце и сложить их значения или найти среднее арифметическое.

Автор - andreevivan7
Дата добавления - 18.03.2022 в 06:44
Nic70y Дата: Пятница, 18.03.2022, 07:38 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Находится одна строка
так и должно быть.
Формулу завершаю ctrl+shift+enter
в данном случае это ни чего не даст.
Цель работы
см. функции
Код
=СУММЕСЛИ()
Код
=СРЗНАЧЕСЛИ()
если хотите решения, то вот этого:
Пример данных и формулы в картинке.
не нужно - нужен файл-excel


ЮMoney 41001841029809
 
Ответить
Сообщение
Находится одна строка
так и должно быть.
Формулу завершаю ctrl+shift+enter
в данном случае это ни чего не даст.
Цель работы
см. функции
Код
=СУММЕСЛИ()
Код
=СРЗНАЧЕСЛИ()
если хотите решения, то вот этого:
Пример данных и формулы в картинке.
не нужно - нужен файл-excel

Автор - Nic70y
Дата добавления - 18.03.2022 в 07:38
andreevivan7 Дата: Пятница, 18.03.2022, 09:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо за ответ.
Во вложении файл.
Судя по обширному количеству примеров в интернете ВПР и ПРОСМОТР используют вместе с СУММ для подсчета всех находящихся строк. А у меня не получается.
За предложенные функции спасибо, попробую.
К сообщению приложен файл: ____.xlsx(10.5 Kb)
 
Ответить
СообщениеNic70y, Спасибо за ответ.
Во вложении файл.
Судя по обширному количеству примеров в интернете ВПР и ПРОСМОТР используют вместе с СУММ для подсчета всех находящихся строк. А у меня не получается.
За предложенные функции спасибо, попробую.

Автор - andreevivan7
Дата добавления - 18.03.2022 в 09:38
Serge_007 Дата: Пятница, 18.03.2022, 10:11 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(B3:B12;E3;))*C3:C12)
Код
=СУММПРОИЗВ((B3:B12=E3)*C3:C12)
Код
=СУММЕСЛИ(B3:B12;E3;C3:C12)
Код
=СУММ((B3:B12=E3)*C3:C12)


Судя по обширному количеству примеров в интернете ВПР и ПРОСМОТР используют вместе с СУММ для подсчета всех находящихся строк
Приведите хотя бы один пример
К сообщению приложен файл: 20220318_andree.xls(74.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(B3:B12;E3;))*C3:C12)
Код
=СУММПРОИЗВ((B3:B12=E3)*C3:C12)
Код
=СУММЕСЛИ(B3:B12;E3;C3:C12)
Код
=СУММ((B3:B12=E3)*C3:C12)


Судя по обширному количеству примеров в интернете ВПР и ПРОСМОТР используют вместе с СУММ для подсчета всех находящихся строк
Приведите хотя бы один пример

Автор - Serge_007
Дата добавления - 18.03.2022 в 10:11
andreevivan7 Дата: Пятница, 18.03.2022, 10:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

 
Ответить
СообщениеSerge_007,
https://office-guru.ru/excel....68.html

Автор - andreevivan7
Дата добавления - 18.03.2022 в 10:14
Nic70y Дата: Пятница, 18.03.2022, 10:26 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
отвлекли, а тут уже ответили,
не актуально,
удалите


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 18.03.2022, 10:27
 
Ответить
Сообщениеотвлекли, а тут уже ответили,
не актуально,
удалите

Автор - Nic70y
Дата добавления - 18.03.2022 в 10:26
китин Дата: Пятница, 18.03.2022, 10:31 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
andreevivan7, вы невнимательно читали данную статью.
Цитата
мы использовали массив {2,3,4} для третьего аргумента, чтобы выполнить поиск несколько раз в одной функции ВПР, и получить сумму значений в столбцах 2, 3 и 4.

а у вас строки


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеandreevivan7, вы невнимательно читали данную статью.
Цитата
мы использовали массив {2,3,4} для третьего аргумента, чтобы выполнить поиск несколько раз в одной функции ВПР, и получить сумму значений в столбцах 2, 3 и 4.

а у вас строки

Автор - китин
Дата добавления - 18.03.2022 в 10:31
andreevivan7 Дата: Пятница, 18.03.2022, 11:21 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Спасибо Вам добрый молодцы, что наставили на путь истинный! :)
Тему можно закрыть.
 
Ответить
СообщениеСпасибо Вам добрый молодцы, что наставили на путь истинный! :)
Тему можно закрыть.

Автор - andreevivan7
Дата добавления - 18.03.2022 в 11:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » SUM не складывает значения массива по ВПР или ПРОСМОТР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!