Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подстановка коэффициента в зависимости от суммы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подстановка коэффициента в зависимости от суммы (Формулы/Formulas)
подстановка коэффициента в зависимости от суммы
maritomilova Дата: Воскресенье, 20.03.2022, 16:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

В листе поиск значений есть сумма уровней (сейчас равно 15, столбец J), а в листе база данных установлены коэффициенты напротив каждой фамилии, которые должны вставляться в файл поиск значений в зависимости от суммы уровней в столбце J. То есть если сумма уровней составляет 4, тогда напротив фамилий в столбце К файле поиск значений должны выходить коэффициенты из столбца I (файл база данных), если 15 то из столбца J(база данных), если 23 то из столбца K(база данных), если 60 то из столбца L(база данных).Желательно решить проблему макросом
К сообщению приложен файл: -1-.xlsm(28.7 Kb)
 
Ответить
СообщениеВ листе поиск значений есть сумма уровней (сейчас равно 15, столбец J), а в листе база данных установлены коэффициенты напротив каждой фамилии, которые должны вставляться в файл поиск значений в зависимости от суммы уровней в столбце J. То есть если сумма уровней составляет 4, тогда напротив фамилий в столбце К файле поиск значений должны выходить коэффициенты из столбца I (файл база данных), если 15 то из столбца J(база данных), если 23 то из столбца K(база данных), если 60 то из столбца L(база данных).Желательно решить проблему макросом

Автор - maritomilova
Дата добавления - 20.03.2022 в 16:49
Gustav Дата: Воскресенье, 20.03.2022, 21:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Задача довольно легко решается формулой (для ячейки K2 листа "Поиск значений" и далее копируем ниже):
Код
=ИНДЕКС('База данных'!$I$2:$L$4; ПОИСКПОЗ(B2;'База данных'!$B$2:$B$4;); ПОИСКПОЗ($J$5;{0;5;10;50};1))

А макросом зачем? Преподаватель так задал? Тогда определяйтесь с тем, по какому событию будет выполняться пересчет этих значений. В общем, ставьте задачу до конца. В конце концов, можно записать макрорекордером процесс создания этой формулы - и это тоже будет иметь право называться макросом :)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеЗадача довольно легко решается формулой (для ячейки K2 листа "Поиск значений" и далее копируем ниже):
Код
=ИНДЕКС('База данных'!$I$2:$L$4; ПОИСКПОЗ(B2;'База данных'!$B$2:$B$4;); ПОИСКПОЗ($J$5;{0;5;10;50};1))

А макросом зачем? Преподаватель так задал? Тогда определяйтесь с тем, по какому событию будет выполняться пересчет этих значений. В общем, ставьте задачу до конца. В конце концов, можно записать макрорекордером процесс создания этой формулы - и это тоже будет иметь право называться макросом :)

Автор - Gustav
Дата добавления - 20.03.2022 в 21:43
maritomilova Дата: Понедельник, 21.03.2022, 07:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо. Нет я не студент, я человек очень мало понимающий в программировании. Нужно для работы. Просто у меня в рабочем файле База данных состоит из 13000 строк, вот я и подумала, что для такого количества лучше макрос.
 
Ответить
СообщениеСпасибо. Нет я не студент, я человек очень мало понимающий в программировании. Нужно для работы. Просто у меня в рабочем файле База данных состоит из 13000 строк, вот я и подумала, что для такого количества лучше макрос.

Автор - maritomilova
Дата добавления - 21.03.2022 в 07:02
Gustav Дата: Понедельник, 21.03.2022, 13:47 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
в рабочем файле База данных состоит из 13000 строк

Можно немного оптимизировать расчет, вынеся в отдельную ячейку вычисление второго индекса (столбца), поскольку он будет одинаковым для всех строк:
Код
=ПОИСКПОЗ($J$5;{0;5;10;50};1)

и затем сослаться на эту ячейку в формуле для каждой строки
Код
=ИНДЕКС('База данных'!$I$2:$L$4; ПОИСКПОЗ(B2;'База данных'!$B$2:$B$4;); абсолютный$$АдресЯчейкиВычисленияСтолбца )

По идее, должно быть пошустрее.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
в рабочем файле База данных состоит из 13000 строк

Можно немного оптимизировать расчет, вынеся в отдельную ячейку вычисление второго индекса (столбца), поскольку он будет одинаковым для всех строк:
Код
=ПОИСКПОЗ($J$5;{0;5;10;50};1)

и затем сослаться на эту ячейку в формуле для каждой строки
Код
=ИНДЕКС('База данных'!$I$2:$L$4; ПОИСКПОЗ(B2;'База данных'!$B$2:$B$4;); абсолютный$$АдресЯчейкиВычисленияСтолбца )

По идее, должно быть пошустрее.

Автор - Gustav
Дата добавления - 21.03.2022 в 13:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подстановка коэффициента в зависимости от суммы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!