Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести несколько строк соответствующих нескольким условиям. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести несколько строк соответствующих нескольким условиям. (Формулы/Formulas)
Вывести несколько строк соответствующих нескольким условиям.
askerov1988 Дата: Пятница, 08.04.2022, 12:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Есть таблица из трех столбцов в которой указаны Наименование прибора, Диаметр и Длина.
Подскажите пожалуйста, как:
1. Вывести отдельную таблицу состоящую из строк в которых и Диаметр и Длина равна диаметру и длине, указываемым в отдельных ячейках.
2. Вывести отдельную таблицу состоящую из строк в которых Диаметр и Длина равна Диаметру и Длине прибора, указанного в отдельной ячейке
Спасибо!
К сообщению приложен файл: __97-2003.xls(25.5 Kb)
 
Ответить
СообщениеДобрый день!
Есть таблица из трех столбцов в которой указаны Наименование прибора, Диаметр и Длина.
Подскажите пожалуйста, как:
1. Вывести отдельную таблицу состоящую из строк в которых и Диаметр и Длина равна диаметру и длине, указываемым в отдельных ячейках.
2. Вывести отдельную таблицу состоящую из строк в которых Диаметр и Длина равна Диаметру и Длине прибора, указанного в отдельной ячейке
Спасибо!

Автор - askerov1988
Дата добавления - 08.04.2022 в 12:56
alexa1965 Дата: Пятница, 08.04.2022, 13:11 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 20 ±
Замечаний: 0% ±

2003> 2010> 2016
Код
=ИНДЕКС(A$1:A$8;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$7=F$1)*(C$2:C$7=$F$2);СТРОКА(A$2:A$7);1000);СТРОКА(A1)))
Формула массивная для ячейки а13


Главное не быть балабастиком
 
Ответить
Сообщение
Код
=ИНДЕКС(A$1:A$8;НАИМЕНЬШИЙ(ЕСЛИ((B$2:B$7=F$1)*(C$2:C$7=$F$2);СТРОКА(A$2:A$7);1000);СТРОКА(A1)))
Формула массивная для ячейки а13

Автор - alexa1965
Дата добавления - 08.04.2022 в 13:11
Nic70y Дата: Пятница, 08.04.2022, 13:15 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7723
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ИНДЕКС(A$2:A$7;НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$7&C$2:C$7=B13&C13;СТРОКА(C$2:C$7)-1);СТРОКА(A1)))
К сообщению приложен файл: _97-2003.xls(27.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(A$2:A$7;НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$7&C$2:C$7=B13&C13;СТРОКА(C$2:C$7)-1);СТРОКА(A1)))

Автор - Nic70y
Дата добавления - 08.04.2022 в 13:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести несколько строк соответствующих нескольким условиям. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!