Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммесли НЕ содержит ... - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммесли НЕ содержит ... (Формулы/Formulas)
Суммесли НЕ содержит ...
Snow Дата: Понедельник, 11.04.2022, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Здравствуйте вам :hello:
Подскажите, пжл, как в формуле суммесли использовать "НЕ содержит"
или, может суммесли только по числу, без доп знаков
К сообщению приложен файл: 7824539.xlsx(8.3 Kb)
 
Ответить
СообщениеЗдравствуйте вам :hello:
Подскажите, пжл, как в формуле суммесли использовать "НЕ содержит"
или, может суммесли только по числу, без доп знаков

Автор - Snow
Дата добавления - 11.04.2022 в 12:52
_Boroda_ Дата: Понедельник, 11.04.2022, 13:00 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(A:A; "<>*"&D2&"*";B:B)
К сообщению приложен файл: 7824539_1.xlsx(9.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 11.04.2022, 13:03
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(A:A; "<>*"&D2&"*";B:B)

Автор - _Boroda_
Дата добавления - 11.04.2022 в 13:00
Serge_007 Дата: Понедельник, 11.04.2022, 13:00 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15156
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Здравствуйте
Код
=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте
Код
=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))

Автор - Serge_007
Дата добавления - 11.04.2022 в 13:00
Snow Дата: Понедельник, 11.04.2022, 13:16 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Так нужно?


да работает, спасибо
а как сделать, чтобы считало сумму не содержит "/С" ?


Сообщение отредактировал Snow - Понедельник, 11.04.2022, 13:23
 
Ответить
Сообщение
Так нужно?


да работает, спасибо
а как сделать, чтобы считало сумму не содержит "/С" ?

Автор - Snow
Дата добавления - 11.04.2022 в 13:16
Snow Дата: Понедельник, 11.04.2022, 13:17 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))


так считает только по критерию ("/" или "/С") , а просто числа без значков не считает %)
 
Ответить
Сообщение
=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))


так считает только по критерию ("/" или "/С") , а просто числа без значков не считает %)

Автор - Snow
Дата добавления - 11.04.2022 в 13:17
_Boroda_ Дата: Понедельник, 11.04.2022, 13:33 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а как сделать, чтобы считало сумму не содержит "/С" ?

Именно так и сделать. См. файл
Или, если без ссылки на ячейку
Код
=СУММЕСЛИ(A:A;"<>*/С*";B:B)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
а как сделать, чтобы считало сумму не содержит "/С" ?

Именно так и сделать. См. файл
Или, если без ссылки на ячейку
Код
=СУММЕСЛИ(A:A;"<>*/С*";B:B)

Автор - _Boroda_
Дата добавления - 11.04.2022 в 13:33
Snow Дата: Понедельник, 11.04.2022, 13:39 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Именно так и сделать


не работает так
только считает без лишних знаков
К сообщению приложен файл: 7824539_1-1-.xlsx(8.5 Kb)
 
Ответить
Сообщение
Именно так и сделать


не работает так
только считает без лишних знаков

Автор - Snow
Дата добавления - 11.04.2022 в 13:39
Serge_007 Дата: Понедельник, 11.04.2022, 13:59 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15156
Репутация: 2503 ±
Замечаний: ±

Excel 2016
просто числа без значков не считает
Этого не было в вопросе

Код
=СУММПРОИЗВ(ЕЧИСЛО(A$3:A$7)*B$3:B$7)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
просто числа без значков не считает
Этого не было в вопросе

Код
=СУММПРОИЗВ(ЕЧИСЛО(A$3:A$7)*B$3:B$7)

Автор - Serge_007
Дата добавления - 11.04.2022 в 13:59
Snow Дата: Понедельник, 11.04.2022, 14:13 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Этого не было в вопросе

согласна :)

=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))


а эта не считает ;)
К сообщению приложен файл: 2888046.xlsx(8.6 Kb)
 
Ответить
Сообщение
Этого не было в вопросе

согласна :)

=СУММПРОИЗВ((ЕОШ(ПОИСК(D2;A$3:A$7))*B$3:B$7))


а эта не считает ;)

Автор - Snow
Дата добавления - 11.04.2022 в 14:13
_Boroda_ Дата: Понедельник, 11.04.2022, 14:15 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не работает так
только считает без лишних знаков

Я не понимаю, что Вам посчитать нужно. Напишите в файле конкретно - в этой ячейке должно быть столько-то потому, что ...


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не работает так
только считает без лишних знаков

Я не понимаю, что Вам посчитать нужно. Напишите в файле конкретно - в этой ячейке должно быть столько-то потому, что ...

Автор - _Boroda_
Дата добавления - 11.04.2022 в 14:15
Snow Дата: Понедельник, 11.04.2022, 14:31 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
=СУММЕСЛИ(A:A; "<>*"&D2&"*";B:B)

она у меня, почему-то не во всех файлах работает
где-то что-то мешает, наверное
К сообщению приложен файл: 9311305.xlsx(9.5 Kb)


Сообщение отредактировал Snow - Понедельник, 11.04.2022, 14:37
 
Ответить
Сообщение
=СУММЕСЛИ(A:A; "<>*"&D2&"*";B:B)

она у меня, почему-то не во всех файлах работает
где-то что-то мешает, наверное

Автор - Snow
Дата добавления - 11.04.2022 в 14:31
_Boroda_ Дата: Понедельник, 11.04.2022, 14:38 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я ж написал -
Код
=СУММЕСЛИ(A:A; "<>*"&D4&"*";B:B)

Где в D4 стоит слеш
Или, чтобы не захватывало строку Итого, вот так можно
Код
=СУММЕСЛИМН(B:B;A:A; "<>*"&D4&"*";A:A;"<>Итого")

Или еще проще
Код
=СУММЕСЛИ(A:A; "<>*";B:B)
К сообщению приложен файл: 9311305_1.xlsx(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ ж написал -
Код
=СУММЕСЛИ(A:A; "<>*"&D4&"*";B:B)

Где в D4 стоит слеш
Или, чтобы не захватывало строку Итого, вот так можно
Код
=СУММЕСЛИМН(B:B;A:A; "<>*"&D4&"*";A:A;"<>Итого")

Или еще проще
Код
=СУММЕСЛИ(A:A; "<>*";B:B)

Автор - _Boroda_
Дата добавления - 11.04.2022 в 14:38
Snow Дата: Понедельник, 11.04.2022, 14:49 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
 
Ответить
Сообщение

Автор - Snow
Дата добавления - 11.04.2022 в 14:49
Serge_007 Дата: Понедельник, 11.04.2022, 15:01 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 15156
Репутация: 2503 ±
Замечаний: ±

Excel 2016
эта не считает
Что не считает?
Вы же даже файл приложили с правильными результатами работы формулы...


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
эта не считает
Что не считает?
Вы же даже файл приложили с правильными результатами работы формулы...

Автор - Serge_007
Дата добавления - 11.04.2022 в 15:01
Snow Дата: Понедельник, 11.04.2022, 16:46 | Сообщение № 15
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Что не считает?


она у меня, почему-то не во всех файлах работает
где-то что-то мешает, наверное


это я , похоже, все порчу :D

спасибо за помощь
 
Ответить
Сообщение
Что не считает?


она у меня, почему-то не во всех файлах работает
где-то что-то мешает, наверное


это я , похоже, все порчу :D

спасибо за помощь

Автор - Snow
Дата добавления - 11.04.2022 в 16:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммесли НЕ содержит ... (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!