Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнить таблицу данными из другой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить таблицу данными из другой (Формулы/Formulas)
Заполнить таблицу данными из другой
TanyaKatana Дата: Среда, 13.04.2022, 11:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Добрый день.
Есть одна большая таблица и одна маленькая. Как таблицу с бОльшим количеством данных заполнить из более мелкой таблицы. Что-то вроде ВПР, но справка говорит, так не сработает. Только если наоборот, из большой в мелкую заполнять.

например
табл 1
запись_1
запись_2
запись_3
запись_4

табл 2

Запись_1 10
Запись_3 15

Чтобы получилось

запись_1 10
запись_2
запись_3 15
запись_4


Сообщение отредактировал TanyaKatana - Среда, 13.04.2022, 11:10
 
Ответить
СообщениеДобрый день.
Есть одна большая таблица и одна маленькая. Как таблицу с бОльшим количеством данных заполнить из более мелкой таблицы. Что-то вроде ВПР, но справка говорит, так не сработает. Только если наоборот, из большой в мелкую заполнять.

например
табл 1
запись_1
запись_2
запись_3
запись_4

табл 2

Запись_1 10
Запись_3 15

Чтобы получилось

запись_1 10
запись_2
запись_3 15
запись_4

Автор - TanyaKatana
Дата добавления - 13.04.2022 в 11:02
_Boroda_ Дата: Среда, 13.04.2022, 11:10 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А какая разница? Приложите файл-пример, так понятнее будет. И что нужно распишите

Код
=ЕСЛИОШИБКА(ВПР(A2;E2:F8;2;);"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 13.04.2022, 11:11
 
Ответить
СообщениеА какая разница? Приложите файл-пример, так понятнее будет. И что нужно распишите

Код
=ЕСЛИОШИБКА(ВПР(A2;E2:F8;2;);"")

Автор - _Boroda_
Дата добавления - 13.04.2022 в 11:10
Serge_007 Дата: Среда, 13.04.2022, 11:23 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15154
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Здравствуйте

ВПР, но справка говорит, так не сработает. Только если наоборот, из большой в мелкую заполнять
Эот что за юмористическая справка? Дайте ссылочку


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

ВПР, но справка говорит, так не сработает. Только если наоборот, из большой в мелкую заполнять
Эот что за юмористическая справка? Дайте ссылочку

Автор - Serge_007
Дата добавления - 13.04.2022 в 11:23
TanyaKatana Дата: Среда, 13.04.2022, 11:29 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

=ЕСЛИОШИБКА(ВПР(A2;E2:F8;2;);"")


как-то криво у меня получается

Эот что за юмористическая справка? Дайте ссылочку


Добрый день. Уже не смог найти
К сообщению приложен файл: 8401483.xlsx(8.6 Kb)
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ВПР(A2;E2:F8;2;);"")


как-то криво у меня получается

Эот что за юмористическая справка? Дайте ссылочку


Добрый день. Уже не смог найти

Автор - TanyaKatana
Дата добавления - 13.04.2022 в 11:29
китин Дата: Среда, 13.04.2022, 11:32 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6809
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2007;2010;2016
почувствуй разницу
Код
=ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2;0);"")

а так у вас в файле
Код
=ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2);"")


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениепочувствуй разницу
Код
=ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2;0);"")

а так у вас в файле
Код
=ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2);"")

Автор - китин
Дата добавления - 13.04.2022 в 11:32
Serge_007 Дата: Среда, 13.04.2022, 11:32 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15154
Репутация: 2503 ±
Замечаний: ±

Excel 2016
криво у меня получается
Вы не с форума скопировали формулу
Должно быть так: =ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2;);"")
Точку с запятой потеряли (выделил красным)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
криво у меня получается
Вы не с форума скопировали формулу
Должно быть так: =ЕСЛИОШИБКА(ВПР(B2;G$2:H$6;2;);"")
Точку с запятой потеряли (выделил красным)

Автор - Serge_007
Дата добавления - 13.04.2022 в 11:32
TanyaKatana Дата: Среда, 13.04.2022, 11:35 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 20% ±

Спасибо. Все работает
 
Ответить
СообщениеСпасибо. Все работает

Автор - TanyaKatana
Дата добавления - 13.04.2022 в 11:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить таблицу данными из другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!