Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Значение ячейки в зависимости от порядка значений в строке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение ячейки в зависимости от порядка значений в строке (Формулы/Formulas)
Значение ячейки в зависимости от порядка значений в строке
brener Дата: Четверг, 14.04.2022, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые. Только на мудрость вашу уповаю ))
Есть диапазон данных из семи столбцов и больше 5000 строк, где содержатся неотрицательные числа. Задача в конце каждой строки диапазона поставить значение:
X – если значения в строке не уменьшаются (следующее больше или равно предыдущему);
Z – если между положительными числами или в ячейке последнего столбца диапазона встречается хотя бы один ноль;
Y – во всех остальных случаях, включая наличие нулей перед первым положительным значением.

Первый раз столкнулся с подобным, хотя бы ткните, пожалуйста, куда смотреть. Пример прилагаю.
К сообщению приложен файл: 0029956.xls(24.0 Kb)


Сообщение отредактировал brener - Четверг, 14.04.2022, 15:17
 
Ответить
СообщениеЗдравствуйте, уважаемые. Только на мудрость вашу уповаю ))
Есть диапазон данных из семи столбцов и больше 5000 строк, где содержатся неотрицательные числа. Задача в конце каждой строки диапазона поставить значение:
X – если значения в строке не уменьшаются (следующее больше или равно предыдущему);
Z – если между положительными числами или в ячейке последнего столбца диапазона встречается хотя бы один ноль;
Y – во всех остальных случаях, включая наличие нулей перед первым положительным значением.

Первый раз столкнулся с подобным, хотя бы ткните, пожалуйста, куда смотреть. Пример прилагаю.

Автор - brener
Дата добавления - 14.04.2022 в 15:17
_Boroda_ Дата: Четверг, 14.04.2022, 15:33 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
вопрос снят, сам сообразил


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Четверг, 14.04.2022, 15:35
 
Ответить
Сообщениевопрос снят, сам сообразил

Автор - _Boroda_
Дата добавления - 14.04.2022 в 15:33
Serge_007 Дата: Четверг, 14.04.2022, 15:39 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Здравствуйте

Попробуйте такую формулу массива (надо проверять):
Код
=ЕСЛИ(СУММ(--(B2:G2>C2:H2))=0;"X";ЕСЛИ(МИН((B2:G2=0)+(C2:H2>0));"Y";"Z"))
К сообщению приложен файл: 20220414_brener.xls(64.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Попробуйте такую формулу массива (надо проверять):
Код
=ЕСЛИ(СУММ(--(B2:G2>C2:H2))=0;"X";ЕСЛИ(МИН((B2:G2=0)+(C2:H2>0));"Y";"Z"))

Автор - Serge_007
Дата добавления - 14.04.2022 в 15:39
brener Дата: Четверг, 14.04.2022, 15:51 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Serge_007, ух ты! Интересный подход. Спасибо, пошёл проверять на боевых цифрах.

UPD Проверил руками первые сто строк. Тьфу-тьфу-тьфу, без сбоев.


Сообщение отредактировал brener - Четверг, 14.04.2022, 16:15
 
Ответить
СообщениеSerge_007, ух ты! Интересный подход. Спасибо, пошёл проверять на боевых цифрах.

UPD Проверил руками первые сто строк. Тьфу-тьфу-тьфу, без сбоев.

Автор - brener
Дата добавления - 14.04.2022 в 15:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Значение ячейки в зависимости от порядка значений в строке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!