Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование массива данных по времени - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование массива данных по времени (Формулы/Formulas)
Формирование массива данных по времени
maxpan09 Дата: Пятница, 15.04.2022, 14:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Есть набор массивов данных с датчиков. С каждого датчика приходит набор из 5 параметров раз в секунду, при этом каждый датчик имеет свою привязку ко времени. Можно ли как то показания с датчиков привести к одному времени. Сейчас решаю эту проблему перетаскиванием всего массива в нужную строку до совпадения времени соседнего массива. Проблема еще заключается в том что бывают пропущенные секунды по времени. То есть простой сортировкой это не решить. Пример фала во вложении.
К сообщению приложен файл: 3138960.xlsx(30.1 Kb)


Сообщение отредактировал maxpan09 - Пятница, 15.04.2022, 14:32
 
Ответить
СообщениеЕсть набор массивов данных с датчиков. С каждого датчика приходит набор из 5 параметров раз в секунду, при этом каждый датчик имеет свою привязку ко времени. Можно ли как то показания с датчиков привести к одному времени. Сейчас решаю эту проблему перетаскиванием всего массива в нужную строку до совпадения времени соседнего массива. Проблема еще заключается в том что бывают пропущенные секунды по времени. То есть простой сортировкой это не решить. Пример фала во вложении.

Автор - maxpan09
Дата добавления - 15.04.2022 в 14:09
Serge_007 Дата: Пятница, 15.04.2022, 14:22 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Здравствуйте

"Ожидаемый"результат" в файле - как получился?
Объясните на примере пары конкретных ячеек


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

"Ожидаемый"результат" в файле - как получился?
Объясните на примере пары конкретных ячеек

Автор - Serge_007
Дата добавления - 15.04.2022 в 14:22
maxpan09 Дата: Пятница, 15.04.2022, 14:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Перезалил файл примера
К сообщению приложен файл: 2348931.xlsx(30.1 Kb)
 
Ответить
СообщениеПерезалил файл примера

Автор - maxpan09
Дата добавления - 15.04.2022 в 14:30
_Boroda_ Дата: Пятница, 15.04.2022, 14:43 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I:I;ПОИСКПОЗ($A2;$H:$H;));"")
К сообщению приложен файл: 2348931_1.xlsx(31.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I:I;ПОИСКПОЗ($A2;$H:$H;));"")

Автор - _Boroda_
Дата добавления - 15.04.2022 в 14:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование массива данных по времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!