Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма чисел в столбце с пустыми ячейками - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел в столбце с пустыми ячейками (Формулы/Formulas)
Сумма чисел в столбце с пустыми ячейками
sergeyvislyaev Дата: Понедельник, 01.08.2022, 20:07 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Спасибо! Начал тестировать формулу Ника, Работает. Потом "отпишусь" еще.
Не сочтите за наглость, но если можно - можно, чтобы формула Ника (я пока рассматриваю ее) не учитывала ноль, т. е. чтобы ноль она считала как пустую ячейку. Спасибо!
 
Ответить
СообщениеСпасибо! Начал тестировать формулу Ника, Работает. Потом "отпишусь" еще.
Не сочтите за наглость, но если можно - можно, чтобы формула Ника (я пока рассматриваю ее) не учитывала ноль, т. е. чтобы ноль она считала как пустую ячейку. Спасибо!

Автор - sergeyvislyaev
Дата добавления - 01.08.2022 в 20:07
_Boroda_ Дата: Вторник, 02.08.2022, 10:41 | Сообщение № 22
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16369
Репутация: 6355 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=СУММ(B3:ИНДЕКС(B:B;ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/B3:B49);СТРОКА(3:49));3);49)))

Тоже формула массива
К сообщению приложен файл: 9852601_1.xls(34.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=СУММ(B3:ИНДЕКС(B:B;ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/B3:B49);СТРОКА(3:49));3);49)))

Тоже формула массива

Автор - _Boroda_
Дата добавления - 02.08.2022 в 10:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел в столбце с пустыми ячейками (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!