Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рассчитатат сумму по каждому наименованию и поставщику - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитатат сумму по каждому наименованию и поставщику (Формулы/Formulas)
Рассчитатат сумму по каждому наименованию и поставщику
mishura08 Дата: Среда, 27.04.2022, 13:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Доброго времени, возникла задача, как решить - не знаю..
Суть задачи:
Выполните расчеты в диапазоне ячеек J27:J34, используя данные в диапазоне A1:D32:
рассчитайте сумму по каждому наименованию и поставщику фруктов.
Уже весь интернет перерыл, нашел похожее, но оно не работает.
К сообщению приложен файл: 3762157.xlsx(9.8 Kb)


Сообщение отредактировал mishura08 - Среда, 27.04.2022, 13:11
 
Ответить
СообщениеДоброго времени, возникла задача, как решить - не знаю..
Суть задачи:
Выполните расчеты в диапазоне ячеек J27:J34, используя данные в диапазоне A1:D32:
рассчитайте сумму по каждому наименованию и поставщику фруктов.
Уже весь интернет перерыл, нашел похожее, но оно не работает.

Автор - mishura08
Дата добавления - 27.04.2022 в 13:10
Serge_007 Дата: Среда, 27.04.2022, 13:23 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15157
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=СУММПРОИЗВ((C$2:C$32=ПОДСТАВИТЬ(H27;"""";))*(B$2:B$32=I27)*D$2:D$32)
Код
=СУММЕСЛИМН(D$2:D$32;B$2:B$32;I27;C$2:C$32;ПОДСТАВИТЬ(H27;"""";))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=СУММПРОИЗВ((C$2:C$32=ПОДСТАВИТЬ(H27;"""";))*(B$2:B$32=I27)*D$2:D$32)
Код
=СУММЕСЛИМН(D$2:D$32;B$2:B$32;I27;C$2:C$32;ПОДСТАВИТЬ(H27;"""";))

Автор - Serge_007
Дата добавления - 27.04.2022 в 13:23
mishura08 Дата: Среда, 27.04.2022, 13:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Вы волшебник, спасибо большое. Осталось разобраться как эта формула работает.


Сообщение отредактировал Serge_007 - Среда, 27.04.2022, 13:25
 
Ответить
СообщениеВы волшебник, спасибо большое. Осталось разобраться как эта формула работает.

Автор - mishura08
Дата добавления - 27.04.2022 в 13:25
Serge_007 Дата: Среда, 27.04.2022, 13:31 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15157
Репутация: 2503 ±
Замечаний: ±

Excel 2016
как эта формула работает
Вот эта часть ПОДСТАВИТЬ(H27;"""";) позволяет формуле игнорировать все кавычки в названиях поставщиков (в верхней таблицы эти названия без кавычек)

Далее мы просто перемножаем соответствующие массивы, например B$2:B$32=I27 возвращает массив
{ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА}
, что означает совпадения во второй, пятой, девятой и т.д. строках (апельсины)
Все ИСТИНА в результате перемножения превращаются в 1, а ЛОЖЬ - в 0

Ну и в конце - все единицы умножаем на значения из столбца Сумма: *D$2:D$32


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как эта формула работает
Вот эта часть ПОДСТАВИТЬ(H27;"""";) позволяет формуле игнорировать все кавычки в названиях поставщиков (в верхней таблицы эти названия без кавычек)

Далее мы просто перемножаем соответствующие массивы, например B$2:B$32=I27 возвращает массив
{ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ЛОЖЬ:ИСТИНА}
, что означает совпадения во второй, пятой, девятой и т.д. строках (апельсины)
Все ИСТИНА в результате перемножения превращаются в 1, а ЛОЖЬ - в 0

Ну и в конце - все единицы умножаем на значения из столбца Сумма: *D$2:D$32

Автор - Serge_007
Дата добавления - 27.04.2022 в 13:31
mishura08 Дата: Среда, 27.04.2022, 13:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Огромное спасибо


Сообщение отредактировал Serge_007 - Среда, 27.04.2022, 13:54
 
Ответить
СообщениеОгромное спасибо

Автор - mishura08
Дата добавления - 27.04.2022 в 13:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитатат сумму по каждому наименованию и поставщику (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!