Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти 3 одинаковых числа в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти 3 одинаковых числа в столбце (Формулы/Formulas)
Найти 3 одинаковых числа в столбце
pain2430 Дата: Среда, 04.05.2022, 01:54 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Приветствую. Прошу помощи в решении такой задачи:
В столбце числа, нужна формула которая находит два повторяющихся значения, затем если (сразу) или через несколько значений находит третий повтор - отображать это, если не находит и случился новый повтор, искать третье значение нового повтора.
Более подробно в прикрепленном примере. Спасибо!
К сообщению приложен файл: _1.xlsx(10.3 Kb)
 
Ответить
СообщениеПриветствую. Прошу помощи в решении такой задачи:
В столбце числа, нужна формула которая находит два повторяющихся значения, затем если (сразу) или через несколько значений находит третий повтор - отображать это, если не находит и случился новый повтор, искать третье значение нового повтора.
Более подробно в прикрепленном примере. Спасибо!

Автор - pain2430
Дата добавления - 04.05.2022 в 01:54
bmv98rus Дата: Среда, 04.05.2022, 10:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3926
Репутация: 707 ±
Замечаний: 0% ±

Excel 2013/2016
pain2430, Нужен результат или результат одной формулой? Дело в том что
если не находит и случился новый повтор, искать третье значение нового повтора.
если и возможно то организуется одной формулой очень не просто.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеpain2430, Нужен результат или результат одной формулой? Дело в том что
если не находит и случился новый повтор, искать третье значение нового повтора.
если и возможно то организуется одной формулой очень не просто.

Автор - bmv98rus
Дата добавления - 04.05.2022 в 10:33
pain2430 Дата: Среда, 04.05.2022, 11:43 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Нужен результат или результат одной формулой?

Нужен результат, если одной формулой это сделать невозможно, можно и несколько формул. Спасибо!
 
Ответить
Сообщение
Нужен результат или результат одной формулой?

Нужен результат, если одной формулой это сделать невозможно, можно и несколько формул. Спасибо!

Автор - pain2430
Дата добавления - 04.05.2022 в 11:43
bmv98rus Дата: Среда, 04.05.2022, 12:59 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3926
Репутация: 707 ±
Замечаний: 0% ±

Excel 2013/2016
Не знаю зачем "Не нашли третье" попробуйте
R2 и далее
Код
=IF((IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)<>"Случилось")*(IFERROR(LOOKUP(2;1/(R$1:R1="Нашли второе");A$1:A1);)=A2);"Случилось";IF(COUNTIF(INDEX(A:A;IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));ROW(R$1:R1));)+1):A2;A2)=1;"";"Нашли второе"))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеНе знаю зачем "Не нашли третье" попробуйте
R2 и далее
Код
=IF((IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)<>"Случилось")*(IFERROR(LOOKUP(2;1/(R$1:R1="Нашли второе");A$1:A1);)=A2);"Случилось";IF(COUNTIF(INDEX(A:A;IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));ROW(R$1:R1));)+1):A2;A2)=1;"";"Нашли второе"))

Автор - bmv98rus
Дата добавления - 04.05.2022 в 12:59
pain2430 Дата: Среда, 04.05.2022, 14:24 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Спасибо Вам большое, Вы как всегда гениальны.
"Не нашли третье" - все таки нужно мне для расчетов,может все таки можно всунуть этот параметр? если не в одну формулу, то хотя бы рядом? Спасибо!


Сообщение отредактировал Serge_007 - Среда, 04.05.2022, 15:32
 
Ответить
СообщениеСпасибо Вам большое, Вы как всегда гениальны.
"Не нашли третье" - все таки нужно мне для расчетов,может все таки можно всунуть этот параметр? если не в одну формулу, то хотя бы рядом? Спасибо!

Автор - pain2430
Дата добавления - 04.05.2022 в 14:24
pain2430 Дата: Среда, 04.05.2022, 15:31 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Не знаю зачем "Не нашли третье" попробуйте
R2 и далее

Все, решил проблему путем формулы рядом.
Код
=ЕСЛИ(R2="Случилось";"";ЕСЛИ(ПРОСМОТР(999999;1/(R$1:R1<>"");R$1:R1)="Нашли второе";"Не нашли третье";""))


Спасибо Вам огромное за помощь!
 
Ответить
Сообщение
Не знаю зачем "Не нашли третье" попробуйте
R2 и далее

Все, решил проблему путем формулы рядом.
Код
=ЕСЛИ(R2="Случилось";"";ЕСЛИ(ПРОСМОТР(999999;1/(R$1:R1<>"");R$1:R1)="Нашли второе";"Не нашли третье";""))


Спасибо Вам огромное за помощь!

Автор - pain2430
Дата добавления - 04.05.2022 в 15:31
bmv98rus Дата: Среда, 04.05.2022, 16:28 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3926
Репутация: 707 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF((IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)<>"Случилось")*(IFERROR(LOOKUP(2;1/(R$1:R1="Нашли второе");A$1:A1);)=A2);"Случилось";IF(COUNTIF(INDEX(A:A;IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));ROW(R$1:R1));)+1):A2;A2)=1;IF(IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)="Нашли второе";"Не нашли третье";"");"Нашли второе"))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=IF((IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)<>"Случилось")*(IFERROR(LOOKUP(2;1/(R$1:R1="Нашли второе");A$1:A1);)=A2);"Случилось";IF(COUNTIF(INDEX(A:A;IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));ROW(R$1:R1));)+1):A2;A2)=1;IF(IFERROR(LOOKUP(2;1/((R$1:R1="Нашли второе")+(R$1:R1="Случилось"));R$1:R1);)="Нашли второе";"Не нашли третье";"");"Нашли второе"))

Автор - bmv98rus
Дата добавления - 04.05.2022 в 16:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти 3 одинаковых числа в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!