Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упростить формулу для вычисления по указанному месяцу - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу для вычисления по указанному месяцу (Формулы/Formulas)
Упростить формулу для вычисления по указанному месяцу
remis8423 Дата: Среда, 18.05.2022, 08:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Хотелось бы упростить формулу для вычисления количества вещества по указанному месяцу (получилась слишком большая)

Код
=ЕСЛИ(F3="январь";Лист2!H372;0)+ЕСЛИ(F3="февраль";Лист2!H373;0)+ЕСЛИ(F3="март";Лист2!H374;0)+ЕСЛИ(F3="апрель";Лист2!H375;0)+ЕСЛИ(F3="май";Лист2!H376;0)+ЕСЛИ(F3="июнь";Лист2!H377;0)+ЕСЛИ(F3="июль";Лист2!H378;0)+ЕСЛИ(F3="август";Лист2!H379;0)+ЕСЛИ(F3="сентябрь";Лист2!H380;0)+ЕСЛИ(F3="октябрь";Лист2!H381;0)+ЕСЛИ(F3="ноябрь";Лист2!H382;0)+ЕСЛИ(F3="декабрь";Лист2!H383;0)


Файл примера выкладываю.
К сообщению приложен файл: 6398004.xlsx(25.1 Kb)
 
Ответить
СообщениеДобрый день!
Хотелось бы упростить формулу для вычисления количества вещества по указанному месяцу (получилась слишком большая)

Код
=ЕСЛИ(F3="январь";Лист2!H372;0)+ЕСЛИ(F3="февраль";Лист2!H373;0)+ЕСЛИ(F3="март";Лист2!H374;0)+ЕСЛИ(F3="апрель";Лист2!H375;0)+ЕСЛИ(F3="май";Лист2!H376;0)+ЕСЛИ(F3="июнь";Лист2!H377;0)+ЕСЛИ(F3="июль";Лист2!H378;0)+ЕСЛИ(F3="август";Лист2!H379;0)+ЕСЛИ(F3="сентябрь";Лист2!H380;0)+ЕСЛИ(F3="октябрь";Лист2!H381;0)+ЕСЛИ(F3="ноябрь";Лист2!H382;0)+ЕСЛИ(F3="декабрь";Лист2!H383;0)


Файл примера выкладываю.

Автор - remis8423
Дата добавления - 18.05.2022 в 08:27
Nic70y Дата: Среда, 18.05.2022, 08:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
если привести наименование в соот. друг другу, то можно так
Код
=ИНДЕКС(Лист2!$B$371:$J$383;ПОИСКПОЗ($F$3;Лист2!$A$372:$A$383;);ПОИСКПОЗ($B12;Лист2!$B$3:$J$3;))
К сообщению приложен файл: 12.xlsx(25.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеесли привести наименование в соот. друг другу, то можно так
Код
=ИНДЕКС(Лист2!$B$371:$J$383;ПОИСКПОЗ($F$3;Лист2!$A$372:$A$383;);ПОИСКПОЗ($B12;Лист2!$B$3:$J$3;))

Автор - Nic70y
Дата добавления - 18.05.2022 в 08:34
and_evg Дата: Среда, 18.05.2022, 08:35 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 412
Репутация: 71 ±
Замечаний: 0% ±

Excel 2007
Добрый день:
Код
=ВПР(F3;Лист2!$A$371:$H$383;8;ЛОЖЬ)
 
Ответить
СообщениеДобрый день:
Код
=ВПР(F3;Лист2!$A$371:$H$383;8;ЛОЖЬ)

Автор - and_evg
Дата добавления - 18.05.2022 в 08:35
remis8423 Дата: Среда, 18.05.2022, 09:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, при других месяцах формула некорректно работает.
 
Ответить
СообщениеNic70y, при других месяцах формула некорректно работает.

Автор - remis8423
Дата добавления - 18.05.2022 в 09:21
Nic70y Дата: Среда, 18.05.2022, 09:41 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
remis8423, какие Ваши доказательства?©


ЮMoney 41001841029809
 
Ответить
Сообщениеremis8423, какие Ваши доказательства?©

Автор - Nic70y
Дата добавления - 18.05.2022 в 09:41
remis8423 Дата: Среда, 18.05.2022, 09:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, поставьте месяц февраль - ничего не меняется.
 
Ответить
СообщениеNic70y, поставьте месяц февраль - ничего не меняется.

Автор - remis8423
Дата добавления - 18.05.2022 в 09:47
Serge_007 Дата: Среда, 18.05.2022, 10:01 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
remis8423, в формуле замените 371 на 372


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеremis8423, в формуле замените 371 на 372

Автор - Serge_007
Дата добавления - 18.05.2022 в 10:01
Nic70y Дата: Среда, 18.05.2022, 10:01 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
ИНДЕКС(Лист2!$B$372:$J$383
со зрением у меня хреново


ЮMoney 41001841029809
 
Ответить
СообщениеИНДЕКС(Лист2!$B$372:$J$383
со зрением у меня хреново

Автор - Nic70y
Дата добавления - 18.05.2022 в 10:01
remis8423 Дата: Среда, 18.05.2022, 10:13 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Спасибо! Теперь работает.
 
Ответить
СообщениеСпасибо! Теперь работает.

Автор - remis8423
Дата добавления - 18.05.2022 в 10:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу для вычисления по указанному месяцу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!