Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск одновременно значения в 3-х Листах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск одновременно значения в 3-х Листах (Формулы/Formulas)
Поиск одновременно значения в 3-х Листах
Rambo Дата: Понедельник, 23.05.2022, 12:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня,
В общем, пытаюсь разобраться как произвести поиск и возвращение найденного значения значений с помощью ИНДЕКС и ПОИСКПОЗ
одновременно

Разбил формулу на несколько этапов , уже 2-й день мучаюсь, не выходит сделать поиск одновременный на 3-х листах
Возможно где-то накосячил...(не возможно а точно)))

Файл простейшего тэста вложил..
Изначально такую формулу намудрил
Код
=ЕСНД(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0);"")

потом немного облагородив начал работать с Условиями.

Код
=ЕСНД(ИЛИ(ЕОШИБКА(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0));ЕОШИБКА(ИНДЕКС(test002!C:C;ПОИСКПОЗ($A2;test002!A:A;0);0));ЕОШИБКА(ИНДЕКС(test003!C:C;ПОИСКПОЗ($A2;test003!A:A;0);0)));"")

--
Так-же прошу совета -Дополнить , Если на одном из других листом Вдруг повторится (задублируется значение) каким образом сделать исключение?



Заранее благодарен за помощь.!
К сообщению приложен файл: TEST_.xlsx(14.4 Kb)


Сообщение отредактировал Rambo - Понедельник, 23.05.2022, 12:46
 
Ответить
СообщениеДоброго дня,
В общем, пытаюсь разобраться как произвести поиск и возвращение найденного значения значений с помощью ИНДЕКС и ПОИСКПОЗ
одновременно

Разбил формулу на несколько этапов , уже 2-й день мучаюсь, не выходит сделать поиск одновременный на 3-х листах
Возможно где-то накосячил...(не возможно а точно)))

Файл простейшего тэста вложил..
Изначально такую формулу намудрил
Код
=ЕСНД(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0);"")

потом немного облагородив начал работать с Условиями.

Код
=ЕСНД(ИЛИ(ЕОШИБКА(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0));ЕОШИБКА(ИНДЕКС(test002!C:C;ПОИСКПОЗ($A2;test002!A:A;0);0));ЕОШИБКА(ИНДЕКС(test003!C:C;ПОИСКПОЗ($A2;test003!A:A;0);0)));"")

--
Так-же прошу совета -Дополнить , Если на одном из других листом Вдруг повторится (задублируется значение) каким образом сделать исключение?



Заранее благодарен за помощь.!

Автор - Rambo
Дата добавления - 23.05.2022 в 12:42
Rambo Дата: Понедельник, 23.05.2022, 15:22 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Вобщем, Поиск по 3-м Листам Сделал через ЕСЛИ

Код
=ЕСЛИОШИБКА(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0);ЕСЛИОШИБКА(ИНДЕКС(test002!C:C;ПОИСКПОЗ($A2;test002!A:A;0);0);ЕСЛИОШИБКА(ИНДЕКС(test003!C:C;ПОИСКПОЗ($A2;test003!A:A;0);0);"")))



Единственное , Если в соседнем листе находится дублирующее значение, то собственно берется 1-вое по очереди, т.е. начиная с таблицы test001 потом test002 и test003

Пояснения , т.е. Если гипотетически в каждом их этих листов в Стобце A- например задублируется TESTING012 , то из колонки C возьмется значение с 1-го листа, а остальные как я понял игнорируются.
 
Ответить
СообщениеВобщем, Поиск по 3-м Листам Сделал через ЕСЛИ

Код
=ЕСЛИОШИБКА(ИНДЕКС(test001!C:C;ПОИСКПОЗ($A2;test001!A:A;0);0);ЕСЛИОШИБКА(ИНДЕКС(test002!C:C;ПОИСКПОЗ($A2;test002!A:A;0);0);ЕСЛИОШИБКА(ИНДЕКС(test003!C:C;ПОИСКПОЗ($A2;test003!A:A;0);0);"")))



Единственное , Если в соседнем листе находится дублирующее значение, то собственно берется 1-вое по очереди, т.е. начиная с таблицы test001 потом test002 и test003

Пояснения , т.е. Если гипотетически в каждом их этих листов в Стобце A- например задублируется TESTING012 , то из колонки C возьмется значение с 1-го листа, а остальные как я понял игнорируются.

Автор - Rambo
Дата добавления - 23.05.2022 в 15:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск одновременно значения в 3-х Листах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!