Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет среднего итогового процента, с учетом округлений и фо - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет среднего итогового процента, с учетом округлений и фо (Формулы/Formulas)
Расчет среднего итогового процента, с учетом округлений и фо
zhenchkashadrin66 Дата: Среда, 25.05.2022, 08:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Помогите, пожалуйста, с формированием формул для расчета среднего итогового процента, с учетом округлений и ячеек в которых значений нет.
Необходимые условия:
ЕСЛИ В СТОЛБЦЕ С - (НЕТ ЗНАЧЕНИЯ), ТО В СТОЛБЦЕ Д 0
ЕСЛИ В СТОЛБЦЕ Д БОЛЬШЕ 100, ТО 100
ФОРМУЛА СУММы СРЕДНЕГО ПРОЦЕНТА
К сообщению приложен файл: 5117298.xlsx(11.6 Kb)
 
Ответить
СообщениеЗдравствуйте! Помогите, пожалуйста, с формированием формул для расчета среднего итогового процента, с учетом округлений и ячеек в которых значений нет.
Необходимые условия:
ЕСЛИ В СТОЛБЦЕ С - (НЕТ ЗНАЧЕНИЯ), ТО В СТОЛБЦЕ Д 0
ЕСЛИ В СТОЛБЦЕ Д БОЛЬШЕ 100, ТО 100
ФОРМУЛА СУММы СРЕДНЕГО ПРОЦЕНТА

Автор - zhenchkashadrin66
Дата добавления - 25.05.2022 в 08:28
DrMini Дата: Среда, 25.05.2022, 09:14 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток.
Цитата zhenchkashadrin66, 25.05.2022 в 08:28, в сообщении № 1 ()
ЕСЛИ В СТОЛБЦЕ С - (НЕТ ЗНАЧЕНИЯ), ТО В СТОЛБЦЕ Д 0
ЕСЛИ В СТОЛБЦЕ Д БОЛЬШЕ 100, ТО 100

Так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ОКРУГЛВВЕРХ(((C2*100)/B2)*100%;0,1)>=100;100;ОКРУГЛВВЕРХ(((C2*100)/B2)*100%;0,1));"")
 
Ответить
СообщениеДоброго времени суток.
Цитата zhenchkashadrin66, 25.05.2022 в 08:28, в сообщении № 1 ()
ЕСЛИ В СТОЛБЦЕ С - (НЕТ ЗНАЧЕНИЯ), ТО В СТОЛБЦЕ Д 0
ЕСЛИ В СТОЛБЦЕ Д БОЛЬШЕ 100, ТО 100

Так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ОКРУГЛВВЕРХ(((C2*100)/B2)*100%;0,1)>=100;100;ОКРУГЛВВЕРХ(((C2*100)/B2)*100%;0,1));"")

Автор - DrMini
Дата добавления - 25.05.2022 в 09:14
_Boroda_ Дата: Среда, 25.05.2022, 09:15 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16357
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=МИН(ОКРУГЛВВЕРХ(Ч(C2)*100/B2;0,1);100)
К сообщению приложен файл: 5117298_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=МИН(ОКРУГЛВВЕРХ(Ч(C2)*100/B2;0,1);100)

Автор - _Boroda_
Дата добавления - 25.05.2022 в 09:15
zhenchkashadrin66 Дата: Среда, 25.05.2022, 09:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо за ответы, за это время самостоятельно получилось, хоть и сложноватая формула для меня.
С суммой среднего процента разобраться не получается
 
Ответить
СообщениеСпасибо за ответы, за это время самостоятельно получилось, хоть и сложноватая формула для меня.
С суммой среднего процента разобраться не получается

Автор - zhenchkashadrin66
Дата добавления - 25.05.2022 в 09:26
DrMini Дата: Среда, 25.05.2022, 09:26 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Цитата zhenchkashadrin66, 25.05.2022 в 08:28, в сообщении № 1 ()
ФОРМУЛА СУММы СРЕДНЕГО ПРОЦЕНТА

Код
=СРЗНАЧ(D2:D10)
 
Ответить
Сообщение
Цитата zhenchkashadrin66, 25.05.2022 в 08:28, в сообщении № 1 ()
ФОРМУЛА СУММы СРЕДНЕГО ПРОЦЕНТА

Код
=СРЗНАЧ(D2:D10)

Автор - DrMini
Дата добавления - 25.05.2022 в 09:26
ShAM Дата: Среда, 25.05.2022, 09:28 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1336
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Ну и проценты:
Код
=СРЗНАЧ(D2:D10)
с учетом нулей.
Код
=СРЗНАЧЕСЛИ(D2:D10;">0";D2:D10)
без учета нулей.
 
Ответить
СообщениеНу и проценты:
Код
=СРЗНАЧ(D2:D10)
с учетом нулей.
Код
=СРЗНАЧЕСЛИ(D2:D10;">0";D2:D10)
без учета нулей.

Автор - ShAM
Дата добавления - 25.05.2022 в 09:28
zhenchkashadrin66 Дата: Среда, 25.05.2022, 09:29 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

=СРЗНАЧ(D2:D10)


Нужно не среднее число, а именно сумму
К сообщению приложен файл: 3373287.xlsx(11.4 Kb)
 
Ответить
Сообщение
=СРЗНАЧ(D2:D10)


Нужно не среднее число, а именно сумму

Автор - zhenchkashadrin66
Дата добавления - 25.05.2022 в 09:29
_Boroda_ Дата: Среда, 25.05.2022, 09:35 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16357
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, там нужно сложить факт, который с дефектами, сложить дефекты, а потом разделить одно на другое
Код
=МИН(ОКРУГЛВВЕРХ(СУММ(ЕСЛИ(Ч(+C2:C10);B2:B10;))*100/СУММ(C2:C10);0,1);100)
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Если складывать вообще весь факт, то проще
Код
=МИН(ОКРУГЛВВЕРХ(СУММ(B2:B10)*100/СУММ(C2:C10);0,1);100)


Как Вам нужно методически - я не знаю, поэтому два варианта
К сообщению приложен файл: 5117298_2.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, там нужно сложить факт, который с дефектами, сложить дефекты, а потом разделить одно на другое
Код
=МИН(ОКРУГЛВВЕРХ(СУММ(ЕСЛИ(Ч(+C2:C10);B2:B10;))*100/СУММ(C2:C10);0,1);100)
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер

Если складывать вообще весь факт, то проще
Код
=МИН(ОКРУГЛВВЕРХ(СУММ(B2:B10)*100/СУММ(C2:C10);0,1);100)


Как Вам нужно методически - я не знаю, поэтому два варианта

Автор - _Boroda_
Дата добавления - 25.05.2022 в 09:35
zhenchkashadrin66 Дата: Среда, 25.05.2022, 09:41 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

=МИН(ОКРУГЛВВЕРХ(СУММ(B2:B10)*100/СУММ(C2:C10);0,1);100)

СПАСИБО БОЛЬШОЕ, ХОРОШЕГО ДНЯ!
ВСЁ ПОЛУЧИЛОСЬ hands
 
Ответить
Сообщение
=МИН(ОКРУГЛВВЕРХ(СУММ(B2:B10)*100/СУММ(C2:C10);0,1);100)

СПАСИБО БОЛЬШОЕ, ХОРОШЕГО ДНЯ!
ВСЁ ПОЛУЧИЛОСЬ hands

Автор - zhenchkashadrin66
Дата добавления - 25.05.2022 в 09:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет среднего итогового процента, с учетом округлений и фо (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!