Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сформировать таблицу на основе строки с определенной датой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать таблицу на основе строки с определенной датой (Формулы/Formulas)
Сформировать таблицу на основе строки с определенной датой
fomkamchatka Дата: Вторник, 31.05.2022, 15:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Приветствую.
В прикрепленном файле 3 листа. На 3 листе (За день) хочется, чтобы формировалась таблица на основе данных из листа 1 (Реестр отгрузок) за определенную дату. Дата берется из листа 2 (ввод данных). Больше оттуда нас ничего не интересует. Лист 1 ежедневно дополняется, т.е. добавляются новые даты. Так вот, необходимы суммарные значения за соответствующую дату по направлениям. Т.е. за один день может быть 3 отправки на Ростов и 3 Махачкалу. В итоге мне нужен суммарный объем по каждому направлению за указанный день. Объем и вес. Остальные значения в данном случае не интересуют. Подскажите, как такое можно реализовать?
Спасибо.
К сообщению приложен файл: 0531630.xlsm(47.1 Kb)
 
Ответить
СообщениеПриветствую.
В прикрепленном файле 3 листа. На 3 листе (За день) хочется, чтобы формировалась таблица на основе данных из листа 1 (Реестр отгрузок) за определенную дату. Дата берется из листа 2 (ввод данных). Больше оттуда нас ничего не интересует. Лист 1 ежедневно дополняется, т.е. добавляются новые даты. Так вот, необходимы суммарные значения за соответствующую дату по направлениям. Т.е. за один день может быть 3 отправки на Ростов и 3 Махачкалу. В итоге мне нужен суммарный объем по каждому направлению за указанный день. Объем и вес. Остальные значения в данном случае не интересуют. Подскажите, как такое можно реализовать?
Спасибо.

Автор - fomkamchatka
Дата добавления - 31.05.2022 в 15:24
Serge_007 Дата: Вторник, 31.05.2022, 15:33 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте

Если привести исходные данные в вид БД (убрать объединенные ячейки), то самый простой и удобный способ - использовать сводную таблицу (см. вложение)
К сообщению приложен файл: 20220531_fomkam.xls(210.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Если привести исходные данные в вид БД (убрать объединенные ячейки), то самый простой и удобный способ - использовать сводную таблицу (см. вложение)

Автор - Serge_007
Дата добавления - 31.05.2022 в 15:33
msi2102 Дата: Вторник, 31.05.2022, 15:39 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Если привести исходные данные в вид БД (убрать объединенные ячейки),

Можно формулой
Код
=СУММЕСЛИМН('Реестр отгрузок'!$E$3:$E$108;'Реестр отгрузок'!$A$3:$A$108;$E$2;'Реестр отгрузок'!$C$3:$C$108;D4)

или
Код
=СУММПРОИЗВ(('Реестр отгрузок'!$A$3:$A$108=$E$2)*('Реестр отгрузок'!$C$3:$C$108=D4)*'Реестр отгрузок'!$E$3:$E$108)
К сообщению приложен файл: 0456934.xlsm(47.9 Kb)


Сообщение отредактировал msi2102 - Вторник, 31.05.2022, 15:47
 
Ответить
Сообщение
Если привести исходные данные в вид БД (убрать объединенные ячейки),

Можно формулой
Код
=СУММЕСЛИМН('Реестр отгрузок'!$E$3:$E$108;'Реестр отгрузок'!$A$3:$A$108;$E$2;'Реестр отгрузок'!$C$3:$C$108;D4)

или
Код
=СУММПРОИЗВ(('Реестр отгрузок'!$A$3:$A$108=$E$2)*('Реестр отгрузок'!$C$3:$C$108=D4)*'Реестр отгрузок'!$E$3:$E$108)

Автор - msi2102
Дата добавления - 31.05.2022 в 15:39
fomkamchatka Дата: Пятница, 03.06.2022, 12:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, msi2102 Спасибо. И то и то подходит. Весьма благодарен.


Сообщение отредактировал fomkamchatka - Пятница, 03.06.2022, 12:08
 
Ответить
СообщениеSerge_007, msi2102 Спасибо. И то и то подходит. Весьма благодарен.

Автор - fomkamchatka
Дата добавления - 03.06.2022 в 12:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать таблицу на основе строки с определенной датой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!