Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула ГПР в некоторых ячейках пишет #ЗНАЧ! - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула ГПР в некоторых ячейках пишет #ЗНАЧ! (Формулы/Formulas)
формула ГПР в некоторых ячейках пишет #ЗНАЧ!
Экономист4383 Дата: Среда, 01.06.2022, 16:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

Добрый день, помогите решить проблемму. При использовании формулы ГПР в большинстве ячеек пишет #ЗНАЧ!
К сообщению приложен файл: 7486116.xlsx(12.7 Kb)
 
Ответить
СообщениеДобрый день, помогите решить проблемму. При использовании формулы ГПР в большинстве ячеек пишет #ЗНАЧ!

Автор - Экономист4383
Дата добавления - 01.06.2022 в 16:07
bigor Дата: Среда, 01.06.2022, 16:21 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 628
Репутация: 124 ±
Замечаний: 0% ±

нет
Добрый.
У меня только среднюю скорость не находит
К сообщению приложен файл: 9473837.png(81.2 Kb)


Сообщение отредактировал bigor - Среда, 01.06.2022, 16:24
 
Ответить
СообщениеДобрый.
У меня только среднюю скорость не находит

Автор - bigor
Дата добавления - 01.06.2022 в 16:21
msi2102 Дата: Среда, 01.06.2022, 16:22 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 65 ±
Замечаний: 0% ±

Excel 2007
Цитата Экономист4383, 01.06.2022 в 16:07, в сообщении № 1 ()
При использовании формулы ГПР

А Вы уверены, что именно ГПР нужно, почитайте справку про нее ТУТ
 
Ответить
Сообщение
Цитата Экономист4383, 01.06.2022 в 16:07, в сообщении № 1 ()
При использовании формулы ГПР

А Вы уверены, что именно ГПР нужно, почитайте справку про нее ТУТ

Автор - msi2102
Дата добавления - 01.06.2022 в 16:22
Экономист4383 Дата: Среда, 01.06.2022, 16:40 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

bigor, вы меняли формулу? Если да, подскажите, пожалуйста, я уже замучилась с этой таблицей
 
Ответить
Сообщениеbigor, вы меняли формулу? Если да, подскажите, пожалуйста, я уже замучилась с этой таблицей

Автор - Экономист4383
Дата добавления - 01.06.2022 в 16:40
_Boroda_ Дата: Среда, 01.06.2022, 16:46 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16215
Репутация: 6297 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так-то все нормально, но
1. Слишком длинный текст в ПОИСКПОЗ
2. Названия шапок неодинаковые на листах
3. Это формула массива. Вводится одновременным нажатием Контрл Шифт Ентер (Это в файле есть, не заметил сразу)

Можно вот так написать
Код
=СУММПРОИЗВ(($B3='Расчет норм'!$B$2:$B$7)*($C3='Расчет норм'!$C$2:$C$7)*($D3='Расчет норм'!$D$2:$D$7)*ЕЧИСЛО(ПОИСК(I$2;'Расчет норм'!$G$1:$V$1))*'Расчет норм'!$G$2:$V$7)

В формулу не все условия ввел, допишите самостоятельно
К сообщению приложен файл: 7486116_1.xlsx(12.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак-то все нормально, но
1. Слишком длинный текст в ПОИСКПОЗ
2. Названия шапок неодинаковые на листах
3. Это формула массива. Вводится одновременным нажатием Контрл Шифт Ентер (Это в файле есть, не заметил сразу)

Можно вот так написать
Код
=СУММПРОИЗВ(($B3='Расчет норм'!$B$2:$B$7)*($C3='Расчет норм'!$C$2:$C$7)*($D3='Расчет норм'!$D$2:$D$7)*ЕЧИСЛО(ПОИСК(I$2;'Расчет норм'!$G$1:$V$1))*'Расчет норм'!$G$2:$V$7)

В формулу не все условия ввел, допишите самостоятельно

Автор - _Boroda_
Дата добавления - 01.06.2022 в 16:46
Экономист4383 Дата: Среда, 01.06.2022, 16:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

_Boroda_, Спасобо большое!!!
 
Ответить
Сообщение_Boroda_, Спасобо большое!!!

Автор - Экономист4383
Дата добавления - 01.06.2022 в 16:57
bigorq Дата: Среда, 01.06.2022, 18:08 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 25 ±
Замечаний: 0% ±

Нет
Экономист4383, формулу не менял. Но у меня не MSO
 
Ответить
СообщениеЭкономист4383, формулу не менял. Но у меня не MSO

Автор - bigorq
Дата добавления - 01.06.2022 в 18:08
bmv98rus Дата: Среда, 01.06.2022, 20:11 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3943
Репутация: 721 ±
Замечаний: 0% ±

Excel 2013/2016
Я б вот так делал
Код
=SUMIFS(INDEX('Расчет норм'!$1:$1048576;;MATCH(I$2;'Расчет норм'!$1:$1;));'Расчет норм'!$B:$B;$B3;'Расчет норм'!$C:$C;$C3;'Расчет норм'!$D:$D;$D3;'Расчет норм'!$E:$E;$E3;'Расчет норм'!$F:$F;$F3)
точно не медленнее и все условия ввел , а то бородатор разленился.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 01.06.2022, 20:12
 
Ответить
СообщениеЯ б вот так делал
Код
=SUMIFS(INDEX('Расчет норм'!$1:$1048576;;MATCH(I$2;'Расчет норм'!$1:$1;));'Расчет норм'!$B:$B;$B3;'Расчет норм'!$C:$C;$C3;'Расчет норм'!$D:$D;$D3;'Расчет норм'!$E:$E;$E3;'Расчет норм'!$F:$F;$F3)
точно не медленнее и все условия ввел , а то бородатор разленился.

Автор - bmv98rus
Дата добавления - 01.06.2022 в 20:11
Экономист4383 Дата: Четверг, 02.06.2022, 15:19 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 20% ±

bmv98rus, Спасибо!!!
 
Ответить
Сообщениеbmv98rus, Спасибо!!!

Автор - Экономист4383
Дата добавления - 02.06.2022 в 15:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула ГПР в некоторых ячейках пишет #ЗНАЧ! (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!