Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в массиве при неточных исходных данных поиска - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве при неточных исходных данных поиска (Формулы/Formulas)
Поиск в массиве при неточных исходных данных поиска
igrtsk Дата: Четверг, 30.06.2022, 11:39 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 304
Репутация: 50 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Прошу помощи в написании формулы: необходимо формулой выполнять поиск в массиве данных, если искомые числовые значения непосредственно не содержатся среди исходных данных.

Например, в столбце "толщина проводника" есть значения 12, 18 и т.д.
1-е условие поиска заданное пользователем "толщина проводника" равно 14 (в столбце поиска это значение отсутствует, но находится между 12 и 18),
2-е условие поиска "ширина проводника" равно 0,12 (в строке поиска не присутствует, но находится между 0,1 и 0,15 соответственно).
В при этих условиях должен быть возвращен результат 14,5 (находящийся на пересечении строки со значением 12 и столбца со значением 0,1).
Аналогично: для условия "толщина проводника" 37 и "ширина проводника" 0,33 возвращается значение поиска 1,66
К сообщению приложен файл: 6513867.xls(40.5 Kb)


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеДобрый день!
Прошу помощи в написании формулы: необходимо формулой выполнять поиск в массиве данных, если искомые числовые значения непосредственно не содержатся среди исходных данных.

Например, в столбце "толщина проводника" есть значения 12, 18 и т.д.
1-е условие поиска заданное пользователем "толщина проводника" равно 14 (в столбце поиска это значение отсутствует, но находится между 12 и 18),
2-е условие поиска "ширина проводника" равно 0,12 (в строке поиска не присутствует, но находится между 0,1 и 0,15 соответственно).
В при этих условиях должен быть возвращен результат 14,5 (находящийся на пересечении строки со значением 12 и столбца со значением 0,1).
Аналогично: для условия "толщина проводника" 37 и "ширина проводника" 0,33 возвращается значение поиска 1,66

Автор - igrtsk
Дата добавления - 30.06.2022 в 11:39
Nic70y Дата: Четверг, 30.06.2022, 11:46 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7875
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС($C4:$O12;ПОИСКПОЗ(C15;$B4:$B12);ПОИСКПОЗ(C16;$C3:$O3))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС($C4:$O12;ПОИСКПОЗ(C15;$B4:$B12);ПОИСКПОЗ(C16;$C3:$O3))

Автор - Nic70y
Дата добавления - 30.06.2022 в 11:46
igrtsk Дата: Четверг, 30.06.2022, 12:02 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 304
Репутация: 50 ±
Замечаний: 0% ±

Excel 2016
Спасибо! То, что требовалось!


Инструктор по применению лосей в кавалерийских частях РККА
 
Ответить
СообщениеСпасибо! То, что требовалось!

Автор - igrtsk
Дата добавления - 30.06.2022 в 12:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве при неточных исходных данных поиска (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!