Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по строкам и возвращение названия столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по строкам и возвращение названия столбца (Формулы/Formulas)
Поиск по строкам и возвращение названия столбца
NexuS Дата: Четверг, 07.07.2022, 09:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
В примере с помощью формулы, построчно нахожу минимальную цену, потом с помощью формулы необходимо понять какому магазину она принадлежит, вчера часа 3 мучал ПОИСКПОЗ и ИНДЕКС так и не смог разобраться %) выручайте.

Спасибо большое!
Всем хорошего дня и настроения! ^_^
К сообщению приложен файл: 1302014.xls(28.0 Kb)


Сообщение отредактировал NexuS - Четверг, 07.07.2022, 09:41
 
Ответить
СообщениеДобрый день!
В примере с помощью формулы, построчно нахожу минимальную цену, потом с помощью формулы необходимо понять какому магазину она принадлежит, вчера часа 3 мучал ПОИСКПОЗ и ИНДЕКС так и не смог разобраться %) выручайте.

Спасибо большое!
Всем хорошего дня и настроения! ^_^

Автор - NexuS
Дата добавления - 07.07.2022 в 09:27
Serge_007 Дата: Четверг, 07.07.2022, 09:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте

часа 3 мучал ПОИСКПОЗ и ИНДЕКС
?
Код
=ИНДЕКС(B$1:G$1;ПОИСКПОЗ(H2;B2:G2;))


как протягивать Гистограмму
Цитата Правила форума ()
4. Один вопрос - одна тема
Нельзя в одной теме задавать несколько не связанных одной темой вопросов


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

часа 3 мучал ПОИСКПОЗ и ИНДЕКС
?
Код
=ИНДЕКС(B$1:G$1;ПОИСКПОЗ(H2;B2:G2;))


как протягивать Гистограмму
Цитата Правила форума ()
4. Один вопрос - одна тема
Нельзя в одной теме задавать несколько не связанных одной темой вопросов

Автор - Serge_007
Дата добавления - 07.07.2022 в 09:31
bigor Дата: Четверг, 07.07.2022, 09:35 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 144 ±
Замечаний: 0% ±

нет
Добрый
По первому вопросу
Код
=INDEX($B$1:$G$1;;MATCH(H2;B2:G2;0))
 
Ответить
СообщениеДобрый
По первому вопросу
Код
=INDEX($B$1:$G$1;;MATCH(H2;B2:G2;0))

Автор - bigor
Дата добавления - 07.07.2022 в 09:35
NexuS Дата: Четверг, 07.07.2022, 09:38 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Код
=ИНДЕКС(B$1:G$1;ПОИСКПОЗ(H2;B2:G2;))
Спасибо добрый человек, так и думал что все гораздо проще, чем в примерах. Видимо к концу дня уже не варила голова.


Сообщение отредактировал Serge_007 - Четверг, 07.07.2022, 09:47
 
Ответить
Сообщение
Код
=ИНДЕКС(B$1:G$1;ПОИСКПОЗ(H2;B2:G2;))
Спасибо добрый человек, так и думал что все гораздо проще, чем в примерах. Видимо к концу дня уже не варила голова.

Автор - NexuS
Дата добавления - 07.07.2022 в 09:38
_Boroda_ Дата: Четверг, 07.07.2022, 10:48 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще. Но с ИНДЕКС лучше
Код
=ПРОСМОТР(;-1/(B2:G2=H2);B$1:G$1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще. Но с ИНДЕКС лучше
Код
=ПРОСМОТР(;-1/(B2:G2=H2);B$1:G$1)

Автор - _Boroda_
Дата добавления - 07.07.2022 в 10:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по строкам и возвращение названия столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!