Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возврат значений из таблицы(прайса) при заданных услових - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значений из таблицы(прайса) при заданных услових (Формулы/Formulas)
Возврат значений из таблицы(прайса) при заданных услових
LVNSwan85 Дата: Вторник, 12.07.2022, 14:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня, уважаемые эксперты.
Помогите решить вопрос либо ткните в тему (что-то не нашел, оч сложно для меня это), ситуация следующая:
есть разные виды черепицы и разные виды покрытий для нее, есть прайс с ценами. В расчетном поле выбирается черепица и покрытие, в поле цена должна соответственно отображаться цена, исходя из прайса.
К сообщению приложен файл: 8995060.xlsx(15.0 Kb)
 
Ответить
СообщениеДоброго дня, уважаемые эксперты.
Помогите решить вопрос либо ткните в тему (что-то не нашел, оч сложно для меня это), ситуация следующая:
есть разные виды черепицы и разные виды покрытий для нее, есть прайс с ценами. В расчетном поле выбирается черепица и покрытие, в поле цена должна соответственно отображаться цена, исходя из прайса.

Автор - LVNSwan85
Дата добавления - 12.07.2022 в 14:05
китин Дата: Вторник, 12.07.2022, 14:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6908
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Так?
Код
=ИНДЕКС($K$6:$K$30;ПОИСКПОЗ($A7&$B7;$I$6:$I$30&$J$6:$J$30;0))

Формула массива. Вводится Ctrl Shift Enter
К сообщению приложен файл: LVNSwan85.xlsx(16.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеТак?
Код
=ИНДЕКС($K$6:$K$30;ПОИСКПОЗ($A7&$B7;$I$6:$I$30&$J$6:$J$30;0))

Формула массива. Вводится Ctrl Shift Enter

Автор - китин
Дата добавления - 12.07.2022 в 14:14
LVNSwan85 Дата: Вторник, 12.07.2022, 14:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Огромное вам спасибо! Вопрос закрыт
 
Ответить
СообщениеОгромное вам спасибо! Вопрос закрыт

Автор - LVNSwan85
Дата добавления - 12.07.2022 в 14:23
Serge_007 Дата: Вторник, 12.07.2022, 14:27 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
В расчетном поле выбирается черепица и покрытие, в поле цена должна соответственно отображаться цена, исходя из прайса
Код
=СУММПРОИЗВ((I$6:I$30=A7)*(B7=J$6:J$30)*K$6:K$30)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
В расчетном поле выбирается черепица и покрытие, в поле цена должна соответственно отображаться цена, исходя из прайса
Код
=СУММПРОИЗВ((I$6:I$30=A7)*(B7=J$6:J$30)*K$6:K$30)

Автор - Serge_007
Дата добавления - 12.07.2022 в 14:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значений из таблицы(прайса) при заданных услових (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!