Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как работает СМЕЩ внутри Промежуточных Итогов ? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как работает СМЕЩ внутри Промежуточных Итогов ? (Формулы/Formulas)
Как работает СМЕЩ внутри Промежуточных Итогов ?
t3308095 Дата: Суббота, 16.07.2022, 19:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Всем, привет.

Помогите пожалуйста разобрать формулу
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3,СМЕЩ(C1,СТРОКА(2:20)-1,))*(C2:C20<50))

Функция СМЕЩ согласно документации https://support.microsoft.com/ru-ru....6d11b66 ВТОРЫМ аргументом должна принимать ЧИСЛО , которое показывает на сколько надо сместиться вниз/вверх по строкам от первого аргумента.

А в формуле выше СМЕЩ(C1,СТРОКА(2:20)-1,) второй аргумент НЕ ЧИСЛО, а массив чисел СТРОКА(2:20)-1 от 1 до 19 .

Как это работает?
Спасибо
К сообщению приложен файл: 877879_1.xlsx(13.9 Kb)


Сообщение отредактировал t3308095 - Суббота, 16.07.2022, 19:10
 
Ответить
СообщениеВсем, привет.

Помогите пожалуйста разобрать формулу
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3,СМЕЩ(C1,СТРОКА(2:20)-1,))*(C2:C20<50))

Функция СМЕЩ согласно документации https://support.microsoft.com/ru-ru....6d11b66 ВТОРЫМ аргументом должна принимать ЧИСЛО , которое показывает на сколько надо сместиться вниз/вверх по строкам от первого аргумента.

А в формуле выше СМЕЩ(C1,СТРОКА(2:20)-1,) второй аргумент НЕ ЧИСЛО, а массив чисел СТРОКА(2:20)-1 от 1 до 19 .

Как это работает?
Спасибо

Автор - t3308095
Дата добавления - 16.07.2022 в 19:09
прохожий2019 Дата: Суббота, 16.07.2022, 19:35 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 955
Репутация: 262 ±
Замечаний: 0% ±

365 Beta Channel
НЕ ЧИСЛО, а массив чисел
вот и почитайте про формулы массива :)
функция применяется последовательно к каждому элементу массива и получается массив результатов, они попарно умножаются со вторым массивом - (C2:C20<50), а результаты суммируются
 
Ответить
Сообщение
НЕ ЧИСЛО, а массив чисел
вот и почитайте про формулы массива :)
функция применяется последовательно к каждому элементу массива и получается массив результатов, они попарно умножаются со вторым массивом - (C2:C20<50), а результаты суммируются

Автор - прохожий2019
Дата добавления - 16.07.2022 в 19:35
t3308095 Дата: Суббота, 16.07.2022, 19:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Цитата прохожий2019, 16.07.2022 в 19:35, в сообщении № 2 ()
вот и почитайте про формулы массива


Спасибо, рад что Вам весело.
Мне понятно почему там срабатывает условие из второго массива (C2:C20<50) внутри функции СУММПРОИЗВ.

У меня вопрос вызывает другая функция, которая называется СМЕЩ и каким образом она проглатывает массив чисел {1-19} во втором аргументе, хотя в документации написано, что должно быть ЧИСЛО.
 
Ответить
Сообщение
Цитата прохожий2019, 16.07.2022 в 19:35, в сообщении № 2 ()
вот и почитайте про формулы массива


Спасибо, рад что Вам весело.
Мне понятно почему там срабатывает условие из второго массива (C2:C20<50) внутри функции СУММПРОИЗВ.

У меня вопрос вызывает другая функция, которая называется СМЕЩ и каким образом она проглатывает массив чисел {1-19} во втором аргументе, хотя в документации написано, что должно быть ЧИСЛО.

Автор - t3308095
Дата добавления - 16.07.2022 в 19:48
прохожий2019 Дата: Суббота, 16.07.2022, 21:10 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 955
Репутация: 262 ±
Замечаний: 0% ±

365 Beta Channel
хотя в документации написано, что должно быть ЧИСЛО
она работает потому же, почему работает
Код
=ДЛСТР(G5:G18)
где аргументом должен быть ТЕКСТ
Цитата прохожий2019, 16.07.2022 в 19:35, в сообщении № 2 ()
функция применяется последовательно к каждому элементу массива
 
Ответить
Сообщение
хотя в документации написано, что должно быть ЧИСЛО
она работает потому же, почему работает
Код
=ДЛСТР(G5:G18)
где аргументом должен быть ТЕКСТ
Цитата прохожий2019, 16.07.2022 в 19:35, в сообщении № 2 ()
функция применяется последовательно к каждому элементу массива

Автор - прохожий2019
Дата добавления - 16.07.2022 в 21:10
t3308095 Дата: Суббота, 16.07.2022, 21:19 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Цитата прохожий2019, 16.07.2022 в 21:10, в сообщении № 4 ()
она работает


дошло , спасибо!
 
Ответить
Сообщение
Цитата прохожий2019, 16.07.2022 в 21:10, в сообщении № 4 ()
она работает


дошло , спасибо!

Автор - t3308095
Дата добавления - 16.07.2022 в 21:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как работает СМЕЩ внутри Промежуточных Итогов ? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!