Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протяжка формулы с по столбцу с заданным шагом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с по столбцу с заданным шагом (Формулы/Formulas)
Протяжка формулы с по столбцу с заданным шагом
remis8423 Дата: Понедельник, 18.07.2022, 14:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Суть проблемы в следующем:

Нужно протянуть формулу с шагом:

Код
=сумм(Январь!C3:C6)
протягивая по столбцу должно получиться -
Код
=сумм(Январь!C7:C10)


(шагом по 4 клетки)

Формула будет размещена в итоговой вкладке с разных вкладок с января по декабрь.
К сообщению приложен файл: 9812178.xlsx(20.8 Kb)


Сообщение отредактировал remis8423 - Понедельник, 18.07.2022, 15:52
 
Ответить
СообщениеДобрый день!

Суть проблемы в следующем:

Нужно протянуть формулу с шагом:

Код
=сумм(Январь!C3:C6)
протягивая по столбцу должно получиться -
Код
=сумм(Январь!C7:C10)


(шагом по 4 клетки)

Формула будет размещена в итоговой вкладке с разных вкладок с января по декабрь.

Автор - remis8423
Дата добавления - 18.07.2022 в 14:54
китин Дата: Понедельник, 18.07.2022, 15:25 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
файл будет?


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениефайл будет?

Автор - китин
Дата добавления - 18.07.2022 в 15:25
remis8423 Дата: Понедельник, 18.07.2022, 15:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

китин, добавил пример
 
Ответить
Сообщениекитин, добавил пример

Автор - remis8423
Дата добавления - 18.07.2022 в 15:52
Egyptian Дата: Понедельник, 18.07.2022, 16:23 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 392
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(OFFSET(январь!C$3;4*ROWS(C$3:C3)-4;;4))

Дальше по аналогии.
К сообщению приложен файл: 7285212.xlsx(20.5 Kb)
 
Ответить
Сообщение
Код
=SUM(OFFSET(январь!C$3;4*ROWS(C$3:C3)-4;;4))

Дальше по аналогии.

Автор - Egyptian
Дата добавления - 18.07.2022 в 16:23
remis8423 Дата: Понедельник, 18.07.2022, 16:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, Спасибо!
 
Ответить
СообщениеEgyptian, Спасибо!

Автор - remis8423
Дата добавления - 18.07.2022 в 16:56
Gustav Дата: Понедельник, 18.07.2022, 17:38 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2138
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Еще можно таким путем пойти. Немножко запарно, но если освоите, то цены Вам не будет, а девочки из бухгалтерии будут благодарны за простые человеческие формулы ;)

1.На листе "Итого" в диапазон L3:M4 вводите начальные числа ряда:
[vba]
Код
3    6
7    10
[/vba]
2.Протягивате вниз насколько надо, например, до 9-й строки:
[vba]
Код
3    6
7    10
11    14
15    18
19    22
23    26
27    30
[/vba]
3.В ячейку N3 вводите и протягиваете вниз до N9 формулу:
Код
="=СУММ(январь!C"&L3&":C"&M3&")"

Картина получается такая:
[vba]
Код
3    6    =СУММ(январь!C3:C6)
7    10    =СУММ(январь!C7:C10)
11    14    =СУММ(январь!C11:C14)
15    18    =СУММ(январь!C15:C18)
19    22    =СУММ(январь!C19:C22)
23    26    =СУММ(январь!C23:C26)
27    30    =СУММ(январь!C27:C30)
[/vba]
4.Из диапазона N3:N9 копируете и вставляете в диапазон C3:C9 специальной вставкой "ВСТАВИТЬ ЗНАЧЕНИЯ".

5.Не снимая выделения с диапазона вставки C3:C9, идёте в Редактор VBA по Alt+F11 и там по Ctrl+G попадаете в Окно отладки

6.В Окне отладки набираете следующий оператор и жмете Enter:
[vba]
Код
Selection.FormulaLocal = Selection.Value
[/vba]
7.По Alt+F11 возвращаетесь в Excel - в диапазоне C3:C9 результаты расчетов по формулам:
[vba]
Код
13
14
14
24
0
0
0
[/vba]
Внутри ячеек C3:C9 - заветные формулы (понятные "девочкам"):
[vba]
Код
=СУММ(январь!C3:C6)
=СУММ(январь!C7:C10)
=СУММ(январь!C11:C14)
=СУММ(январь!C15:C18)
=СУММ(январь!C19:C22)
=СУММ(январь!C23:C26)
=СУММ(январь!C27:C30)
[/vba]


Мой tip box - яд 41001663842605
 
Ответить
СообщениеЕще можно таким путем пойти. Немножко запарно, но если освоите, то цены Вам не будет, а девочки из бухгалтерии будут благодарны за простые человеческие формулы ;)

1.На листе "Итого" в диапазон L3:M4 вводите начальные числа ряда:
[vba]
Код
3    6
7    10
[/vba]
2.Протягивате вниз насколько надо, например, до 9-й строки:
[vba]
Код
3    6
7    10
11    14
15    18
19    22
23    26
27    30
[/vba]
3.В ячейку N3 вводите и протягиваете вниз до N9 формулу:
Код
="=СУММ(январь!C"&L3&":C"&M3&")"

Картина получается такая:
[vba]
Код
3    6    =СУММ(январь!C3:C6)
7    10    =СУММ(январь!C7:C10)
11    14    =СУММ(январь!C11:C14)
15    18    =СУММ(январь!C15:C18)
19    22    =СУММ(январь!C19:C22)
23    26    =СУММ(январь!C23:C26)
27    30    =СУММ(январь!C27:C30)
[/vba]
4.Из диапазона N3:N9 копируете и вставляете в диапазон C3:C9 специальной вставкой "ВСТАВИТЬ ЗНАЧЕНИЯ".

5.Не снимая выделения с диапазона вставки C3:C9, идёте в Редактор VBA по Alt+F11 и там по Ctrl+G попадаете в Окно отладки

6.В Окне отладки набираете следующий оператор и жмете Enter:
[vba]
Код
Selection.FormulaLocal = Selection.Value
[/vba]
7.По Alt+F11 возвращаетесь в Excel - в диапазоне C3:C9 результаты расчетов по формулам:
[vba]
Код
13
14
14
24
0
0
0
[/vba]
Внутри ячеек C3:C9 - заветные формулы (понятные "девочкам"):
[vba]
Код
=СУММ(январь!C3:C6)
=СУММ(январь!C7:C10)
=СУММ(январь!C11:C14)
=СУММ(январь!C15:C18)
=СУММ(январь!C19:C22)
=СУММ(январь!C23:C26)
=СУММ(январь!C27:C30)
[/vba]

Автор - Gustav
Дата добавления - 18.07.2022 в 17:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с по столбцу с заданным шагом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!