Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация строк (Формулы/Formulas)
Нумерация строк
boldinae Дата: Вторник, 19.07.2022, 17:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 40% ±

Добрый день! Подскажите, как пронумеровать строки по адресам, реестр адрес большой, в данном файле всего лишь пример/часть
К сообщению приложен файл: _Microsoft_Exce.xlsx(9.0 Kb)
 
Ответить
СообщениеДобрый день! Подскажите, как пронумеровать строки по адресам, реестр адрес большой, в данном файле всего лишь пример/часть

Автор - boldinae
Дата добавления - 19.07.2022 в 17:33
msi2102 Дата: Вторник, 19.07.2022, 18:24 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так
Код
=ЕСЛИОШИБКА(ЕСЛИ(B2="";A1;A1+1);1)

или макросом
[vba]
Код
Sub Номерация()
    Dim m As Long, rng As Range, f As Byte
    m = 0
    f = 1
    For n = 2 To ActiveSheet.UsedRange.Rows.Count
        If Not Cells(n, 2).MergeCells Then
            f = 1: m = m + 1
        Else
            If f = 1 Then m = m + 1: f = 0
        End If
        Cells(n, 1) = m
    Next n
    If Not rng Is Nothing Then rng.Delete
End Sub
[/vba]
Номерует по принципу: если ячейки в столбце B не объединены то добавляет единицу, иначе то же значение
К сообщению приложен файл: _Microsoft_Exce.xlsm(21.2 Kb)


Сообщение отредактировал msi2102 - Вторник, 19.07.2022, 18:28
 
Ответить
СообщениеПопробуйте так
Код
=ЕСЛИОШИБКА(ЕСЛИ(B2="";A1;A1+1);1)

или макросом
[vba]
Код
Sub Номерация()
    Dim m As Long, rng As Range, f As Byte
    m = 0
    f = 1
    For n = 2 To ActiveSheet.UsedRange.Rows.Count
        If Not Cells(n, 2).MergeCells Then
            f = 1: m = m + 1
        Else
            If f = 1 Then m = m + 1: f = 0
        End If
        Cells(n, 1) = m
    Next n
    If Not rng Is Nothing Then rng.Delete
End Sub
[/vba]
Номерует по принципу: если ячейки в столбце B не объединены то добавляет единицу, иначе то же значение

Автор - msi2102
Дата добавления - 19.07.2022 в 18:24
DrMini Дата: Среда, 20.07.2022, 07:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 885
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Вот так ещё можно:
Код
=ЕСЛИ(B2="";"";ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;$B$2:B2))
К сообщению приложен файл: 3516316.xlsx(9.9 Kb)
 
Ответить
СообщениеВот так ещё можно:
Код
=ЕСЛИ(B2="";"";ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;$B$2:B2))

Автор - DrMini
Дата добавления - 20.07.2022 в 07:25
alexa1965 Дата: Среда, 20.07.2022, 09:19 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 270
Репутация: 35 ±
Замечаний: 0% ±

2003> 2010> 2016
Как вариант
Код
=ЕСЛИ(ЕПУСТО(B2);"";СЧЁТЗ(B$2:$B2))


Главное не быть балабастиком
 
Ответить
СообщениеКак вариант
Код
=ЕСЛИ(ЕПУСТО(B2);"";СЧЁТЗ(B$2:$B2))

Автор - alexa1965
Дата добавления - 20.07.2022 в 09:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!