Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить статус всем дублям, если хотябы один из них содер - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить статус всем дублям, если хотябы один из них содер (Формулы/Formulas)
Проставить статус всем дублям, если хотябы один из них содер
antonlakiza2 Дата: Среда, 20.07.2022, 21:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Помогите пож-та проставить статус всем дублям, если хотябы один из них содержит определенное условие. Пересмотрел весь интернет.

Прикрепил xlsx файл, где видны примеры и как должен выглядеть результат.

Номер клиента Статус Результат в таком формате Условие
79081378601 1 да Вывести "да", если хотябы один дубль номера содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"
80725086702 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
80725086702 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
80725086703 1 да Вывести "да", если хотябы один дубль номера содержит "1"
80725086704 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"
К сообщению приложен файл: 8107598.xlsx(5.2 Kb)
 
Ответить
СообщениеПомогите пож-та проставить статус всем дублям, если хотябы один из них содержит определенное условие. Пересмотрел весь интернет.

Прикрепил xlsx файл, где видны примеры и как должен выглядеть результат.

Номер клиента Статус Результат в таком формате Условие
79081378601 1 да Вывести "да", если хотябы один дубль номера содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"
80725086702 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
80725086702 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
80725086703 1 да Вывести "да", если хотябы один дубль номера содержит "1"
80725086704 0 нет Вывести "нет", если ни один дубль номера НЕ содержит "1"
79081378601 0 да Вывести "да", если хотябы один дубль номера содержит "1"

Автор - antonlakiza2
Дата добавления - 20.07.2022 в 21:31
scriptapplications Дата: Среда, 20.07.2022, 21:59 | Сообщение № 2
Группа: Проверенные
Ранг: Участник
Сообщений: 64
Репутация: 12 ±
Замечаний: 0% ±

antonlakiza2, формула массива (вводится через Ctrl+Shift+Enter) для ячейки C2:
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(A2&1;$A$2:$A$9&$B$2:$B$9;0);0)>0;"да";"нет")

Далее формула растягивается на весь диапазон (пример в E2:E9 вложенного файла)
К сообщению приложен файл: 8107598_1.xlsx(9.2 Kb)


Сообщение отредактировал scriptapplications - Среда, 20.07.2022, 22:04
 
Ответить
Сообщениеantonlakiza2, формула массива (вводится через Ctrl+Shift+Enter) для ячейки C2:
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(A2&1;$A$2:$A$9&$B$2:$B$9;0);0)>0;"да";"нет")

Далее формула растягивается на весь диапазон (пример в E2:E9 вложенного файла)

Автор - scriptapplications
Дата добавления - 20.07.2022 в 21:59
Egyptian Дата: Среда, 20.07.2022, 22:25 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
Так что-ли?
Код
=IF(COUNTIFS($A$2:$A$50;A2;$B$2:$B$50;1);"да";"нет")
 
Ответить
СообщениеТак что-ли?
Код
=IF(COUNTIFS($A$2:$A$50;A2;$B$2:$B$50;1);"да";"нет")

Автор - Egyptian
Дата добавления - 20.07.2022 в 22:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить статус всем дублям, если хотябы один из них содер (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!