Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор по условию из таблицы нескольких значений без плвторов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор по условию из таблицы нескольких значений без плвторов (Формулы/Formulas)
Выбор по условию из таблицы нескольких значений без плвторов
Vlad1943 Дата: Четверг, 21.07.2022, 13:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!

Не смог найти решение, хотя похожие находил, но что-то прописал неверно.
Задачка в файле. Вопрос в том, что при одинаковом значении (14) отображает только одно, а нужно все.
Эксель 2007.
Спасибо!
К сообщению приложен файл: 3799582.xlsx(9.9 Kb)
 
Ответить
СообщениеЗдравствуйте!

Не смог найти решение, хотя похожие находил, но что-то прописал неверно.
Задачка в файле. Вопрос в том, что при одинаковом значении (14) отображает только одно, а нужно все.
Эксель 2007.
Спасибо!

Автор - Vlad1943
Дата добавления - 21.07.2022 в 13:43
китин Дата: Четверг, 21.07.2022, 13:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6875
Репутация: 1055 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=ИНДЕКС($B$2:$B$17;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$17=$E2;СТРОКА($A$2:$A$17)-1);СЧЁТЕСЛИ($E$2:E2;E2)))

формула массива
К сообщению приложен файл: 5903463.xlsx(11.4 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=ИНДЕКС($B$2:$B$17;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$17=$E2;СТРОКА($A$2:$A$17)-1);СЧЁТЕСЛИ($E$2:E2;E2)))

формула массива

Автор - китин
Дата добавления - 21.07.2022 в 13:57
Vlad1943 Дата: Четверг, 21.07.2022, 14:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Вроде работает! Спасибо огромное!
 
Ответить
СообщениеВроде работает! Спасибо огромное!

Автор - Vlad1943
Дата добавления - 21.07.2022 в 14:13
Vlad1943 Дата: Четверг, 21.07.2022, 14:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

А что за фигурные скобки со второго значения и как вводить такие выражения, чтобы считались?
При попытке переноса в другую таблицу значения не отображаются..
 
Ответить
СообщениеА что за фигурные скобки со второго значения и как вводить такие выражения, чтобы считались?
При попытке переноса в другую таблицу значения не отображаются..

Автор - Vlad1943
Дата добавления - 21.07.2022 в 14:26
bigor Дата: Четверг, 21.07.2022, 14:28 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 670
Репутация: 136 ±
Замечаний: 0% ±

нет
формула массива
вводится тремя кнопками Ctrl+Shift+Enter
 
Ответить
Сообщение
формула массива
вводится тремя кнопками Ctrl+Shift+Enter

Автор - bigor
Дата добавления - 21.07.2022 в 14:28
Vlad1943 Дата: Четверг, 21.07.2022, 14:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Вроде получилось. А как убрать массив для редактирования ячеек?
 
Ответить
СообщениеВроде получилось. А как убрать массив для редактирования ячеек?

Автор - Vlad1943
Дата добавления - 21.07.2022 в 14:47
Vlad1943 Дата: Четверг, 21.07.2022, 15:21 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Разобрался с массивами. Спасибо!
 
Ответить
СообщениеРазобрался с массивами. Спасибо!

Автор - Vlad1943
Дата добавления - 21.07.2022 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор по условию из таблицы нескольких значений без плвторов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!