Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение значения по нескольким критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение значения по нескольким критериям (Формулы/Formulas)
Нахождение значения по нескольким критериям
Merkuriy Дата: Пятница, 22.07.2022, 17:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Ранее к вам обращался с похожим вопросом и, спасибо за помощь, все получилось.
Используя ваш ответ в качестве основы попытался написать новую формулу, чтобы на основе нескольких критериев формула находила нужное значение и ставила его в соответствующую ячейку. Но что-то пошло у меня не так. Прошу вас помочь мне с этим разобраться. Суть вопроса в следующем: нужно чтобы на основе данных из таблицы лист1 (строка:дата, владелец груза, грузополучатель; столбец: краткое наименование) формула находила на листе3 соответствующее значение и подставляла его в столец цена лист1.
Спасибо за помощь!
К сообщению приложен файл: 7138987.xlsx(17.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Ранее к вам обращался с похожим вопросом и, спасибо за помощь, все получилось.
Используя ваш ответ в качестве основы попытался написать новую формулу, чтобы на основе нескольких критериев формула находила нужное значение и ставила его в соответствующую ячейку. Но что-то пошло у меня не так. Прошу вас помочь мне с этим разобраться. Суть вопроса в следующем: нужно чтобы на основе данных из таблицы лист1 (строка:дата, владелец груза, грузополучатель; столбец: краткое наименование) формула находила на листе3 соответствующее значение и подставляла его в столец цена лист1.
Спасибо за помощь!

Автор - Merkuriy
Дата добавления - 22.07.2022 в 17:36
bigorq Дата: Пятница, 22.07.2022, 18:31 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 25 ±
Замечаний: 0% ±

Нет
Здравствуйте
Попробуйте так:
Код
=SUMPRODUCT((Лист3.$B$5:$B$25=D4)*(Лист3.$C$5:$C$25=G4)*(Лист3.$D$5:$D$25=H4)*(Лист3.$E$4:$K$4=I4)*(Лист3.$E$5:$K$25))


Сообщение отредактировал bigorq - Пятница, 22.07.2022, 18:31
 
Ответить
СообщениеЗдравствуйте
Попробуйте так:
Код
=SUMPRODUCT((Лист3.$B$5:$B$25=D4)*(Лист3.$C$5:$C$25=G4)*(Лист3.$D$5:$D$25=H4)*(Лист3.$E$4:$K$4=I4)*(Лист3.$E$5:$K$25))

Автор - bigorq
Дата добавления - 22.07.2022 в 18:31
Pelena Дата: Пятница, 22.07.2022, 18:38 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18492
Репутация: 4185 ±
Замечаний: ±

Excel 2016 & Mac Excel
Ещё вариант
Код
=ИНДЕКС(Лист3!$E$5:$K$20;ПРОСМОТР(;-1/($D4>=Лист3!$B$5:$B$26)/($G4=Лист3!$C$5:$C$26);СТРОКА(Лист3!$B$5:$B$26)-4);ПОИСКПОЗ($I4;Лист3!$E$4:$K$4;0))
К сообщению приложен файл: 9356946.xlsx(17.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=ИНДЕКС(Лист3!$E$5:$K$20;ПРОСМОТР(;-1/($D4>=Лист3!$B$5:$B$26)/($G4=Лист3!$C$5:$C$26);СТРОКА(Лист3!$B$5:$B$26)-4);ПОИСКПОЗ($I4;Лист3!$E$4:$K$4;0))

Автор - Pelena
Дата добавления - 22.07.2022 в 18:38
Merkuriy Дата: Пятница, 22.07.2022, 22:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
Добрый вечер.
Большое спасибо за помощь!
Формула прекрасно работает.
hands
 
Ответить
СообщениеPelena,
Добрый вечер.
Большое спасибо за помощь!
Формула прекрасно работает.
hands

Автор - Merkuriy
Дата добавления - 22.07.2022 в 22:21
zaspeg Дата: Понедельник, 01.08.2022, 15:07 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Добрый день.
Подскажите, пожалуйста, формулу.
На лист1 имеется столбец HS Code.
Нужно чтобы брались первые 4 цифры из значений этого столбца, сравнивались со столбцом Code на лист2, находились строки именно с 4-х значным кодом.
Зетем значение со столбца Name на лист2, соответсвующее 4-х значному коду, подставлялось в столбец Name на лист1.
Спасибо.
К сообщению приложен файл: tnved.xlsx(37.0 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, формулу.
На лист1 имеется столбец HS Code.
Нужно чтобы брались первые 4 цифры из значений этого столбца, сравнивались со столбцом Code на лист2, находились строки именно с 4-х значным кодом.
Зетем значение со столбца Name на лист2, соответсвующее 4-х значному коду, подставлялось в столбец Name на лист1.
Спасибо.

Автор - zaspeg
Дата добавления - 01.08.2022 в 15:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение значения по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!