Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ с условиями без формулы массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с условиями без формулы массива (Формулы/Formulas)
СУММПРОИЗВ с условиями без формулы массива
Anis625 Дата: Среда, 27.07.2022, 15:02 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
Добрый день, всем участникам форума!
Подскажите, пожалуйста, есть ли альтернативное решение обойти формулы массива при использовании формулы СУММПРОИЗВ (т.к. применяя в большой таблице расчет заметно подтормаживает при использовании срезов).
На условном примере: обычной формулой СУММПРОИЗВ получаю сумму по конкретному цеху (B2) и складу (B3), и не получается результат (E2, без формулы массива) если нужно получить результат сразу по всем цехам.
Пробовал сделать с ЕСЛИ и прописать две формулы - в продуктиве тормозить стало еще сильнее.
Буду признателен за любой совет.
К сообщению приложен файл: 3494819.xlsx(9.3 Kb)
 
Ответить
СообщениеДобрый день, всем участникам форума!
Подскажите, пожалуйста, есть ли альтернативное решение обойти формулы массива при использовании формулы СУММПРОИЗВ (т.к. применяя в большой таблице расчет заметно подтормаживает при использовании срезов).
На условном примере: обычной формулой СУММПРОИЗВ получаю сумму по конкретному цеху (B2) и складу (B3), и не получается результат (E2, без формулы массива) если нужно получить результат сразу по всем цехам.
Пробовал сделать с ЕСЛИ и прописать две формулы - в продуктиве тормозить стало еще сильнее.
Буду признателен за любой совет.

Автор - Anis625
Дата добавления - 27.07.2022 в 15:02
Serge_007 Дата: Среда, 27.07.2022, 15:06 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте

есть ли альтернативное решение обойти формулы массива при использовании формулы СУММПРОИЗВ
Штатное решение - сводная таблица
Она в разы быстрее любых формул массива


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

есть ли альтернативное решение обойти формулы массива при использовании формулы СУММПРОИЗВ
Штатное решение - сводная таблица
Она в разы быстрее любых формул массива

Автор - Serge_007
Дата добавления - 27.07.2022 в 15:06
Anis625 Дата: Среда, 27.07.2022, 15:20 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
Serge_007,
Это следующий этап вместе с Power Pivot (там представление есть как сделать). Пока формулы. Получается только формула массива?
 
Ответить
СообщениеSerge_007,
Это следующий этап вместе с Power Pivot (там представление есть как сделать). Пока формулы. Получается только формула массива?

Автор - Anis625
Дата добавления - 27.07.2022 в 15:20
Serge_007 Дата: Среда, 27.07.2022, 15:38 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Получается только формула массива?
Да
Причем что СУММПРОИЗВ(), что СУММЕСЛИМН() - так же "массивные" функции, несмотря на то что вводятся просто Enter'ом


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Получается только формула массива?
Да
Причем что СУММПРОИЗВ(), что СУММЕСЛИМН() - так же "массивные" функции, несмотря на то что вводятся просто Enter'ом

Автор - Serge_007
Дата добавления - 27.07.2022 в 15:38
Anis625 Дата: Среда, 27.07.2022, 15:48 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
Serge_007,
Понятно. Спасибо Вам!
 
Ответить
СообщениеSerge_007,
Понятно. Спасибо Вам!

Автор - Anis625
Дата добавления - 27.07.2022 в 15:48
Nic70y Дата: Пятница, 29.07.2022, 11:16 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
альтернативное решение обойти формулы массива
дополнительный столбец
Код
=ЕСЛИ(ЕСЛИ(B$2="Все";"Все";A6)=B$2;ЕСЛИ(B6=B$3;C6;);)
К сообщению приложен файл: 4348646.xlsx(9.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
альтернативное решение обойти формулы массива
дополнительный столбец
Код
=ЕСЛИ(ЕСЛИ(B$2="Все";"Все";A6)=B$2;ЕСЛИ(B6=B$3;C6;);)

Автор - Nic70y
Дата добавления - 29.07.2022 в 11:16
volos3454 Дата: Четверг, 20.10.2022, 09:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 40% ±

Добрый день. Помогите с формулой. Имеется данные по отгрузке товара. Где есть акционное товары, нужно посчитать сумму по всем акционным товарам по каждому покупателю, формула массива такое не умеет.
К сообщению приложен файл: summ.xls(345.0 Kb)
 
Ответить
СообщениеДобрый день. Помогите с формулой. Имеется данные по отгрузке товара. Где есть акционное товары, нужно посчитать сумму по всем акционным товарам по каждому покупателю, формула массива такое не умеет.

Автор - volos3454
Дата добавления - 20.10.2022 в 09:52
Egyptian Дата: Четверг, 20.10.2022, 11:02 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
К сообщению приложен файл: 0025254.xls(346.0 Kb)
 
Ответить
СообщениеДоступно только для пользователей

Автор - Egyptian
Дата добавления - 20.10.2022 в 11:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с условиями без формулы массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!