Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение наличия даты в списке, Пишу формулу на определен - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение наличия даты в списке, Пишу формулу на определен (Формулы/Formulas)
Определение наличия даты в списке, Пишу формулу на определен
учуд Дата: Понедельник, 01.08.2022, 23:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Пишу формулу на проверку наличия даты в списке. Но выдает ошибку.
Ниже формула и краткое описание
Вот формула:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(&ДАТА(ГОД(B9); МЕСЯЦ(B9)-E9; ДЕНЬ(B9)); $L$8:$W$8; 0));1; "-")

Ошибка возникает на этапе первого условия (&ДАТА(ГОД(B11); МЕСЯЦ(B11)-E11; ДЕНЬ(B11)). Не могу понять почему оно не считает его как дату и потом не ищет в списке.
Если заменить просто на дату то работает. Но мне нужно только через формулу.
Заранее спасибо!
К сообщению приложен файл: 8050051.xlsx(68.1 Kb)
 
Ответить
СообщениеДобрый день.
Пишу формулу на проверку наличия даты в списке. Но выдает ошибку.
Ниже формула и краткое описание
Вот формула:
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(&ДАТА(ГОД(B9); МЕСЯЦ(B9)-E9; ДЕНЬ(B9)); $L$8:$W$8; 0));1; "-")

Ошибка возникает на этапе первого условия (&ДАТА(ГОД(B11); МЕСЯЦ(B11)-E11; ДЕНЬ(B11)). Не могу понять почему оно не считает его как дату и потом не ищет в списке.
Если заменить просто на дату то работает. Но мне нужно только через формулу.
Заранее спасибо!

Автор - учуд
Дата добавления - 01.08.2022 в 23:13
Pelena Дата: Понедельник, 01.08.2022, 23:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18492
Репутация: 4185 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Перемудрили немного
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B9; $L$8:$W$8; 0));1; "-")

не дочитала малость
Если заменить просто на дату то работает. Но мне нужно только через формулу.

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(ДАТА(ГОД(B9); МЕСЯЦ(B9); ДЕНЬ(B9)); $L$8:$W$8; 0));1; "-")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Перемудрили немного
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B9; $L$8:$W$8; 0));1; "-")

не дочитала малость
Если заменить просто на дату то работает. Но мне нужно только через формулу.

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(ДАТА(ГОД(B9); МЕСЯЦ(B9); ДЕНЬ(B9)); $L$8:$W$8; 0));1; "-")

Автор - Pelena
Дата добавления - 01.08.2022 в 23:18
учуд Дата: Понедельник, 01.08.2022, 23:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
Там нужно от одной даты отнять 3 месяца, а не просто дату записать
 
Ответить
СообщениеPelena,
Там нужно от одной даты отнять 3 месяца, а не просто дату записать

Автор - учуд
Дата добавления - 01.08.2022 в 23:34
учуд Дата: Понедельник, 01.08.2022, 23:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
И когда отнимаешь дату ПОИСКПОЗ перестает работать
 
Ответить
СообщениеPelena,
И когда отнимаешь дату ПОИСКПОЗ перестает работать

Автор - учуд
Дата добавления - 01.08.2022 в 23:35
Egyptian Дата: Вторник, 02.08.2022, 00:06 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 375
Репутация: 127 ±
Замечаний: 0% ±

Excel 2013/2016
Можно так.
Код
=ISNUMBER(MATCH(DATE(YEAR(B9); MONTH(B9)-E9; DAY(B9)); $L$8:$W$8;0))+0

или так:
Код
=COUNTIF( $L$8:$W$8;DATE(YEAR(B9); MONTH(B9)-E9; DAY(B9)))
 
Ответить
СообщениеМожно так.
Код
=ISNUMBER(MATCH(DATE(YEAR(B9); MONTH(B9)-E9; DAY(B9)); $L$8:$W$8;0))+0

или так:
Код
=COUNTIF( $L$8:$W$8;DATE(YEAR(B9); MONTH(B9)-E9; DAY(B9)))

Автор - Egyptian
Дата добавления - 02.08.2022 в 00:06
Pelena Дата: Вторник, 02.08.2022, 08:27 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18492
Репутация: 4185 ±
Замечаний: ±

Excel 2016 & Mac Excel
от одной даты отнять 3 месяца

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(ДАТАМЕС(B9;-E9); $L$8:$W$8; 0));1; "-")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
от одной даты отнять 3 месяца

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(ДАТАМЕС(B9;-E9); $L$8:$W$8; 0));1; "-")

Автор - Pelena
Дата добавления - 02.08.2022 в 08:27
учуд Дата: Вторник, 02.08.2022, 09:17 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
Спасибо большон!
 
Ответить
СообщениеPelena,
Спасибо большон!

Автор - учуд
Дата добавления - 02.08.2022 в 09:17
учуд Дата: Вторник, 02.08.2022, 09:17 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Egyptian,
Спасибо большое!
 
Ответить
СообщениеEgyptian,
Спасибо большое!

Автор - учуд
Дата добавления - 02.08.2022 в 09:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение наличия даты в списке, Пишу формулу на определен (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!