Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по части слова без VBA - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по части слова без VBA (Формулы/Formulas)
ВПР по части слова без VBA
tel9035913360 Дата: Вторник, 16.08.2022, 09:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Поискал в инете не смог разобраться с формулой, почему то все ведет к VBA
Суть: Поиск значения в таблице по части текста
более понятное объяснение во вложении
Спасибо !
К сообщению приложен файл: 6387846.xlsx(9.2 Kb)
 
Ответить
СообщениеПоискал в инете не смог разобраться с формулой, почему то все ведет к VBA
Суть: Поиск значения в таблице по части текста
более понятное объяснение во вложении
Спасибо !

Автор - tel9035913360
Дата добавления - 16.08.2022 в 09:39
bigorq Дата: Вторник, 16.08.2022, 09:43 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 25 ±
Замечаний: 0% ±

Нет
Добрый день. Файл не смотрел. С подстановочными знаками пробовали?
 
Ответить
СообщениеДобрый день. Файл не смотрел. С подстановочными знаками пробовали?

Автор - bigorq
Дата добавления - 16.08.2022 в 09:43
_Boroda_ Дата: Вторник, 16.08.2022, 09:48 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16360
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ВПР(ПСТР(B17;ПОИСК(".";B17);99);C3:G11;2;)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ВПР(ПСТР(B17;ПОИСК(".";B17);99);C3:G11;2;)

Автор - _Boroda_
Дата добавления - 16.08.2022 в 09:48
Serge_007 Дата: Вторник, 16.08.2022, 09:48 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15407
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Код
=ВПР(ПСТРБ($B3;НАЙТИ(".";$B3);99);$C3:$G12;СТОЛБЕЦ(A1);)
К сообщению приложен файл: 20220816_tel903.xls(59.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ВПР(ПСТРБ($B3;НАЙТИ(".";$B3);99);$C3:$G12;СТОЛБЕЦ(A1);)

Автор - Serge_007
Дата добавления - 16.08.2022 в 09:48
tel9035913360 Дата: Вторник, 16.08.2022, 10:27 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Все огромное спасибо !
Serge_007 отдельное за файл с примером
 
Ответить
СообщениеВсе огромное спасибо !
Serge_007 отдельное за файл с примером

Автор - tel9035913360
Дата добавления - 16.08.2022 в 10:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по части слова без VBA (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!