Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать уникальные значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать уникальные значения (Формулы/Formulas)
Посчитать уникальные значения
350 Дата: Четверг, 25.08.2022, 11:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 20% ±

Добрый день, уважаемые знатоки Excel.
Помогите, пожалуйста, со следующей задачей - во вложени список, в которм необходимо посчитать уникальные значения приложенных кодов.

Заранее признателен за Вашу помощь!
К сообщению приложен файл: ForumExcel25082.xlsx(23.8 Kb)
 
Ответить
СообщениеДобрый день, уважаемые знатоки Excel.
Помогите, пожалуйста, со следующей задачей - во вложени список, в которм необходимо посчитать уникальные значения приложенных кодов.

Заранее признателен за Вашу помощь!

Автор - 350
Дата добавления - 25.08.2022 в 11:48
gling Дата: Четверг, 25.08.2022, 12:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2371
Репутация: 617 ±
Замечаний: 0% ±

2010
необходимо посчитать уникальные значения
Здравствуйте.
Выделяете столбец с данными--на вкладке Данные жмёте кнопку "Удалить дубликаты"--выскакивает результат сколько удалилось повторов и сколько осталось уникальных значений, одно из значений это шапка таблицы.


ЯД-41001506838083
 
Ответить
Сообщение
необходимо посчитать уникальные значения
Здравствуйте.
Выделяете столбец с данными--на вкладке Данные жмёте кнопку "Удалить дубликаты"--выскакивает результат сколько удалилось повторов и сколько осталось уникальных значений, одно из значений это шапка таблицы.

Автор - gling
Дата добавления - 25.08.2022 в 12:22
jakim Дата: Четверг, 25.08.2022, 12:22 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1115
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=SUMPRODUCT(1/COUNTIF(A2:A1108;A2:A1108))
 
Ответить
Сообщение
Формула

Код
=SUMPRODUCT(1/COUNTIF(A2:A1108;A2:A1108))

Автор - jakim
Дата добавления - 25.08.2022 в 12:22
scriptapplications Дата: Четверг, 25.08.2022, 12:25 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 9 ±
Замечаний: 0% ±

350, количество уникальных (тех, которые в списке содержатся один раз) в диапазоне $A2:$A1108 определяется формулой массива (ввод через Ctrl +Shift +Enter) :
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИ($A2:$A1108;$A2:$A1108)=1;1;0))

Количество различных значений в списке равно:
Код
=СУММ(1/СЧЁТЕСЛИ($A2:$A1108;$A2:$A1108))


Сообщение отредактировал scriptapplications - Четверг, 25.08.2022, 12:38
 
Ответить
Сообщение350, количество уникальных (тех, которые в списке содержатся один раз) в диапазоне $A2:$A1108 определяется формулой массива (ввод через Ctrl +Shift +Enter) :
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИ($A2:$A1108;$A2:$A1108)=1;1;0))

Количество различных значений в списке равно:
Код
=СУММ(1/СЧЁТЕСЛИ($A2:$A1108;$A2:$A1108))

Автор - scriptapplications
Дата добавления - 25.08.2022 в 12:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать уникальные значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!