Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск данных в таблице и вывод их значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных в таблице и вывод их значений (Формулы/Formulas)
Поиск данных в таблице и вывод их значений
swi040779 Дата: Понедельник, 05.09.2022, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 80% ±

2010
Добрый день. Обращаюсь к знающим людям, есть календарь сделанный в excel (не мной) пытаюсь его переделать под собственные нужды. Помимо календаря. есть три таблицы с выводом данных которая долно производить поиск и вывод данных в соответствующую таблицу.
Для примера: к примеру сегодня 3 января, эта дата выделяется в самом календаре и соответственно в таблице "Праздники" должны выводится все праздники перечисленные на листе "Данные" (их может быть несколько). То же самое и с другими таблицами.
В том что имеется используется формула
Код
=ИНДЕКС(Данные!$B$3:$B$2000;НАИМЕНЬШИЙ(ЕСЛИ(Данные!$F$3:$F$2000=СЕГОДНЯ();СТРОКА(Данные!$B$3:$B$2000)-2);СТРОКА(A1)))
, но она работает не корректно, а именно, сегодня 5 сентября. а выводит она данные которые относятся к 3-му января.
К сообщению приложен файл: calendar2.xlsx(278.5 Kb)


Сообщение отредактировал Serge_007 - Понедельник, 05.09.2022, 11:54
 
Ответить
СообщениеДобрый день. Обращаюсь к знающим людям, есть календарь сделанный в excel (не мной) пытаюсь его переделать под собственные нужды. Помимо календаря. есть три таблицы с выводом данных которая долно производить поиск и вывод данных в соответствующую таблицу.
Для примера: к примеру сегодня 3 января, эта дата выделяется в самом календаре и соответственно в таблице "Праздники" должны выводится все праздники перечисленные на листе "Данные" (их может быть несколько). То же самое и с другими таблицами.
В том что имеется используется формула
Код
=ИНДЕКС(Данные!$B$3:$B$2000;НАИМЕНЬШИЙ(ЕСЛИ(Данные!$F$3:$F$2000=СЕГОДНЯ();СТРОКА(Данные!$B$3:$B$2000)-2);СТРОКА(A1)))
, но она работает не корректно, а именно, сегодня 5 сентября. а выводит она данные которые относятся к 3-му января.

Автор - swi040779
Дата добавления - 05.09.2022 в 10:57
Nic70y Дата: Понедельник, 05.09.2022, 11:51 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7725
Репутация: 1853 ±
Замечаний: 0% ±

Excel 2010
{формула массива вводится одновременным нажатием Ctrl Shift Enter}


ЮMoney 41001841029809
 
Ответить
Сообщение{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Автор - Nic70y
Дата добавления - 05.09.2022 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных в таблице и вывод их значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!