Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск подстроки в строках по двум условиям с неравенством - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск подстроки в строках по двум условиям с неравенством (Формулы/Formulas)
Поиск подстроки в строках по двум условиям с неравенством
Xenus91 Дата: Среда, 07.09.2022, 04:02 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Просьба помочь, решить задачу
необходимо получить номер маршрута из столбца "№", по 2 условиям:
1) в строках столбца "Маршрут" содержится подстрока из ячейки Е1
2) в строках столбца "Статус" не содержится подстрока "Загружен*"
сам смог вывести по 2 условиям, но по столбцу "Статус"="Ожидает*", а нужно исключить именно "Загружен*"
файл прилагаю
заранее большое спасибо
К сообщению приложен файл: 9821798.xlsx(10.6 Kb)
 
Ответить
СообщениеДоброго времени суток!
Просьба помочь, решить задачу
необходимо получить номер маршрута из столбца "№", по 2 условиям:
1) в строках столбца "Маршрут" содержится подстрока из ячейки Е1
2) в строках столбца "Статус" не содержится подстрока "Загружен*"
сам смог вывести по 2 условиям, но по столбцу "Статус"="Ожидает*", а нужно исключить именно "Загружен*"
файл прилагаю
заранее большое спасибо

Автор - Xenus91
Дата добавления - 07.09.2022 в 04:02
Pelena Дата: Среда, 07.09.2022, 06:54 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС(C2:C25;ПОИСКПОЗ(1;(ПОИСК("*"&E1&"*";Таблица1[Маршрут]))*ЕОШИБКА(ПОИСК("Загружен*";Таблица1[Статус]));0);1)

Или так, для функции ПОИСК() звёздочки не нужны
Код
=ИНДЕКС(C2:C25;ПОИСКПОЗ(1;ЕЧИСЛО(ПОИСК(E1;Таблица1[Маршрут]))*ЕОШИБКА(ПОИСК("Загружен";Таблица1[Статус]));0);1)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(C2:C25;ПОИСКПОЗ(1;(ПОИСК("*"&E1&"*";Таблица1[Маршрут]))*ЕОШИБКА(ПОИСК("Загружен*";Таблица1[Статус]));0);1)

Или так, для функции ПОИСК() звёздочки не нужны
Код
=ИНДЕКС(C2:C25;ПОИСКПОЗ(1;ЕЧИСЛО(ПОИСК(E1;Таблица1[Маршрут]))*ЕОШИБКА(ПОИСК("Загружен";Таблица1[Статус]));0);1)

Автор - Pelena
Дата добавления - 07.09.2022 в 06:54
Xenus91 Дата: Среда, 07.09.2022, 09:07 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Pelena, все работает, большое спасибо!
 
Ответить
СообщениеPelena, все работает, большое спасибо!

Автор - Xenus91
Дата добавления - 07.09.2022 в 09:07
baxtiyor1916 Дата: Четверг, 08.09.2022, 08:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Для Excel 365/2021:
Код
=ФИЛЬТР(Таблица1[№];(ЕЧИСЛО(ПОИСК(E1;Таблица1[Маршрут]))*(ЕОШ(ПОИСК("Загружен";Таблица1[Статус])))))

вернёт все маршруты, отвечающие условиям
К сообщению приложен файл: 8652173.xlsx(12.0 Kb)
 
Ответить
СообщениеДля Excel 365/2021:
Код
=ФИЛЬТР(Таблица1[№];(ЕЧИСЛО(ПОИСК(E1;Таблица1[Маршрут]))*(ЕОШ(ПОИСК("Загружен";Таблица1[Статус])))))

вернёт все маршруты, отвечающие условиям

Автор - baxtiyor1916
Дата добавления - 08.09.2022 в 08:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск подстроки в строках по двум условиям с неравенством (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!