Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/добавление цифры в номер - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » добавление цифры в номер (Формулы/Formulas)
добавление цифры в номер
irenatu83 Дата: Воскресенье, 25.09.2022, 16:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

если старый номер начинается 3,5,7,9, тогда приписать вперед номера цифру 1, если на другие то 6.
пробовала через if, но не получается добавиться больше чем одну цифру
К сообщению приложен файл: 8838656.png(5.1 Kb)


Сообщение отредактировал irenatu83 - Воскресенье, 25.09.2022, 17:00
 
Ответить
Сообщениеесли старый номер начинается 3,5,7,9, тогда приписать вперед номера цифру 1, если на другие то 6.
пробовала через if, но не получается добавиться больше чем одну цифру

Автор - irenatu83
Дата добавления - 25.09.2022 в 16:59
scriptapplications Дата: Воскресенье, 25.09.2022, 17:15 | Сообщение № 2
Группа: Проверенные
Ранг: Участник
Сообщений: 64
Репутация: 12 ±
Замечаний: 0% ±

irenatu83, для номера в ячейке A2 попробуйте так
Код
=ЕСЛИ(НАЙТИ(ПСТР(A2;1;1);"3579012468")<5;1;6)&A2

а дальше растяните

или так
Код
=ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ(ПСТР(A2;1;1);"3579");1);6)&A2

К сообщению приложен файл: 8934804.png(29.5 Kb) · 3726024.png(28.6 Kb)


Сообщение отредактировал scriptapplications - Воскресенье, 25.09.2022, 18:38
 
Ответить
Сообщениеirenatu83, для номера в ячейке A2 попробуйте так
Код
=ЕСЛИ(НАЙТИ(ПСТР(A2;1;1);"3579012468")<5;1;6)&A2

а дальше растяните

или так
Код
=ЕСЛИОШИБКА(ЕСЛИ(НАЙТИ(ПСТР(A2;1;1);"3579");1);6)&A2


Автор - scriptapplications
Дата добавления - 25.09.2022 в 17:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » добавление цифры в номер (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!