Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти Сб и выдать какая она по счету - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти Сб и выдать какая она по счету (Формулы/Formulas)
Найти Сб и выдать какая она по счету
galemovivan Дата: Среда, 28.09.2022, 23:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте,подскажите пожалуста,как найти в данном виде таблицы все субботы и вывести в ячейку первую(вторую или n-ную) субботу по счету???
К сообщению приложен файл: 9451109.jpg(47.8 Kb)


Сообщение отредактировал galemovivan - Среда, 28.09.2022, 23:28
 
Ответить
СообщениеЗдравствуйте,подскажите пожалуста,как найти в данном виде таблицы все субботы и вывести в ячейку первую(вторую или n-ную) субботу по счету???

Автор - galemovivan
Дата добавления - 28.09.2022 в 23:23
Serge_007 Дата: Четверг, 29.09.2022, 00:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте

как найти в данном виде таблицы все субботы
В данном виде - только визуально
Формулы Excel не работают в картинках, читайте правила форума


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

как найти в данном виде таблицы все субботы
В данном виде - только визуально
Формулы Excel не работают в картинках, читайте правила форума

Автор - Serge_007
Дата добавления - 29.09.2022 в 00:02
Gustav Дата: Четверг, 29.09.2022, 02:09 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
"Калькулятор" - без линейки дней месяца. В ячейках A1:A4 - числа-параметры:
A1: 2022 - год
A2: 10 - месяц (1-12)
A3: 6 - день недели (1-7)
A4: 2 - какой по счету выдать?
В ячейке A5 - формула массива (Ctrl+Shift+Enter):
Код
=ИНДЕКС(ДАТА(A1;A2;СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0)))));
ПОИСКПОЗ(A4&"_"&A3;
ОТБР((СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0))))-1)/7)+1
&"_"&
ДЕНЬНЕД(ДАТА(A1;A2;СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0)))));2);0))
Результат при указанных параметрах: 08.10.2022

P.S. Если же допустимо (не страшно), что какие-то N-ые дни чуть-чуть "залезут" в следующий месяц, то можно длину проверяемого месяца принять постоянной и равной всегда 31 дню. В этом случае формула значительно упрощается:
Код
=ИНДЕКС(ДАТА(A1;A2;СТРОКА(1:31));
ПОИСКПОЗ(A4&"_"&A3;
ОТБР((СТРОКА(1:31)-1)/7)+1
&"_"&
ДЕНЬНЕД(ДАТА(A1;A2;СТРОКА(1:31));2);0))


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 29.09.2022, 02:30
 
Ответить
Сообщение"Калькулятор" - без линейки дней месяца. В ячейках A1:A4 - числа-параметры:
A1: 2022 - год
A2: 10 - месяц (1-12)
A3: 6 - день недели (1-7)
A4: 2 - какой по счету выдать?
В ячейке A5 - формула массива (Ctrl+Shift+Enter):
Код
=ИНДЕКС(ДАТА(A1;A2;СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0)))));
ПОИСКПОЗ(A4&"_"&A3;
ОТБР((СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0))))-1)/7)+1
&"_"&
ДЕНЬНЕД(ДАТА(A1;A2;СТРОКА(ДВССЫЛ("1:"&ДЕНЬ(КОНМЕСЯЦА(ДАТА(A1;A2;1);0)))));2);0))
Результат при указанных параметрах: 08.10.2022

P.S. Если же допустимо (не страшно), что какие-то N-ые дни чуть-чуть "залезут" в следующий месяц, то можно длину проверяемого месяца принять постоянной и равной всегда 31 дню. В этом случае формула значительно упрощается:
Код
=ИНДЕКС(ДАТА(A1;A2;СТРОКА(1:31));
ПОИСКПОЗ(A4&"_"&A3;
ОТБР((СТРОКА(1:31)-1)/7)+1
&"_"&
ДЕНЬНЕД(ДАТА(A1;A2;СТРОКА(1:31));2);0))

Автор - Gustav
Дата добавления - 29.09.2022 в 02:09
scriptapplications Дата: Четверг, 29.09.2022, 08:40 | Сообщение № 4
Группа: Проверенные
Ранг: Участник
Сообщений: 64
Репутация: 12 ±
Замечаний: 0% ±

galemovivan, считаем, что строка "дни недели" начинается с A2, а столбец чисел суббот начинается с ячейки AF2 и значения в строках 1 и 2 не содержат ошибок.
Запишите следующую формулу в AF2 и растяните вниз на все нужные строки:
Код
=8-ПОИСКПОЗ($A$2;{"вс";"пн";"вт";"ср";"чт";"пт";"сб"};0)+ЦЕЛОЕ(СТРОКА()-СТРОКА($AF$2))*7


Сообщение отредактировал scriptapplications - Четверг, 29.09.2022, 08:51
 
Ответить
Сообщениеgalemovivan, считаем, что строка "дни недели" начинается с A2, а столбец чисел суббот начинается с ячейки AF2 и значения в строках 1 и 2 не содержат ошибок.
Запишите следующую формулу в AF2 и растяните вниз на все нужные строки:
Код
=8-ПОИСКПОЗ($A$2;{"вс";"пн";"вт";"ср";"чт";"пт";"сб"};0)+ЦЕЛОЕ(СТРОКА()-СТРОКА($AF$2))*7

Автор - scriptapplications
Дата добавления - 29.09.2022 в 08:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти Сб и выдать какая она по счету (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!