Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить два столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить два столбца (Формулы/Formulas)
Сравнить два столбца
DAUR Дата: Вторник, 11.10.2022, 15:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Здраствуйте

Помогите пожалуйста сравнить два столбца с данными и убрать дубликаты при условии что коды в ячейках А и С совпадают
Например
В столбце А код 1006 два раза с серийными номерами Tets7 и Tets6 в столбце В
Тогда когда в столбце С код 1006 один раз с кодом Tets7 в столбце D
Необходима формула которая бы сравнила эти столбцы и удалила бы дублирующие серийные номера для каждого кода

Заранее благодарю
К сообщению приложен файл: New_Microsoft_E.xlsx(11.3 Kb)
 
Ответить
СообщениеЗдраствуйте

Помогите пожалуйста сравнить два столбца с данными и убрать дубликаты при условии что коды в ячейках А и С совпадают
Например
В столбце А код 1006 два раза с серийными номерами Tets7 и Tets6 в столбце В
Тогда когда в столбце С код 1006 один раз с кодом Tets7 в столбце D
Необходима формула которая бы сравнила эти столбцы и удалила бы дублирующие серийные номера для каждого кода

Заранее благодарю

Автор - DAUR
Дата добавления - 11.10.2022 в 15:49
_Boroda_ Дата: Вторник, 11.10.2022, 16:11 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(($B$3:$B$99<>"")*ЕНД(ПОИСКПОЗ($A$3:$A$99&$B$3:$B$99;$C$3:$C$99&$D$3:$D$99;));СТРОКА($3:$99));СТРОКА(I1)));"")
К сообщению приложен файл: 8287624.xlsx(12.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(($B$3:$B$99<>"")*ЕНД(ПОИСКПОЗ($A$3:$A$99&$B$3:$B$99;$C$3:$C$99&$D$3:$D$99;));СТРОКА($3:$99));СТРОКА(I1)));"")

Автор - _Boroda_
Дата добавления - 11.10.2022 в 16:11
DAUR Дата: Среда, 12.10.2022, 08:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_,
Спасибо огромное
Не сочтите за наглость сможите помочь с вычетанием столбца при условии
В столбце А коды товара в В - количество проданных а в D остаток на складе
Необходима формула чтобы вычитала из количества на складе количество проданных только при условии что коды совпадают
то есть чтобы вычитала код 1001 от кода 1001 и так далее

Спасибо еще раз
К сообщению приложен файл: 5430064.xlsx(10.4 Kb)
 
Ответить
Сообщение_Boroda_,
Спасибо огромное
Не сочтите за наглость сможите помочь с вычетанием столбца при условии
В столбце А коды товара в В - количество проданных а в D остаток на складе
Необходима формула чтобы вычитала из количества на складе количество проданных только при условии что коды совпадают
то есть чтобы вычитала код 1001 от кода 1001 и так далее

Спасибо еще раз

Автор - DAUR
Дата добавления - 12.10.2022 в 08:38
_Boroda_ Дата: Среда, 12.10.2022, 09:27 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А что это за странный файл приложен? вот в предыдущем все хорошо - как есть / как надо. А в это что?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА что это за странный файл приложен? вот в предыдущем все хорошо - как есть / как надо. А в это что?

Автор - _Boroda_
Дата добавления - 12.10.2022 в 09:27
DAUR Дата: Среда, 12.10.2022, 10:42 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_,

Упс прошу прощения
нужно как то посторить формулу схожую на суммесли но только для вычитания
 
Ответить
Сообщение_Boroda_,

Упс прошу прощения
нужно как то посторить формулу схожую на суммесли но только для вычитания

Автор - DAUR
Дата добавления - 12.10.2022 в 10:42
_Boroda_ Дата: Среда, 12.10.2022, 10:56 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Файл-то приложите нормальный. Вручную сделайте так, как нужно, чтобы было


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФайл-то приложите нормальный. Вручную сделайте так, как нужно, чтобы было

Автор - _Boroda_
Дата добавления - 12.10.2022 в 10:56
DAUR Дата: Среда, 12.10.2022, 11:17 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_,

Прошу прощения я сам ступил
Когда вам написал то нашел решение - просто на минус один умножил и получилось вычетание ))))
Все равно спасибо вам за помощь
 
Ответить
Сообщение_Boroda_,

Прошу прощения я сам ступил
Когда вам написал то нашел решение - просто на минус один умножил и получилось вычетание ))))
Все равно спасибо вам за помощь

Автор - DAUR
Дата добавления - 12.10.2022 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить два столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!