Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула вывода фамилий из графика отпусков по месяцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула вывода фамилий из графика отпусков по месяцам (Формулы/Formulas)
Формула вывода фамилий из графика отпусков по месяцам
lancaster Дата: Вторник, 18.10.2022, 05:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Прошу помощи в написании формулы - дан график отпусков с фамилиями и месяцами, сам отпуск проставляется символом (или текстом) на пересечении фамилии и месяца. Нужно собрать таблицу с 12 столбцами месяцев, чтоб в строках чтоб были фамилии отпускников за тот или иной месяц. Отпусков у одной фамилии может быть несколько. Знаю, что это ПОИСКПОЗ и ИНДЕКС, но сообразить синтаксис не могу. Решения из похожих тем по графику смен применить не смог. Заранее благодарен.
К сообщению приложен файл: 9333914.xlsx(9.2 Kb)
 
Ответить
СообщениеДобрый день. Прошу помощи в написании формулы - дан график отпусков с фамилиями и месяцами, сам отпуск проставляется символом (или текстом) на пересечении фамилии и месяца. Нужно собрать таблицу с 12 столбцами месяцев, чтоб в строках чтоб были фамилии отпускников за тот или иной месяц. Отпусков у одной фамилии может быть несколько. Знаю, что это ПОИСКПОЗ и ИНДЕКС, но сообразить синтаксис не могу. Решения из похожих тем по графику смен применить не смог. Заранее благодарен.

Автор - lancaster
Дата добавления - 18.10.2022 в 05:14
Pelena Дата: Вторник, 18.10.2022, 07:35 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18616
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$5;АГРЕГАТ(15;6;(СТРОКА($B$3:$B$5)-2)/(ИНДЕКС($C$3:$E$5;0;ПОИСКПОЗ(H$2;$C$2:$E$2;0))<>"");СТРОКА(A1)));"")
К сообщению приложен файл: 9823428.xlsx(10.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$5;АГРЕГАТ(15;6;(СТРОКА($B$3:$B$5)-2)/(ИНДЕКС($C$3:$E$5;0;ПОИСКПОЗ(H$2;$C$2:$E$2;0))<>"");СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 18.10.2022 в 07:35
Nic70y Дата: Вторник, 18.10.2022, 07:38 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7875
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
вариант массивной:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$99;НАИМЕНЬШИЙ(ЕСЛИ(C$3:C$99<>"";СТРОКА(C$3:C$99));СТРОКА(H1)));"")
К сообщению приложен файл: 32.xlsx(9.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант массивной:
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$99;НАИМЕНЬШИЙ(ЕСЛИ(C$3:C$99<>"";СТРОКА(C$3:C$99));СТРОКА(H1)));"")

Автор - Nic70y
Дата добавления - 18.10.2022 в 07:38
lancaster Дата: Вторник, 18.10.2022, 08:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо всем огромное!
Pelena, в рабочей таблице возвращает фамилии на 2 строки ниже правильных, не могу понять почему..


Сообщение отредактировал lancaster - Вторник, 18.10.2022, 08:14
 
Ответить
СообщениеСпасибо всем огромное!
Pelena, в рабочей таблице возвращает фамилии на 2 строки ниже правильных, не могу понять почему..

Автор - lancaster
Дата добавления - 18.10.2022 в 08:12
Pelena Дата: Вторник, 18.10.2022, 17:52 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18616
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Видимо, рабочая таблица начинается с другой строки.
Править надо в этом фрагменте (СТРОКА($B$3:$B$5)-2), если таблица с пятой строки, то -4, если с десятой строки, то -9


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВидимо, рабочая таблица начинается с другой строки.
Править надо в этом фрагменте (СТРОКА($B$3:$B$5)-2), если таблица с пятой строки, то -4, если с десятой строки, то -9

Автор - Pelena
Дата добавления - 18.10.2022 в 17:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула вывода фамилий из графика отпусков по месяцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!